Jump to content


Photo
- - - - -

How to change non-native resolution behavior?


  • Please log in to reply
4 replies to this topic

#1 VuDu

VuDu

    Beginner

  • Members
  • 7 posts
  • Country:Portugal

  • Brand:Asus
  • Model:A6Vc
  • Resolution:1280x800 (WXGA)
  • Operating System:XP Pro SP2

Posted 01 January 2007 - 02:29 PM

Hi there,

I know this is possible to do under nVidia's Control Panel on WIndows but I'd like to know if there's some other way to do it, like editing the graphics card BIOS or something...
The default on my laptop is stretching to fill the whole screen, but I hate it when things get wider on lower resolutions so I'd really like to know if it's possible to do it on any other way.
I use Linux too and since there's no "nVidia Control Panel" there, I can't seem to find out how to change that behavior.

Thanks.

Edited by VuDu, 01 January 2007 - 02:31 PM.


#2 Fabrice Roux

Fabrice Roux

    Guest hunter

  • Retired Moderators
  • PipPipPipPipPipPip
  • 2,067 posts
  • Country:France

  • Brand:Dell
  • Model:Inspiron 9300
  • Resolution:1920x1200 (WUXGA)
  • Video Card:(00C8) GeForce Go 6800
  • SUBSYS:019C1028
  • Operating System:XP Pro SP2

Posted 01 January 2007 - 03:22 PM

The last time I installed a nVidia driver 96.xx the nVidia setting apps was available... but I can't say if the equivalent of the Digital flat panel tab is available in Linux drivers.

#3 Fabrice Roux

Fabrice Roux

    Guest hunter

  • Retired Moderators
  • PipPipPipPipPipPip
  • 2,067 posts
  • Country:France

  • Brand:Dell
  • Model:Inspiron 9300
  • Resolution:1920x1200 (WUXGA)
  • Video Card:(00C8) GeForce Go 6800
  • SUBSYS:019C1028
  • Operating System:XP Pro SP2

Posted 01 January 2007 - 04:27 PM

I just logged on my Ubuntu HDD... with the beta driver 96.25... or should I call it 1.9625.

Using the nVidia installer, I have the "Nvidia X server settings" in my System tools. The scaling is there under GPU 0 / DFP 0.

#4 VuDu

VuDu

    Beginner

  • Members
  • 7 posts
  • Country:Portugal

  • Brand:Asus
  • Model:A6Vc
  • Resolution:1280x800 (WXGA)
  • Operating System:XP Pro SP2

Posted 02 January 2007 - 07:00 AM

Though I didn't have the shortcut, I managed to get there running nvidia-settings on a terminal.
It worked! :)
Thanks for you help, but if someone knows a way to change that, making "Centered" to be the default action, I'd really appreciate that.
For example I have some friends that have laptops with other video cards and some have Centered and others have Stretched, so... if possible, I'd like to know if it was possible to change the hardware's default setting :)

Edited by VuDu, 02 January 2007 - 07:01 AM.


#5 Fabrice Roux

Fabrice Roux

    Guest hunter

  • Retired Moderators
  • PipPipPipPipPipPip
  • 2,067 posts
  • Country:France

  • Brand:Dell
  • Model:Inspiron 9300
  • Resolution:1920x1200 (WUXGA)
  • Video Card:(00C8) GeForce Go 6800
  • SUBSYS:019C1028
  • Operating System:XP Pro SP2

Posted 02 January 2007 - 09:34 AM

Did you go to the page I pointed you? You have 3 main options:
  • Display adapter scaling, the default behaviour that fills the screen with the image. (no black bars, image distortion)
  • Centered. Probably the one you want. (black frame around resolutions smaller than your native resolution)
  • Fixed aspect ration scaling. The one I use, so my games are not distorded, I get black bars on the side if the aspect ratio is not matching my screen.