Jump to content


Photo
- - - - -

Forceware X 100.30 is out (finally)


  • This topic is locked This topic is locked
2 replies to this topic

#1 mobilenvidia

mobilenvidia

    Smeg Head

  • Admin
  • 14,639 posts
  • Country:New Zealand

  • Brand:Dell
  • Model:Latitude D820
  • Resolution:1920x1200 (WUXGA)
  • Video Card:(01D8) GeForce Go 7400 / Quadro NVS 120M
  • Operating System:Win7 Ultimate x64

Posted 16 January 2007 - 05:02 AM

The most anticipated driver ever has finally been released/leaked or what ever you may like to call it.
8800 Users can now rejoice in finally having support in Vista which is not even released yet.
I wonder if this or a slightly later build will be included with Vista or will become a Windows Update Download.

I've tested the x64 version of this driver for a while now and am not too impressed with them on my go7900 GS (GTX BIOS modded).
The Control Panel is very lacking in any usability.

There is no:
Powermizer page
Resolution page
TV control page
Overlay page

Control Panel takes ages to pop up. (a another install of driver has made this shorter, but still takes ages)
Resolution always resorts to 1024x768 after a Standby/Resume.

It does have:
Rotate Page
Colour Page
Display Configuration page (Dualview Clone etc.)
3D Settings
Image settings

Now that the x64 version and nTune only work with x86 there is of course no Overclock page :)
There are good news though: this driver at least detects my LCD TV via HDMI (DVI) with it's proper name, 95 series drivers don't.
But some small issues still exist here as well, the TV MUST be selected first, then LCD panel else the TV just displays a blank page.

[Version]
Signature   = "$Windows NT$"
Provider	= %NVIDIA%
ClassGUID   = {4D36E968-E325-11CE-BFC1-08002BE10318}
Class[tab][/tab]  = Display
CatalogFile = NV_DISP.CAT
DriverVer   = 12/14/2006, 7.15.11.0030

This driver in it's original state is for 8800 series desktop GPUs only
Also there is no SLI support yet in Vista, but at least your have some support now.

A modded INF (supplied below) is needed unless you have a 8800 GPU.

Right, you're probably thinking why all this jabbering... where's the driver?

Links Won't work till MS releases drivers.

For 32bit Driver, modded INF and feedback head on over HERE.

For 64bit Driver, modded INF and feedback head on over HERE.


Feedback as usual is encouraged.

[UPDATE]
It looks like these are doing really well for 8800 owners, with most things working as they should and even decent benchies as well.
There is even a report that the old control panel is back (I doubt this somehow, but who knows, would be nice though)
Some non 8800 folk also are having better luck with these than I am.
Laptop owner feedback is encouraged on these

[UPDATE]We've had a letter from Microsoft asking to remove the links from our website.
I have done this, to keep relations with Microsoft intact, not that there ever has been a relationship.
But I don't want to rock the boat.

Here is what we received:

To whom it may concern,

It’s been called to our attention that your site has posted proprietary property from Microsoft and NVIDIA for public use and we would appreciate it if you removed it immediately.

The property in question is the ForceWare Vista 100.30 (GeForce 8800) x64 and ForceWare Vista 100.30 (GeForce 8800) x86 drivers.

Please remove the links to these drivers or we will be forced to elevate this situation to Microsoft’s legal department.

Thank you,

George Menzel, Lead Program Manager, Microsoft Corporation
Derek Perez, Director of Public Relations, NVIDIA


The drivers will obviously be available in many other places other than here.
Not sure why MS has taken this stance nearly a week after they were released by us.
The Horse has bolted has had babies who now have also bolted.
Never mind, we meant no harm in releasing these, and I tink the release has done much good especially for the 8800 owners.

Hopefully MS will reverse it's stance, but in the mean time the 2 x 100.30 threads have been removed :)


#2 Stianu89

Stianu89

    Novice

  • Members
  • Pip
  • 15 posts
  • Country:Norway

  • Brand:AOpen
  • Model:1559
  • Resolution:1400x1050 (SXGA+)
  • Video Card:(0148) GeForce Go 6600
  • Operating System:Vista Ultimate x86

Posted 16 January 2007 - 02:45 PM

I just have a question, does this driver work with gf go 6600 with the modded inf?

#3 mobilenvidia

mobilenvidia

    Smeg Head

  • Admin
  • 14,639 posts
  • Country:New Zealand

  • Brand:Dell
  • Model:Latitude D820
  • Resolution:1920x1200 (WUXGA)
  • Video Card:(01D8) GeForce Go 7400 / Quadro NVS 120M
  • Operating System:Win7 Ultimate x64

Posted 16 January 2007 - 05:21 PM

It might, Vista is a strange tempremental OS, the support is in the INF for your GPU