Compal FL90 BIOS

75 posts in this topic

Posted · Report post

Hey guys...

Any new releases? I was wondering if you had any success about eneabling VT and DEP...

Share this post


Link to post
Share on other sites

Posted · Report post

I LOVE you! :)

I've been having a pure nightmare here with no end in sight trying to get the BIOS flashed. This just worked, no stress. You are doing the internet a huge favour here :)

Share this post


Link to post
Share on other sites

Posted · Report post

Wow lol nicely done. I was searching for newer BIOS, but this is even better because I didn't know how to install, tnx.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

I've flashed the 1.19, VT works, you have to load bios default setting. But IT seems to be very slow. I'm waiting for 2.0 bios and hope win 2008 hyper V will work faster.

Hey guys...

Any new releases? I was wondering if you had any success about eneabling VT and DEP...

Share this post


Link to post
Share on other sites

Posted · Report post

I did back to 1.18 BIOS because after installing newest updates for WinXP PRO (with SP3) the laptop goes unstable (& freeze when i left it on it's own for longer moment, so when i back it's dead and only hard reset helps, but mouse cursor is still working. I think something that wake him up has been changed in some winxp update & it's not longer works with 1.19 as it should).

well when i back to 1.18 VT works great & there are no such freezing laptop problems :)

So everyone please back to 1.18 if u feel your laptop is unstable :)

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks Dude, nice job.

Plus, I can confirm it won't cause any trouble to a linux system.

Keep it up. :)

Share this post


Link to post
Share on other sites

Posted · Report post

Well AFAIK Compal will not release any newer BIOS for FL90 systems because it is no longer supported. Sorry guys. 1.19 (unstable) beta is last release, and i recommend using 1.18.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi, I flashed may compal fl90 with 1.19 which I found here and now my laptop turned to brick - it even does not start at all, just turns on power light and thats all. Is there some way to recover?

p.s.

previously was using bios 1.07 - had some issues with new RAM so decided to flash new bios

Share this post


Link to post
Share on other sites

Posted · Report post

artishox it is better to update BIOS version by version, 1.07 to 1.08, 1.08 to 1.09 etc.

It is also strange that your laptop do not start.

There is method to repair it. you just need USB floppy drive for that, empty floppy disk and old verion of BIOS.

Here are all the files that you will need for that and instructions: fl90tools.rar

Give it a try. Tell us if you made it :)

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hi,

Now is modded fl90 1.18 bios for windows 7 slic 2.1

fl90 1.18 slic 2.1

BTW. How shoud i make to flash 1.18 bios to slic 2.0 1.18?

Edited by 00raq00

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

Now is modded fl90 1.18 bios for windows 7 slic 2.1

fl90 1.18 slic 2.1

BTW. How shoud i make to flash 1.18 bios to slic 2.0 1.18?

The instructions are the same like for standard BIOS from compal site.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

After using your bios iso my compal wanted password to start up. Can someone help ?

Share this post


Link to post
Share on other sites

Posted · Report post

Hi guys.

Thanks a lot for the update.

I wanted to give the Windows 7 a chance to impress me when I discovered a Code 12 issue on my graphic card.

After an n update v1.19 everything works like a charm. Thanks again

Regards from Denmark

Share this post


Link to post
Share on other sites

Posted · Report post

Hey guys a little help please!!!i downloaded this modded bios v1.18 with levono slic 2.1 but when i tried to activate it, it just doesn't work...

Please if anyone has succesfully installed a bios with slic 2.1 and activate it post the bios he used or give us a tutorial..Please HELPPPPPPPPPPPPPPP

Share this post


Link to post
Share on other sites

Posted · Report post

Had problem with ram and win7 at version 1.07. (when I put 3GB, windows had some problem with graphics and directx)

After update to 1.19 everything works just fine! :)

Thanks a lot! :)

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hi,

After using your bios iso my compal wanted password to start up. Can someone help ?

Impossible, BIOS files do not have password inside (password is saved in CMOS not in BIOS).

And for anyone else, please use 1.18 instead of 1.19. There are some problems with 1.19.

Edited by Nicram

Share this post


Link to post
Share on other sites

Posted · Report post

Any news about modded bios with slic 2.1 ??????

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I do not plan releasing modded BIOS as .iso image because it "may be" not stable as original version.

Edited by Nicram

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

So guys here is a modded version of compal bios with Alienware SLIC 2.1

Just burn the iso, boot it, and then make right choices...

Sorry link removed cause installer seem to have problems!!!

Edited by ribben

Share this post


Link to post
Share on other sites

Posted · Report post

hi :)

Hope you can help me

(sorry for bad english) german speak

I have a Notebook:

Nexoc Osiris E619

Mobile Dual Core2 Duo T9300, 2600MHz ( 13x 200 )

Motherboardname: Compal IFL90

CPU Bezeichnung: Penryn

Motherboard Cipsatz: Intel Crestine-PM PM965

Bios Typ: Phönix 11/06/07 Ver. 1.14

I will upgrade the Bios of vers. 1.18

The link to

BIOS v1.18 recommended version:

http://www.itos.pl/d...d/compal118.rar

http://www.marcinwilk.eu/compal118.rar

is working

But i can not unzip with winrar:

The Message: ! C:\compal118.rar: Ungültige oder zerstörte Authentizitätsinformationen. ?

Hope you can help me :)

Many thx

denny

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

It looks like Your file is broken, try to download again, from other source maybe.

Another problem may be old winrar bersion. Try to use the newest.

Edited by Nicram

Share this post


Link to post
Share on other sites

Posted · Report post

It is little hard to update BIOS in Compal, because we need to boot in DOS mode & then do it.

So i prepared CD image in .iso format, so anyone can record it & start computer with such CD.

It will work automatically then ;-)

http://www.marcinwilk.eu/compal.rar

UPDATE!!!

BIOS version 1,13. Here is link to my package that automatically change BIOS, that uses today released BIOS v1.13 (10-27-2007):

http://www.marcinwilk.eu/compal113.rar

http://www.itos.asia/download/compal113.rar

BIOS v1.16:

http://www.marcinwilk.eu/compal116.rar

http://www.itos.asia/download/compal116.rar

BIOS v1.18 recommended version:

http://www.marcinwilk.eu/compal118.rar

http://www.itos.asia/download/compal118.rar

BIOS v1.19 (newest 08-06-2008 - not recommended version, got some problems)

http://www.marcinwilk.eu/compal119.rar

http://www.itos.asia/download/compal119.rar

can i add different gfx card from 8600m gt 512mb to geforce 9300m gs 512mb, 1.8 bios working fine from 1.1 thanks loads!

Share this post


Link to post
Share on other sites

Posted · Report post

BUMP

ive recently come into 2 compal fl90s both with bad 8600 gt cards... ive seen everything avalible for the compal fl90/ifl90, sager np2090... im aware that the easy fix is to get the ati card... but im looking into working on this http://www.ebay.com/itm/251074865580?ssPageName=STRK:MEWAX:IT&_trksid=p3984.m1438.l2649 this is a 9300/9400 gs but modeled for a fl90...

 

ive not done ANYTHING with the laptops as i only want to have to open either of them once...

 

also im wondering about using the jhl model 8600 gt seeing as how its "suppossedly" the redone chispet and pcb which is to be less faulty (going on the fact the the jhl models where released about 1yr after the i/fl)... 

http://www.ebay.com/itm/130782255219?ssPageName=STRK:MEWAX:IT&_trksid=p3984.m1438.l2649

 

any thoughts... please respond soon... thank you

Share this post


Link to post
Share on other sites

Posted · Report post

hello

 

can anyone upload 1.18 update all the links are dead

Share this post


Link to post
Share on other sites

Posted · Report post

hello

 

can anyone upload 1.18 update all the links are dead

Links are working all the time. Which one are the ones that you got problems with?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now