Latest Sigmatel / IDT Modded Drivers for Win 7 and Vista

500 posts in this topic

Posted

Sigmatel / IDT Modded Drivers

Version 6.10.0.6277 DriverVer=04/07/2010,6.10.0.6277 Vista/Windows 7 x32/x64

Version 6.10.6263.0 DriverVer=12/15/2009,6.10.6263.0 Vista/Windows 7 x32/x64

Version 6.10.6255.0 DriverVer=11/06/2009,6.10.0.6255 Vista/Windows 7 x32/x64

Version 6.10.6233.0 DriverVer=08/26/2009,6.10.0.6233 Vista/Windows 7 x32/x64

Version 6.10.6187.0 DriverVer=04/09/2009,6.10.0.6187 Vista/Windows 7 x32/x64

Version 6.10.20001.0 DriverVer=03/012/2009,6.10.0.20001 Vista/Windows 7 x32/x64

Version 6.10.6162.3 DriverVer=03/06/2009,6.10.0.6162 Vista/Windows 7 x32/x64

Version 6.10.6162.0 DriverVer=03/02/2009,6.10.6162.0 Vista/Windows 7 x32/x64

Version 6.10.6159.0 DriverVer=02/23/2009,6.10.6159.0 Vista/Windows 7 x32/x64

IDT® HD Audio Driver [Formerly SigmaTel® HD Audio Driver]

=============================================================

Un-installation instructions

============================

If upgrading from previous IDT or SigmaTel driver, uninstall the original driver before running setup.

+To uninstall in Windows XP 32 and 64:

--------------------------------------

Go to "Start", "Control Panel", "Add or Remove Programs", select IDT and/or Sigmatel driver and "Remove".

+To uninstall in Windows Vista 32 and 64:

-----------------------------------------

Go to "Start", "Control Panel", "Programs and Features", select IDT and/or Sigmatel driver and "Uninstall".

Installation of new driver

==========================

(Typical user) To install using the Wizard, run setup.exe from the DISK1 folder, reboot if required.

+(Advanced user) INF installation with Windows XP:

--------------------------------------------------

1. Go to "Control Panel", "System", Hardware tab - "Device Manager", under Sound, video and game controllers, right-click High Definition Audio CODEC and select "Update Driver..."

2. Choose "Install from a list or specific location (Advanced)" and choose "Next".

3. Check the box "Include this location in the search:" and browse to DISK1\WDM\WinXP folder from the driver package and choose "Next".

4. XP will now install the audio driver from the INF file.

+(Advanced user) INF installation with Windows Vista:

-----------------------------------------------------

1. Go to "Control Panel", "System", "Device Manager" on the left side, under Sound, video and game controllers, right-click High Definition Audio CODEC and select "Update Driver Software".

2. Select "Browse my computer for driver software".

3. Navigate to the WDM folder located in the DISK1 folder and choose "Next". 4. Vista will now install the audio driver from the INF file.

Thanks,

IDT PC Audio Team

What may need to happen is in future release you may need to add a certain 'Pin' section to the INI.

This section in all INI but is device/model specific.

This tells the driver what is attached to the machine, ie Speakers, Speaker/HP combined, lineout, linein, SPDIF, HDMI, MICs etc etc

I have left this section blank hoping the driver would detect what was where.

What you will need to do is to find the original driver's INI file (WRTxxxxx.ini)

You will need to do a PCI_ID AND SUBSYS search for the exact INI. (the one below is for Dell i9400 and possibly others)

In this INI will be a section like this:

[HKR\Settings\pin]

[HKR\Settings\Pin\08]

CfgDflt = dword: 0x40C003FA

[HKR\Settings\Pin\09]

CfgDflt = dword: 0x01441340

[HKR\Settings\Pin\10]

CfgDflt = dword: 0x04A11020

Bias = hex: FF,04,02

AltCfg = hex: 20,10,81,04

[HKR\Settings\Pin\11]

CfgDflt = dword: 0x90170310

[HKR\Settings\Pin\12]

CfgDflt = dword: 0x40F003FC

[HKR\Settings\Pin\0D]

CfgDflt = dword: 0x0421121F

Action = hex: 81,0E

[HKR\Settings\Pin\0E]

CfgDflt = dword: 0x90170310

[HKR\Settings\Pin\0F]

CfgDflt = dword: 0x408003FB

Use a Text editor (like WOrdpad etc) to open both INI's (original OEM INI and my Modded one)

Copy and Paste the ORIGINAL section to the Modded INI between [HKR\Settings\GPIO] and [HKR\Settings\Connselector] or below [HKR\Settings\pin]

Save the newly modded INI.

Unistall the current driver USING control panels Uninstall (very important)

Now just run setup and hopefully the Audio/jacks will function as they should.

Please report back here if it does or doesn't

INF v1.001, WRT.ini v1.001

Initial release, driver based on MSUpdate release of 6159.

To do:

Enable Andrea Spatial/Directional Microphone features.

Equaliser integration in to Windows Sound Control panel.

INF v1.001, WRT.ini v1.002

Fixed Coinstaller on 6162.0 and 6162.3 (now used correct version)

INF v1.001, WRT.ini v1.004

Added Andrea Sound Processing

WRT.ini v1.005 Download this INI replace the older modded INI with this one.

Uninstall old drover then reinstall driver again (not doing this will not make changes)

Added

* Jack configuration

* Speaker Configuration now has Stereo, 3.1, Quadrophonic, 5.1 and 7.1

Some cosmetic changes

WRT.ini v1.006 Alpha Download this INI replace the older modded INI with this one.

Uninstall old drover then reinstall driver again (not doing this will not make changes)

This is a stipped back INI file to test if this is the cause of some Audio Chipsets not installing, please report back if this version works or not.

Andrea actually has 2 more features so something to work on with future builds.

WRT.ini v1.007 beta

Rebuilt INI

Added Beam forming to Andrea (missing from v1.004

Preference Page now has all known settings (Thanks to Chris)

I am much happier with this INI, and should be almost a final one.

Any one that can enable the hidden Doldy Pages, let me know.

WRT.ini v1.008 beta

Fixed 32bit Installer tweaks, 32bit OS's should reinstall with this version.

Lots of cosmetic changes.

No other changes.

INF v1.003, INI v1.010

Remade INI from 20001 versions and them also remade INF to enable features.

20001 does not seem tot support SRS, so this has no support for it .

Windows Sound control now has lots of options to play with including Dolby.

Links are in the above.

INF v1.004, INI v1.013

Adjusted INI to work with 6187

Added huge SRS section.

INF got Equalizer added from 20001 as to make the INI more manageable.

Windows Audio now has MonoMix feature added to volume page

INF v1.005, INI v1.018

New Control Panel is now default when clicking on icon in taskbar.

Reverting back to original INF setting from 6187

INF v1.006, INI v1.018

Going back to 1004 INF, this INF has the Windows Audio control support features

INF v1.006, INI v1.019

Removed \Filters\ section to help with installs of other OEM notebooks and allow easy replace of original sections

INF v1.009, INI v1.031 Applies only 6187

This is a Inspiron 9400/E1705 version of the INI, should work with other STAC9200 Notebooks.

Enabled the very elusive Subwoofer volume slider

Enabled the Minipanel (EQ) page

Reverted back to original Control Panel

Lots of other small changes, pretty well everything under the sun has been enabled that I know of.

INF v1.010, INI v1.031 Applies only 6187

Fixed tiny typo in x32 INF :)

INF v1.011, INI v1.031 Applies only to 6277

Made some improvements in the way with SRS, and to allow later versions and additional files.

For other IDT/ST owners you still need to replace the sections mentioned above for this driver to work.

Only i9400 owners get a free ride :)

Below are the pages features I can get (a selection, I can sometime get more with testing)

post-43-1241550050_thumb.jpg

post-43-1241550057_thumb.jpg

post-43-1241550066_thumb.jpg

post-43-1241550076_thumb.jpg

post-43-1241550084_thumb.jpg

post-43-1241550096_thumb.jpg

post-43-1241550103_thumb.jpg

post-43-1241550114_thumb.jpg

post-43-1241550123_thumb.jpg

post-43-1241550132_thumb.jpg

post-43-1241550147_thumb.jpg

post-43-1241550157_thumb.jpg

post-43-1242437127_thumb.jpg

Share this post


Link to post
Share on other sites

Posted

I've just tested the version 6.10.6162.0 on my Dell vostro 1700 (sigmatel HD9205) with vista 32bit

Control panel seems to work correctly but the internal speakers and the 3.5mm outputs give no sound at all

My internal and external (jack) micro also aren't recognised

Share this post


Link to post
Share on other sites

Posted

I've just tested the version 6.10.6162.0 on my Dell vostro 1700 (sigmatel HD9205) with vista 32bit

Control panel seems to work correctly but the internal speakers and the 3.5mm outputs give no sound at all

My internal and external (jack) micro also aren't recognised

Can you grab the PCI_ID and subsys numbers from the sound card in device properties ?

Will help me trace a solution.

Share this post


Link to post
Share on other sites

Posted

These is the ID:

HDAUDIO\FUNC_01&VEN_8384&DEV_76A0&SUBSYS_10280229&REV1002

Share this post


Link to post
Share on other sites

Posted

These is the ID:

HDAUDIO\FUNC_01&VEN_8384&DEV_76A0&SUBSYS_10280229&REV1002

Should work I have nearly the same chip but the 7690 both quite old as it was still Sigmatel.

Share this post


Link to post
Share on other sites

Posted

Version 6.10.6162.3 link missing or sending to 6.10.6162.2 which doesnt download.

Share this post


Link to post
Share on other sites

Posted

Any chance of Win XP version?

Share this post


Link to post
Share on other sites

Posted

Version 6.10.6162.3 link missing or sending to 6.10.6162.2 which doesnt download.

Linked fixed a type :)

Any chance of Win XP version?

I will if Vista turns out OK, otherwise could be wasting my time (I hope not)

Share this post


Link to post
Share on other sites

Posted (edited)

" You uninstalled the previous driver first ? " - yes. No audio playback

I try "a clean" install Version 6.10.6162.3 DriverVer=03/06/2009,6.10.0.6162 Vista/Windows 7 x32/x64

No audio playback.

my id

HDAUDIO\FUNC_01&VEN_111D&DEV_76B2&SUBSYS_103C30F4&REV_1003

HDAUDIO\FUNC_01&VEN_111D&DEV_76B2&SUBSYS_103C30F4.

Thank You for all of your work. :):)

Edited by warden

Share this post


Link to post
Share on other sites

Posted

DriverVer=03/06/2009,6.10.0.6162 Vista/Windows 7 x32/x64, Installs fine, but no sound via internal or headphones. Also it was odd to see that it detected "Dual Headphones" on my system.

This is on a Gateway P6831-FX

HDAUDIO\FUNC_01&VEN_111D&DEV_76B0&SUBSYS_107B0692&REV_1001

HDAUDIO\FUNC_01&VEN_111D&DEV_76B0&SUBSYS_107B0692

same as above, clean install.

Share this post


Link to post
Share on other sites

Posted

Just adding that these work on a Sigmatel based system. I'm surprised as I didn't think anything would work nicely for my XPS 420. :)

Vista x64, Dell XPS420 ( HDAUDIO\FUNC_01&VEN_8384&DEV_7618 ) :)

Now back to working on jack layout and features.

Share this post


Link to post
Share on other sites

Posted (edited)

Dell XPS m1530

sound oki through internal speakers

sound oki through first headphone jack

no sound htrough jack #2 for headphones

missing HDMI output in playback devices

HDAUDIO\FUNC_01&VEN_8384&DEV_7616&SUBSYS_1028022E&REV_1004

HDAUDIO\FUNC_01&VEN_8384&DEV_7616&SUBSYS_1028022E

Windows 7 64-bit 7077

Edited by bogdi1988

Share this post


Link to post
Share on other sites

Posted

6159 Jacks

6159.0_xps420.png

6162 Jacks

6162.3_xps420.png

Share this post


Link to post
Share on other sites

Posted

I keep getting a "404" error when trying to get to these files. Any ideas?

Thanks and later - Mike

Share this post


Link to post
Share on other sites

Posted

Should work I have nearly the same chip but the 7690 both quite old as it was still Sigmatel.

I've retested with the version Version 6.10.6162.3 and the internal speakers and the external audio jack is working :) , but there seems to be almost no amplification (the sound is really quiet)

Share this post


Link to post
Share on other sites

Posted

In dire need of these drivers for XP.

Share this post


Link to post
Share on other sites

Posted

I've just tested the version 6.10.6162.0 on my Dell vostro 1700 (sigmatel HD9205) with vista 32bit

Control panel seems to work correctly but the internal speakers and the 3.5mm outputs give no sound at all

My internal and external (jack) micro also aren't recognised

Same, no sound.

Share this post


Link to post
Share on other sites

Posted

Dell m1330 laptop....no sound through internal speakers....And when trying to configure speaker setup stereo is the only choice.....no 5.1 channel audio?

Share this post


Link to post
Share on other sites

Posted

Added Andrea Sound

Share this post


Link to post
Share on other sites

Posted

hi , Audio no work on windows vista 64 last version , Windows not iniciality problem Exclamation !

HDAUDIO\FUNC_01&VEN_8384&DEV_7627&SUBSYS_30D4103C&REV_1002

HDAUDIO\FUNC_01&VEN_8384&DEV_7627&SUBSYS_30D4103C

old's version no detect HP Full bast

Treble & bass not working

2 microphone integrated not work

Model is HP HDX 9450ES

grettings.

Share this post


Link to post
Share on other sites

Posted

Uploaded an updated INI v1.005

download this INI to save downloading driver again.

replace older modded INI

Uninstall old driver

Reinstall new driver.

Share this post


Link to post
Share on other sites

Posted

I get the dreaded Code 10 error with both driver versions and the new INF.

Share this post


Link to post
Share on other sites

Posted (edited)

no sound when i connect headphones to front jack.

Sony Vaio VGH-FE11H

thank you very much...

OS : Windows 7 build 7100

Edited by burakpadir

Share this post


Link to post
Share on other sites

Posted

Added v1.006 Aplha to start testing Chipset support.

Please report back if your Chipset now installs/works.

Share this post


Link to post
Share on other sites

Posted

Added v1.006 Aplha to start testing Chipset support.

Please report back if your Chipset now installs/works.

thanks , nice work sound spekaer and 2 microphones integrated , NOT Work HP full bass 3" Integrated on portatil HDX9450ES model

*** Posibles bugs

Panel idt sound configuration speakers test speaker NOt sound

Driver support only Stereo not select 3.1/cuadrofonico/5.1/7.1

Auriculars independent test speaker crash auto close

greetings

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now