Sign in to follow this  
Followers 0

Scrolling with Synaptics Touchpad

28 posts in this topic

Posted (edited)

If you have Synaptics drivers and suddenly scrolling stops working with your favourite browsers (mostly after updating drivers), read on.

First, try reinstalling Firefox or Opera. They will modify SynTPEnh.ini file located C:\Program Files\Synaptics\SynTP folder on install so it should work fine.

After reinstalling if you still have problems or do not want to reinstall them for any reason download this;

nvaio.cmd

unzip and copy the SynTPEnh.ini to C:\Program Files\Synaptics\SynTP folder replacing the old one then restart your computer.

If you are still having problems you can try using latest drivers here. There seems to be issues with some Synaptics Drivers (7.12.7, 7.13.0.1HP for example). If you are still having problems it is recommended to use Synaptics Drivers v7.10.8 to solve these issues. Download Synaptics Drivers 7.10.8 RC1 here.

Before changing drivers, uninstall previous one, restart then install new drivers.

SynTPEnh.zip

Edited by sn0wl

Share this post


Link to post
Share on other sites

Posted

I use the latest (original) drivers, and the only program where scrollings isn't working is firefox, isn't the problem with firefox and not with the synaptics drivers? I had this problem with the original, old (7.8.9) drivers too!

Share this post


Link to post
Share on other sites

Posted

I'm still researching but problem seems to be with drivers. Try installing the driver above and it should work fine. Please give feedback if you try.

Share this post


Link to post
Share on other sites

Posted

You are my hero, unzipped .ini file and it fixed Opera functionality! Woohoo!

Share this post


Link to post
Share on other sites

Posted

Oh great! sn0wl, that INI file that you have provided did job. Now virtually scrolling finally works in Firefox. (Although I don't see that scroll-bar graphic now that use to come up earlier on sliding the fingertip over the virtual-scrolling region.)

Synaptics Pointing Device Driver version: 8.2.4.0

Thank you very much!

Share this post


Link to post
Share on other sites

Posted

You Saved our time and made our life easier.

Thanks, the INI file works.

Share this post


Link to post
Share on other sites

Posted

If you have Synaptics drivers and suddenly scrolling stops working with your favourite browsers (mostly after updating drivers), read on.

First, try reinstalling Firefox or Opera. They will modify SynTPEnh.ini file located C:\Program Files\Synaptics\SynTP folder on install so it should work fine.

After reinstalling if you still have problems or do not want to reinstall them for any reason download this;

nvaio.cmd

unzip and copy the SynTPEnh.ini to C:\Program Files\Synaptics\SynTP folder replacing the old one then restart your computer.

If you are still having problems you can try using latest drivers here. There seems to be issues with some Synaptics Drivers (7.12.7, 7.13.0.1HP for example). If you are still having problems it is recommended to use Synaptics Drivers v7.10.8 to solve these issues. Download Synaptics Drivers 7.10.8 RC1 here.

Before changing drivers, uninstall previous one, restart then install new drivers.

you are the king.... I spent a day looking for an answer... and in 1min i did it with your solution.

Greetings from Switzerland

Share this post


Link to post
Share on other sites

Posted

i tried everything it still doesn't work, virtual scrolling works, but the scroll button on my acer still has problems.

Share this post


Link to post
Share on other sites

Posted

Scroll button is something different, you might need manufacturer's custom drivers for that. Anyway for best results, uninstall your previous driver, restart, install new one and restart again. You need to change settings in Synaptics control panel which is usually inside of mouse control panel.

Share this post


Link to post
Share on other sites

Posted

Oh great! sn0wl, that INI file that you have provided did job. Now virtually scrolling finally works in Firefox. (Although I don't see that scroll-bar graphic now that use to come up earlier on sliding the fingertip over the virtual-scrolling region.)Synaptics Pointing Device Driver version: 8.2.4.0

Thank you very much!

..........................

I've been trying to get rid of this little graphic under the arrow when I scroll... Can you help?

Thanks

Share this post


Link to post
Share on other sites

Posted

Hello All. I found that a spyware program called "SpyCatcher" was actually preventing virtual scrolling on my touch pad. I disabled, SpyCatcher, restarted, and voila.

Share this post


Link to post
Share on other sites

Posted

I have found the quickest fix for this bug, i made this myself took me alot of time of research to make this.

Open Notepad, copy and paste the following into it:

taskkill /im SynTPEnh.exe

START SynTPEnh.exe

Now save this as: Fix.bat

Copy this file into: c:\Program Files\Synaptics\SynTP

Create a sortcut for this file on your desktop, so everytime the sroll dont work just open that button it will fix it in 1 second. All it does basicly is kill the process of it and then restart it.

Hope this helps.

Thanks

Share this post


Link to post
Share on other sites

Posted

Thanks a million! i hated having to use ie on my new work laptop!

Share this post


Link to post
Share on other sites

Posted

So, basically, all you need for Virtual Scrolling to work with Opera is the codelines below added to the SynTPEnh.ini file in (usually C:\Program Files\Synaptics\SynTP).

I've just done this ...seem to remember having to do this years ago, but forgot with the new OS installation and seemingly old Synaptics drivers from Dell - v.5.7 according to the Title Bar of the Config App. I'm running Opera 9.25, but as we know, it's a Driver/Config issue

[Opera7]
WT = "*Opera*"
SF = 0x10000000
SF |= 0x00004000
[/codebox]

This has been placed at the top of the file in the attachment of the first post.

Then just open up [b]Task Manager[/b] and find [b]SynTPEnh.exe[/b] in the Processes Tab list of processes. Right Click on it and End Process.

Now restart the process by Double Clicking on [b]SynTPEnh.exe[/b] in the program folder.

...or use the Fix.bat file example in the posts above.

This method prevents loosing all your other settings you've made previously.

For those wanting to understand and learn what the fix is then the above info will help you and may even allow you to change it to fix other applications.

The [b][Opera7][/b] line is not actually important, as [Opera] works too.

The line [b]WT = "*Opera*"[/b] selects the executable based on it's Window Title. If you check further down in the .ini file, you'll see [Opera Browser] as shipped with the driver. This selects the executable based on the window title showing [i]anything[/i]Opera 5[i]anything[/i] - where the * character wildcards leading and trailing text. The reason Opera is broken is because Opera doesn't put the version number in the Window Title anymore - which is why the new WT = line takes anything before or after the word [b]Opera[/b].

As for the SF = and the SF |= (OR =) lines, I can't find anything that says for sure what it stands for or what the hex values mean, but one could suggest it stands for Sense Finger for the Virtual Scrolling/Scrolling Gesture feature of the touch pad driver as it senses how long the finger is on the pad and at which location (probably the Vertical and Horizontal virtual scroll regions).

Share this post


Link to post
Share on other sites

Posted

Additionally, I've found that if the Window Title is long - maybe a web page search result etc. - the driver has a limited string length to search on therefore the wildcard fails to work.

e.g. "Amazon.co.uk: Used and New: Keysonic Compact Notebook Layout Wireless 2.4Ghz Radio Frequency Keyboard With Integrated Touch... - Opera" fails to match. Actually the full title in the web page source is truncated by Opera.

( http://www.amazon.co.uk/gp/offer-listing/B...7074&sr=8-1 )

Internet Explorer still works with this page even though IE truncates the title more.

Maybe a driver update will fix this - I'm still using the v5.7 driver from Dell for this C610 laptop.

Share this post


Link to post
Share on other sites

Posted

I was pointed to this forum by Scrolling using Touchpad at the XYplorer forum, and based on the info given here, added the following to my INI file, which finally made vertical scrolling work on my Dell with a Synaptics pad, so just wanted to THANK y'all here for the tips! :) But horizontal scrolling still doesn't seem to work, however.

[XYplorer]

WT = "*XYplorer*"

SF = 0x10000000

SF |= 0x00004000

Share this post


Link to post
Share on other sites

Posted

3 lines of code and so much joy :)

Thanks averybody for you help :)

Greetings from Poland!!

Share this post


Link to post
Share on other sites

Posted

I stumbled on this thread in an endless circle of trying to fix Firefox scrolling issues.

Firefox boards always say "Just update your driver :) " and are otherwise utterly useless.

I tried that, I tried the SynTPEnh.ini file, I tried modding the file to look for the Window title, no dice.

However the oddest thing fixes the problem

taskkill /im SynTPEnh.exe

although it says "SUCCESS: The process "SynTPEnh.exe" with PID 3524 has been terminated."

the process still exists. However I stop getting the "scroll cursor" when I scroll, and suddenly scrolling works properly in all applications that didn't previously.

If I actually terminate SynTPEnh.exe (either taskkill /f or through task manager), all touchpad scrolling stops working.

I'm guessing taskkill is closing topmost window to politely request a termination, but somehow it keeps working.

So my trick is to add taskkill /im SynTPEnh.exe to windows startup.

WindowsXP SP3

Synaptics v10.2.4

cheers,

-TA

Share this post


Link to post
Share on other sites

Posted

I stumbled on this thread in an endless circle of trying to fix Firefox scrolling issues.

Firefox boards always say "Just update your driver :) " and are otherwise utterly useless.

I tried that, I tried the SynTPEnh.ini file, I tried modding the file to look for the Window title, no dice.

However the oddest thing fixes the problem

taskkill /im SynTPEnh.exe

although it says "SUCCESS: The process "SynTPEnh.exe" with PID 3524 has been terminated."

the process still exists. However I stop getting the "scroll cursor" when I scroll, and suddenly scrolling works properly in all applications that didn't previously.

If I actually terminate SynTPEnh.exe (either taskkill /f or through task manager), all touchpad scrolling stops working.

I'm guessing taskkill is closing topmost window to politely request a termination, but somehow it keeps working.

So my trick is to add taskkill /im SynTPEnh.exe to windows startup.

WindowsXP SP3

Synaptics v10.2.4

cheers,

-TA

Oh my, man you need to put this to Firefox forum or something, this worked like a charm... although I totally don't understand how this has worked...

Share this post


Link to post
Share on other sites

Posted

This exact same solution (taskkill /im SynTPEnh.exe) also solved the same scrolling problem on a Gateway with Synaptics V 12.2.4.1 on Vista SP2. With the same effect of SynTPEnh.exe process being in limbo (still existing, still providing scrolling services, but with no scroll cursor.

I have no idea why it works. I'm just happy that it does.

Share this post


Link to post
Share on other sites

Posted (edited)

Hi all

Tried all the above but still no joy on horizontal scrolling Opera. FF and IE work. Using the newest synaptics driver 14.0.3.

:)

Edited by gabore

Share this post


Link to post
Share on other sites

Posted

Hi all

Tried all the above but still no joy on vertical scrolling Opera. FF and IE work. Using the newest synaptics driver 14.0.3

:)

The newest synaptics driver is 15.1.9.0. You can get it here: http://station-drivers.com/telechargement/synaptics/Synaptics_touchpad_15.1.9.0(www.station-drivers.com).exe It might fix your problem.

Share this post


Link to post
Share on other sites

Posted (edited)

The newest synaptics driver is 15.1.9.0. You can get it here: http://station-drivers.com/telechargement/synaptics/Synaptics_touchpad_15.1.9.0(www.station-drivers.com).exe It might fix your problem.

Thanks for providing the fresh driver, but the issue still exists. I really think it's an Opera issue, cause the horizontal scrolling works in my other browsers. :)

Edited by gabore

Share this post


Link to post
Share on other sites

Posted (edited)

Thanks for providing the fresh driver, but the issue still exists. I really think it's an Opera issue, cause the horizontal scrolling works in my other browsers. :)

I've had this problem on my laptop, but with Firefox, for at least over a year now, and while finding sn0wl's method recently was a relief, it only would work temporarily, and then it would go back to not working. What I noticed was that if I closed Firefox, ran sn0wl's method, and then restarted Firefox, it would work again for a while, but then break again. It's great that it did something, but having to restart Firefox constantly was obviously not ideal. However, after trying practically everything, by way of dumb luck this week, I may have come across a fix that will work for people.

For the past two days, scrolling in Firefox with my touchpad has, amazingly, started working again. What did I do differently? Well, I did just recently install a new version of the Firefox trunk nightly, but I don't think that is it, because I do that all the time, and I don't think a new bug fix has been checked in or anything.

Instead, what I think it is is that a couple days ago, out of sheer dumb luck, I went into Mouse properties in Control Panel, clicked on the Wheel tab at the top, and then changed "The following number of lines at a time" from 3 to 1, and hit Apply. That's it!

Like I said, I can't confirm whether or not installing the latest Firefox trunk nightly after that may have had an impact as well, but I doubt it.

So, can anyone confirm whether this works for them or not?

Edit: False alarm. The problem for me is having a PDF open in a background tab. It's a reported bug in Firefox.

Edited by mmortal03

Share this post


Link to post
Share on other sites

Posted

I've had this problem on my laptop, but with Firefox, for at least over a year now, and while finding sn0wl's method recently was a relief, it only would work temporarily, and then it would go back to not working. What I noticed was that if I closed Firefox, ran sn0wl's method, and then restarted Firefox, it would work again for a while, but then break again. It's great that it did something, but having to restart Firefox constantly was obviously not ideal. However, after trying practically everything, by way of dumb luck this week, I may have come across a fix that will work for people.

For the past two days, scrolling in Firefox with my touchpad has, amazingly, started working again. What did I do differently? Well, I did just recently install a new version of the Firefox trunk nightly, but I don't think that is it, because I do that all the time, and I don't think a new bug fix has been checked in or anything.

Instead, what I think it is is that a couple days ago, out of sheer dumb luck, I went into Mouse properties in Control Panel, clicked on the Wheel tab at the top, and then changed "The following number of lines at a time" from 3 to 1, and hit Apply. That's it!

Like I said, I can't confirm whether or not installing the latest Firefox trunk nightly after that may have had an impact as well, but I doubt it.

So, can anyone confirm whether this works for them or not?

Well, now I am using my Ubuntu boot where I can't find this setting (even in g-conf editor), but will try this on Windows.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0