AGP FastWrite and SideBand Addressing (76.64)

4 posts in this topic

Posted

Hi all!

I've a Dell 5150 laptop, and this site is the best for my mobile graphics card.

I'm running on Gentoo Linux 2.6.11-r9 and i have this settings:

fuzzo@Dell5150 / $ cat /proc/driver/nvidia/registry

VideoMemoryTypeOverride: 1

EnableVia4x: 0

EnableALiAGP: 0

NvAGP: 1

ReqAGPRate: 7

EnableAGPSBA: 0

EnableAGPFW: 0

SoftEDIDs: 1

Mobile: 4294967295

ResmanDebugLevel: 4294967295

FlatPanelMode: 0

DevicesConnected: 0

VideoEnhancement: 0

RmLogonRC: 1

ModifyDeviceFiles: 1

DeviceFileUID: 0

DeviceFileGID: 0

DeviceFileMode: 438
This is the nvidia module parameter now active... Look at my system capabilities:
fuzzo@Dell5150 / $ cat /proc/driver/nvidia/agp/card

Fast Writes:     Supported

SBA:             Supported

AGP Rates:       4x 2x 1x

Registers:       0x1f000217:0x1f000104


fuzzo@Dell5150 / $ cat /proc/driver/nvidia/agp/host-bridge

Host Bridge:     Intel Corp. 82852/855GM Host Bridge

Fast Writes:     Supported

SBA:             Supported

AGP Rates:       4x 2x 1x

Registers:       0x1f000217:0x00000104
It says that i can enable FW and SBA :P but...
fuzzo@Dell5150 / $ cat /proc/driver/nvidia/agp/status

Status:          Enabled

Driver:          NVIDIA

AGP Rate:        4x

Fast Writes:     Disabled

SBA:             Disabled
This says that i use NVIDIA AGP driver (instead of kernel's AGPGART) with 4x speed, but without FW & SBA :) I tried to load module with:
NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1

to enable both features, but X server hangs and my display went "unreadable" :)

How i can activate FW and SBA without problems with X?

Thanks! :(

Share this post


Link to post
Share on other sites

Posted

Same laptop - same problem. Haven't found a solution yet.

Best regards

Lars

Share this post


Link to post
Share on other sites

Posted

Same laptop - same problem. Haven't found a solution yet.

Best regards

Lars

There is a file you can edit before compiling the driver to default most of those to the enabled position. As far as AGP goes, unless you have an AGP card in your laptop, you shouldn't be using the NvAGP driver. If you are using PCX/PCIe use the system driver but make sure the rest are enabled.

Also check your xorg.conf for redundant settings.

Share this post


Link to post
Share on other sites

Posted

SBA can make it unstable anyway, with practically no performance increase really, you should just leave it off.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now