Jump to content
LaptopVideo2Go Forums

GeForce4 420 Go 32M, W2K3, WoW

Guest TryTryAgain

Recommended Posts

Guest TryTryAgain

I've got a non-Toshiba laptop.

About a year ago, when trying to play some games on W2K, I went to nVidia support for help. Believe it or not, they literally told me to come to this site. I read a bunch of things (over and over, until it began to vaguely make sense to me) and successfully installed a driver. Games worked great, including WoW, and my default display was set to 1400 x 1050. Loved it.

I've since upgraded my laptop to W2K3 and WoW stopped working. I've played with 77.77, 84.56, 91.31, and a couple others I can't remember. I've been reading the forums and most of the 420 talk relates to Toshiba-specific issues. I've gone through the motion of uninstalling/reinstalling WoW as well as DirectX 9.0c. I've used some 'driver cleaner' software (via Google, as recommended on a hilarious post here).

My next step is to try 45.91. If it works, I'll try climbing my way back up.

It's been a trying time, but I had wanted to avoid asking for help until I felt I had tried several things and 'exhausted' my abilities. I think I have reached that point.

Can someone shove me in the right direction? (And what data would be helpful, if any? If it's anything not easily found, I might need to be told how to find it out. I'm no expert.)

Link to comment
Share on other sites

LOL it's shocking to hear that you have a non-Toshiba laptop. :)

Why did you chosed Windows Server 2003 over Windows XP? If it's the latest... you might want to try Vista since it's the newest. Please switch to XP... I doubt you bought the WS 2003 license anyway. :)

You might want to read the recommended driver FAQ. In your case the older driver will give the best performance. But you might need a 67.66 to get DirectX 9.0c software support.

Link to comment
Share on other sites

Guest TryTryAgain

Merci for the quick reply.

In my particular case, I do have need for this laptop to be a mobile server. XP just isn't an option. In fact, that's one of the reasons I clung to W2K for so long. Only a couple days ago did I finally take the plunge for W2K3 once I was satisfied things wouldn't be adversely impacted.

Of course, since it isn't rackmounted and attached to fiber does mean it spends a goodly amount of time not serving. During those times, all work and no play makes Jack a dull boy. Given that WoW is crack-like, I would prefer to be able to play again. :)

67.66 seemed like a choice, after reading that it was one of the first drivers that supported the latest DX. It installed just fine, but I continue to get the WoW warning about being unable to start up 3D acceleration, whereupon it lectures me to install 9.0c and update my video drivers. (45.91 wouldn't install at all, btw.)

If you're able to make any other suggestions, my addiction will help me find a way to try it...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...