Jump to content
LaptopVideo2Go Forums

Geforce 4 420 Go troubles


cwc

Recommended Posts

Hi all,

I've been trying to get my 420 Go working in my Sharp laptop. With the stock drivers (downloadable from www.sharpsystems.com), it works okay, however when I go to play certain games (usually requiring DX9+), various artifacts appear in the display.

I have tried using several different driver versions spanning from the 50s to 80s, with the same results. Windows loads normally, everything appears fine. Shortly after logging in, the screen flickers to black, and the display reappears with ridiculously abnormal coloring. I have tried taking screenshots of this behavior, but they come out fine.

I take this to mean there is some weird incompatibility between the newer drivers and my LCD display (as hooking up an external LCD works perfectly), but I am not all that knowledgable and that is just speculation on my part.

I can temporarily fix the colors by using NVRotate to flip the screen to 90 degrees and back, but if I fire up a game the coloration returns.

Has anyone experienced similar behaviour?

Link to comment
Share on other sites

try using the latest forceware drivers (91,31) and going into the hardware control panel and, after assuring that you do not have 2 drivers installed for the video card, make sure the monitor windows has detected is the one you are using (windows simply loves to use the wrong generic drivers).

if you can find your model on the driver list (you almost always can on suse linux :) ... i found a monitor from 1995 on there :) ) then use the closest generic to what ya got for an lcd because windows could also be detecting it as a generic crt instead of lcd

if all that don't work (newest forceware, original monitor drivers or closest generic) then you could go to the color settings in the nvidia control panel and fiddle with the many color adjustment options, or better yet, boot in safe mode and see if you have the problem, if so then check your monitor connection, if not, then restart ur comp and, right as the comp is logging in to windows, hit the control button (i think that is the rite key to hit, check nvidia control panel for startup bypass instructions) to skip loading the nvidia profile and load all default values

see if any of that works =)

Edit: the more i read your post, the more suspiciously the problem looks like your drivers using the wrong profile, try the bypass thing and if you cant get that towork try to change your monito's profile from in the nvidia control panel

if all else fails you can try running without drivers and simplu using the built in windows (xp i hope) ones ... *shudder*

Edited by compmaster
Link to comment
Share on other sites

Try uninstalling the current drivers, restarting your comp, installing 44.68, and restart agian.

Link to comment
Share on other sites

The GeForce 4 4x0 Go serie is DirectX 7 hardware... so if a game requires a hardware specific feature that only exists on a DirectX 9 class hardware whatever the driver you install you'll run into issues.

ps: read the recommended driver FAQ... it will show you what is missing in your GPU to run those games.

Link to comment
Share on other sites

As this is the one of the 2 (maybe 3) NV driven laptop SHARP has ever produced try using the search function in our forum to find similar users. Should not be hard to find. I remember at least one guy owning the RD10.

Also i assume there is an important driver setting missing for your card. To find the setting which is responisble is like searching for the needle in a hay.

SHARP has released only one driver for the RD10: v32.20 which is about 4 years old. Try using 46.11 another driver released from SHARP, but for Actius AL3 i think.

Also try upgrading the SIS AGP driver :) The original one is from 2002

EDIT:

Here are the other RD10 threads (not very helpful i have to admit):

http://forums.laptopvideo2go.com/index.php?showtopic=8921

http://forums.laptopvideo2go.com/index.php?showtopic=7783

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...