Jump to content
LaptopVideo2Go Forums

Geforce4 440 Go memory issues


llecount

Recommended Posts

Hello all, first time poster here on this forum.

I purchased a 64mb Geforce4 440 Go to upgrade the Geforce2 in my Inspiron 8200. I bought it from a seller on ebay who bought it new and couldn't get it to work with his laptop. So taking a risk, I picked it up cheap hoping to work some magic on it.

Upon installation and power up, my 8200's screen was littered with garbled latters and colored blocks, but the screen was still semi-readable even with all the distortion. I got in to the BIOS to make sure it recgonized the card, and sure enough it did as it showed Nvidia Geforce 4 440 Go 64mb.

SO in search for a fix for the screen distortion, I looked to Dell's website and found they had a BIOS update for the 440 Go. I downloaded that, transferred it to floppy (via my wife's Inspiron 8100!) and flashed the BIOS of the 440 Go. After the flash the distortion was gone and everything looked as it should until I went in to the BIOS again.. My 64mb card had somehow been degraded to a 32mb card after the flash! :)

Aside of the memory size problem, the card works beautifully. I can actually run UT24k now without any graphics problems, which is all I wanted it to do. Though it bugs me knowing that the card isn't performing at it's full potential and utilizing all 64mb of of it's memory. Does anyone know what could have possibly caused the memory problem, and a way of correcting it?

Additional info

VGA Bios version: 4.17.00.55

Device ID: 0174

Laptop BIOS: Latitude C840 A13 (flashed for use with the Latitude C/Dock II PDX) System BIOS was flashed AFTER I flashed the 440's BIOS.

Thanks!!

Edited by Bill
Link to comment
Share on other sites

I'm thinking there isn't much to do except to try reflashing it again with the correct VBIOS. (which could mess your card up again)

It kinda sounds like part of the graphics RAM is fried, which would explain why it didn't work before.

Some of these cards have been known to easily go bad.

Can't think of much else to say except you knew the card was broken when you got it.

Also, welcome to the forum! :) :)

Link to comment
Share on other sites

Thanks for the welcome!

I found BIOS version 04.17.00.55.B2 on Dell's website and decided to give that a shot.

Made the Dell bootable floppy, and then restarted the system. I didn't have my battery in when the system booted to the floppy, so the Dell flash utility didn't automatically load. I ran sysid.com at the prompt and got the following information:

PCI Device ID: 0714h

Memory Straps: 1101b

NV17m w/ 64mb of 4x32 Infineon Memory

Don't know if that helps any with diagnosing the problem, but thought I would post it anyway.

I put the battery in, and ran autoexec.bat. It went through the upgrade process successfully. I rebooted and went back in to the system BIOS only to find that it was still showing as a 32mb Card.

Are there any other BIOS revisions I can try for this card? Dell only listed the 2 that I have already tried.

Link to comment
Share on other sites

  • 1 year later...

The latest correct VBIOS for that card (same as mine), would be 4.17.00.55.C2. The B version was what you flashed for the 32MB card. When flashing I believe you have to answer the question whether 32 or 64MB directly in the floppy flash script. It's been a while, so forgive me if I'm wrong there. The important thing at any rate is to use the "C" variant of the Dell A06NV17 VBIOS which supports 64MB. I would think the "reflash" should be no problem at all.

Link to comment
Share on other sites

  • 1 month later...

I would suggest being very careful in flashing the "C" drivers from Dell. Those drivers messed up the display on my Inspiron 8200 w/ Nvidia 440 Go 64MB. It created a lot of pixel distortion/blurring, even messing up the bios display (strange blocks and odd characters replacing many of the normal letters). I would up having to reflash back to the "B" drivers--though this did seem to fix the problems.

See the posts on this forum for a discussion of the issue:

http://www.nvnews.net/vbulletin/showthread.php?t=71233

Link to comment
Share on other sites

Ok....I just read your thread, and can't see anything which is really 'valuable' or repetetive in any forensic fashion. The fact is, it would seem that people are trying to avoid using the Dell created floppy for some reason. It would seem rather impossible that the floppy would somehow burn the wrong bios version.

I took the trouble to look through the boot floppy created by the Dell file A06NV17.exe and determined that it functions automatically without any user intervention. In the provided Autoexec.bat an extra utility routine [sysid.com] is executed which determines the cards memory size and branches to either new32.exe or new64.exe to perform the flash depending upon the sysid.com result. Their content of the 2 .exe files is surprisingly VERY different, and not just several bytes as one would suspect. The sysid.com result should be reliable, since it seems to check the cards memory strappings, and branches to an error when things are not as expected. A prerequisite is that both AC and battery power be present for the flash.

To tell you the truth, I can't really remember anything at all about a 'B' rom version.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...