Jump to content
LaptopVideo2Go Forums

Go 7600 driver problems


Infinity

Recommended Posts

Ok I have been having a lot of issues with my drivers lately, and I will try to lay out the whole thing. About a month ago I started to get real bad video lag while I was gaming, and someone suggested to get new video drivers. So I go the the Nvidia site and they have nothing for Go 7600 cards and so i went searching and found this site. I Downloaded the 84.25 driver and got that running and the game was running smooth as ever. Everything was all good for about two weeks, then during a game a blue screen popped up for a split second and my computer crashed. I got back into the game and I was lagging like crazy. So I went and uninstalled and reinstalled the drivers a couple of times until I got no lag. This worked for about a week, and then one day I have crazy video lag again. So I go back to uninstalling and reinstalling drivers to try and fix it, and I cannot get rid of the lag. This is where I am now, and I have the 87.08 driver currently installed. I was hoping for some feedback on this to see how I could fix it, or should I go ahead and reformat my computer. Thanks for taking the time to read this.

Link to comment
Share on other sites

Hi,

why don't you try a newer driver, maybe 91.33, 91.73 or 97.44? I also have a GeForce Go 7600 on my laptop and i have horrible problems with corrupted game textures. I tried to play oblivion, ssam 2 and call of cthulhu but the textures get corrupted and the game becomes unplayable. Have you tried these games? Do you have the same problems? I also formatted my laptop but the problems persisted so format only when there is nothing else to try.

Link to comment
Share on other sites

Hey thank you for the help! I have tried about 5 different drivers and they didnt work, but I installed the 91.33 driver, like you suggested, and all is well. Thanks for the input. My problems weren't with textures but with video lag. I have about a 2.4 mb connection and my ping would shoot up to 150 from 50, so that is a video lag problem, but after playing 2 minutes into the round it would level off until I got into a gun fight. Now with the 91.33 driver it runs smooth the whole time, but it still has a bit of lag during gun fights. The games I play are CS:S, CoD 2, and CoD but mainly CoD 1 because I enjoy the gameplay of that a lot better.

Link to comment
Share on other sites

Ok New problem...

Everything went well with the 91.33 driver for about an hour of gaming, then I started to get lag again. :) I am now wondering if I have heat issues, but I keep the computer well ventulated. Any suggestions?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...