Jump to content
LaptopVideo2Go Forums

Geforce FX Go 5300 Pixel artifact in desktop


Recommended Posts


Due to a ACPI bug, the last VGA I had in this laptop burned up. During POST, the ACPI forgot turning the fan on. Saddly I didn't notice that :)

After a half hour, the laptop turned off and the VGA burned up.

I sent the laptop for repair. They replaced the Geforce FX Go 5700 with a older 5300.

They replaced the processor with a better one, so I will not complain about it :)

(For the curious, they replaced a AMD Athlon64 3000+ with an 3400+)

Now, with a repaired laptop, I have a new annoying problem. Since I don't want to be another 3 months waiting for a repair, I will try to fix the problem myself with your help.

During normal desktop operation I have some pixel artifacts in random places over the screen.

ie: when working on the console, colored pixels appears over the black background.

I can see the same behavior, when typing in this text box and when drawing some images..

I thought this could be some Linux driver incompatibility.. So I installed windows and toke the latest forceware driver. In windows, I have the same problem when moving windows or typing text..

So.. What could it be? I really don't know what to do.. But waiting another 3 months for a repair, seems a bad option :P

PS: I created a screen capture. Please see the attachment.

***************************** AFTER 2 DAYS ************************************

I'm starting to become pissed off.

Yesterday, I started Google Earth (as usual) in linux. But with this "new" VGA some black squares shows up all over the globe in random positions. Besides that, I'm experiencing hard lockups in the display system. That is, the screen image become still during several seconds, sometimes I can move the mouse pointer sometimes not. During the video lockup, the whole system is running and responsive. If I click in some app launcher button (guessing its position) during the video lockup I can see disk activity, after the lockup that app is fully opened and running.

This happens to all OpenGL/DirectX application.

I tried Google Earth both in windows and linux, they have same behavior (except Google Earth runs faster in linux, lol )

I tried other simple DirectX games under windows, even the most basic games experiences hard lockups.

Before having this VGA, I used to play "Perimeter" from Codemasters. Now it's impossible!

I'm running Windows XP 64 Pro and Linux Gentoo with full 64bit env.

The GPU temperature is most of time 40~45ºC.

What could it be? Do you think the VGA memory is damaged?

Would a VGA BIOS flash fix the problem?

I'm really desperate, I need my laptop to develop college apps, so sending it to repair and wait three months is not really an option.

I don't care if VGA BIOS voids the VGA warranty.

Anyway, this whole history stinks. Just for the worse scenario, who knows where to buy miniAGP VGAs? I spent some time searching and nothing :P

I really appreciate some advice from you.

Have a nice day.


Edited by miknix
Link to comment
Share on other sites

  • 2 weeks later...


I found how to fix this problem. I reduced vga memory clock speed from 552Mhz to 540Mhz!

Is there anyone having a similar vga card that could tell me the card speeds? I think the default gpu and mem speeds

specified in the VGA BIOS are wrong!


Link to comment
Share on other sites

  • 2 weeks later...

Kind of same problem here , Fx go5700 burned, and then changed with fx go5300. The problem is in 3D applications. After searching for drivers in the net, problems was not solved. Then decided to update bios(motherboard) with the latest version from acer website. And then after rebooting laptop is dead, 1 long and 2 short beeps comes and does not lights the screen. Can you tell me what is the version of your bios. Because obviously Acer are not giving the right one :) . And from where you have changed the vga memory. bios is not giving any options :) .


"It's not a BUG, It's an undocumented special feature"

Edited by Kalin Dimitrov
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...