Jump to content
LaptopVideo2Go Forums

f.e.a.r. combat issue with 84.21 drivers


HchorionicGT

Recommended Posts

When i was using my manufacturer's stock 83.90 drivers, i was avging 60 fps indoors, 25-30 outdoors on my go 7600 256mb. After updating to lv2go 84.21 drivers, i'm getting avging 15 fps everywhere. I made no changes to game settings or anything. BF2 and CS:S still run normally and maintain the same FPS as before. Any ideas of what i can do?

Link to comment
Share on other sites

Try a different driver, maybe other 84 series. There is 84.26, might be good. Also the latest listed on Nvidia's site is 93.71 Its hard to recommend the newer drivers due to all the bad things I have heard about them, especially any of the Vista drivers.

Some drivers just have problems with or are unoptimized in some games.

Link to comment
Share on other sites

Try a different driver, maybe other 84 series. There is 84.26, might be good. Also the latest listed on Nvidia's site is 93.71 Its hard to recommend the newer drivers due to all the bad things I have heard about them, especially any of the Vista drivers.

Some drivers just have problems with or are unoptimized in some games.

haha, a reboot fixes it. i hadn't noticed because i never tried it on a fresh reboot. the problem seems to surface following hibernations, which i use quite frequently as i take my notebook to classs everyday.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...