Jump to content
LaptopVideo2Go Forums

Full-screen video lag w/Geforce fx go5200 & vista aero


Guest Andrew

Recommended Posts

Dell Inspiron 8600, 1.6ghz Pentium M, nvidia geforce fx go5200 64mb, Vista Business 32-bit retail.

I recently upgraded my Dell Inspiron 8600 (1.6ghz Pentium M, 1.25gb of ram) to Windows Vista Business Edition, and have had no problems (Aero runs smoothly, etc.) except when playing video full-screen while using Aero. All video (DVD, divx, mpeg, etc.) runs smoothly in a window, regardless of the media player, but as soon as I switch to full-screen mode, it begins to lag. The exception to the problem is in PowerDVD 7, where I can choose (sometimes, other times the option is greyed-out) to enable hardware acceleration.

If I turn off Aero and switch to the Windows Vista basic theme, video runs smoothly in full-screen mode. It seems that Aero might be preventing my media players from using hardware acceleration in full-screen video modes, although I'm not entirely sure that is the case, since the processor never reaches 100% usage in any video situation.

I have the latest version of the 95-series drivers (what nvidia recommends for the go5xxx series cards), 97.54, and there is no option in the control panel to permanently enable hardware acceleration. In fact, there are very few options at all, only color adjustement, 3d options, and multiple display management, even in Advanced user mode. The Dell drivers I used in Windows XP SP2, on the other hand, had many more options available.

Does anyone have any idea what I can do to fix this problem, or do I just need to wait for nvidia or dell to release updated drivers? I appreciate any help anyone can offer. I hope I'm being clear, but please don't hesitate to request any other information needed. Several of my friends and myself are hoping to solve this problem ASAP.

Thanks!

Link to comment
Share on other sites

It's not a driver issue. Aero requires a minimum of 128 MB video ram. With only 64 MB on your card, it's having to contantly swap data from your card to main memory and back.

You can turn off the Glass Effects and keep the Aero interface. It should run fine that way.

Link to comment
Share on other sites

It's not a driver issue. Aero requires a minimum of 128 MB video ram. With only 64 MB on your card, it's having to contantly swap data from your card to main memory and back.

You can turn off the Glass Effects and keep the Aero interface. It should run fine that way.

Even without the glass effects it still lags. It also seems odd that the video would play without lag in a maximized media player window, yet lag in full-screen mode (not much larger). Why would that small change make a difference in the way the card handles the video? Additionally, when I am able to enable hardware acceleration (only in PowerDVD), it runs with all glass effects enabled without any problem.

Link to comment
Share on other sites

An update: I tried switching to the Windows Classic Theme with the logic that if performance improved with Vista Basic, then it should be flawless with Windows Classic. In fact, performance in Windows Classic lags only slightly less than Vista Aero, so I definitely believe it is a problem with the drivers (I have never had any problems with video playback on this computer), so I will just wait for an update to the 95 series.

Link to comment
Share on other sites

I am trying to get Aero working properly on my Go5200 32M. My success has varied greatly between drivers. Here's a summary:

97.19 - Aero worked perfectly, all the time. Laptop wouldn't resume from standby though.

[all other pre-100 drivers] - Standby problem solved. Aero drops back to Basic after various amounts of time.

100+ - Aero works fine, but screen fills with garbage if dropping back to Basic e.g. for shutdown, or UAC.

So currently there is no driver that works properly for all! I have read reports that 97.59 works properly, but I am currently running it myself and can confirm that it drops back to Basic like all the others.

I really hope we can find a solution!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...