Jump to content
LaptopVideo2Go Forums

DVD playback on external display


The Singing Badger

Recommended Posts

Hi there, I wonder if anyone can offer some advice. I'll be happy to shoot a kitten if this question is inappropriate, just say the word.

In my job, I frequently plug my laptop to a data projector and play DVD video clips to a large audience. I recently bought a new HP laptop (HP Pavilion dv6105ca) with an NVidia graphics adapter (GeForce Go 6150), but I have found that when plugged into an external display (whether a projector or a monitor), DVD playback has flickering horizontal lines during scenes involving fast movement, as if the lower half of the screen can't quite 'catch up' with the top half (I believe this phenomenon is called 'tearing' although I could be wrong).

Playback is fine when the laptop is not plugged into an external monitor.

It's also fine if I switch the display toggle button so that only the external monitor is being used - but having my laptop screen turned off is too much of a nuisance with the kind of presentations I'm doing.

I have tried several other laptops with the same projector, some of them quite ancient, and none has the same problem.

I've tried different playback software as well, and the effect is the same with all of them.

I've tried fiddling with hardware acceleration and other settings, none of which make a difference.

The driver for the NVidia adapter (8.6.1.9) seems to be more recent than the one listed on HP's website as their most recent (8.6.0.2A), so I'm wary of updating my driver unless it's absolutely necessary.

Google searches have yielded no answers, so I just thought I'd ask you guys if the problems I've been encountering are relatively normal when using data projectors, and if there is a 'quick fix', or whether this is a bizarre and unheard of phenomenon...

Many thanks in advance!

DETAILS

HP Pavilion dv6105ca

NVidia GEforce Go 6150

Windows XP Media Centre 2002

Edited by The Singing Badger
Link to comment
Share on other sites

Your driver version should be fine. Most tearing problems are due to Vertical Synch being disabled in the Performance and Quality Settings.

Check that, and while you're at it, make sure FastWrites is enabled on the AGP Settings page. Sometimes the data outruns the ability to transfer it.

Link to comment
Share on other sites

Hmm, Vertical Sync is definitely on, and I don't appear to have an AGP port on this computer, so far as I can tell.

Any other theories? This is very odd.

Link to comment
Share on other sites

You should have an AGP Settings page on your NVidia Control Panel. If not, try reinstalling your driver using our inf file instead of the one included with the driver. That will add the AGP page and will also optimize your video overlay settings, which could help.

One other idea... If you're using VMR (Video Mix Rendering) in your video player, try switching to Overlay mode. It's much less CPU intensive and may help you. (If not, then switch back to VMR since it's the preferred rendering method.)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...