Jump to content
LaptopVideo2Go Forums

GeForce Go5600 infinite loop issue upon installation.


Recommended Posts

Hey there,

I was recently sold a laptop.

  • Acer Aspire 1710. (1741Mi)
  • Intel Pentium 4 HT (Dual processor) 3.4 GHz; 512 Kb Cache.
  • 1 GIG Ram.
  • 17" SXGA Screen.
  • nVIDIA GeForce FX Go5600 - 128 MB VRAM

Man, I so wanted this machine to work out for me, but the video card keeps failing.

I mean, when I received the unit, it was running on a generic VGA.dll driver, giving me 32-bit colour at 1280*1024 resolution. Now, naturally, I wanted to activate the nVIDIA card and try out some games. However, the moment I install the Go5600 drivers, which were detected and accepted by windows, the machine reboots for settings to take effect, and a few seconds after the XP loading-screen, I get a BSOD with an infinite loop warning - this remains a constant problem, no matter how many different Go5600 drivers I use. Even when I install the drivers, but don't restart, opening dxdiag sends the computer crashing into the same BSOD. (I tried everything; I even altered resolution and colour display, but that too would lead to the n4_disp crash.)

The seller's not being very helpdful at this point, which means I'll have to take a tough line and return the item. However, before I do that, I thought I'd get some feedback from you people. What's your diagnosis? I've seriously tried virtually ever single driver from 55.something to 99.something, and all the modified ForceWare drivers. Really, I just get the same problem - the video card goes into a loop and the n4_disp driver stops working.

Your insights would be greatly appreciated, as I'm at my wits end with this damned situation.


Edited by Kade
Link to comment
Share on other sites

Get the official driver from Acer support, it's v.

Uninstall your current driver.

Use Driver Cleaner to get rid of driver remnants.

Install that Acer driver.

If you get those problems still, your hardware is probably bust :)

Link to comment
Share on other sites

Thanks for the contribution, although there is a small problem. That official driver is designed for the standard 1710 model, which comes with a GeForce Go5700 FX. This particular unit that I own, was actually modified--downgraded--to a Go5600 FX. Even then, I did use the drivers from the Aspire 1700 section, which is a slightly weaker 1710, equipped with the 5600. The 1700 and 1710 are virtually the same unit -- 1700 being slightly inferior, but with virtually the same hardware schematics.

Unfortunately, the 5700 drivers with intel extreme accelerator just didn't work on the system--told me that they're not compatible with my hardware, probably because of the fact that it's housing a 5600.

As for the 5600 drivers from the Aspire 1700, they detect fine, but give me the BSoD. Crap, eh?

Anyway, both solutions failed. So I assume the primary nVIDIA chip on my computer's screwed up?!

Edited by Kade
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...