Jump to content
LaptopVideo2Go Forums

Toshiba P25-S477, GeForce FX Go5200, driver 72.14, DualView, UseHWSelectedDevice


Bill Statler

Recommended Posts

I just fixed an odd post-upgrade problem: resume from standby caused my system to "forget" DualView and use only the external monitor, leaving a black screen on the internal LCD. The trick seems to be setting UseHWSelectedDevice to 0.

I thought I should document what I did, in case someone else stumbles in here with a similar system.

The details...

My computer: Toshiba Satellite P25-S477

Operating System: Windows XP Professional SP2

Graphics board: nVidia GeForce FX Go5200, 32 MB memory, BIOS version 4.34.20.25.14

Internal display: 1440x900 LCD

External display: ViewSonic Q22wb, 1680x1050 LCD, attached to analog VGA port

Old driver: version 44.89

This computer isn't used for gaming. Mostly it's for web browsing and running good old Word 97 and Excel 97. But when we added the external monitor, we noticed a few annoying display bugs (e.g., black bars covering lines of text in Word 97), so I wanted to try a driver upgrade.

After a lot of reading on this forum, I decided to try version 72.14. Someone posted (somewhere, lost the link) that this was the latest driver that fully supports FX Go5200 power management without needing extra tweaks.

I know that 72.14 is available on this site, but I decided to download it from nVidia instead. It's here:

http://www.nvidia.com/object/winxpmce_72.14.html

From the same page, you can download the Release Notes, the Display Properties User's Guide, and the nView 3.5 Desktop Manager User's Guide.

I used the INF Enhancer to make a replacement nv4_disp.inf file. I left all the Enhancer choices at their defaults except for the VMR Fix, which is suggested for drivers after 71.89.

After a lot of failures I ended up making the following 3 changes by hand in nv4_disp.inf:

In the [nv_SoftwareDeviceSettings] section, added this line:

HKR,, DevSwitchSuppressMask,[tab][/tab]  %REG_DWORD%,	7

I'm not sure what this does, but I saw a suggestion that it has something to do with how the driver decides which mode to start up in. Anyway, it was present both in the old driver on my machine and in the default nv4_disp.inf that comes with version 72.14, so it seemed like a good idea to include it.

In the [Mobile_Tweaks] section, un-commented this line and changed the value from 1 to 150:

HKR,, ModesetBlankDelay,[tab][/tab][tab][/tab] %REG_DWORD%,	150

The old driver on my machine used 150 here, so I'm guessing that is what the FX Go5200 wants.

Also in the [Mobile_Tweaks] section, changed this value from 1 to 0:

HKR,, UseHWSelectedDevice,[tab][/tab][tab][/tab] %REG_DWORD%,	0

Apparently this tells the nVidia resource manager which device to resume from after standby. This was very important for my DualView setup -- with the original setting of 1, when the system resumes after being in standby or hibernate mode, about 4 times out of 5 the internal LCD will come on for a fraction of a second, then shut off, and the system will be in single display mode on the external monitor only, rather than DualView. Changing UseHWSelectedDevice to 0 seems to have fixed this problem.

Anyway, it's working. The mystery black bars in Word 97 seem to be gone. Of course, there's a *new* bug now: a tiny section of the Word 97 window that doesn't get redrawn properly. But we can live with that.

(Um, actually I haven't yet tried disconnecting the external monitor to see how the driver handles that change, so that's still an unknown.)

Many thanks to the laptopvideo2go.com team and the forum members! This upgrade would have been impossible for me without the information you've collected here.

Link to comment
Share on other sites

  • 1 month later...

Thanks for this informative first-time post. If only more would be like this... a lot of forum moderators would have an easier life and actually readers would benefit from this too.

I'll FAQ this.

Link to comment
Share on other sites

  • 7 months later...
Guest Michael

Thanks - that helped me sort out a problem with resuming from standby on my Toshiba Satellite Pro M10. The card I've got is a GeForce4 420 Go

This is probably obvious to anyone who's patient enough to read what's on this site, but I'm too lazy so I had to find out the hard way. I'm using Pieter's INF version 30.71, and I made all the changes in the original post, and changed the following value to 2 (as suggested by the comment below):

[MapOSD3ToNV_2]
HKR,, MapOSD3ToNV,				   %REG_DWORD%,	2
;Set the above value to 2 if you experience Resume from Standby/hibernate problems

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...