Jump to content
LaptopVideo2Go Forums

How to prevent Windows Update replacing drivers with Microsoft's drivers


Rocky88

Recommended Posts

I have laptop with nvidia go 7800 and after installing Windows Vista I downloaded 165.01 drivers for my gpu.

Drivers work perfectly, however Windows automatic updates keep replacing my new drivers I downloaded from laptopvideo2go with older drivers from MS (that don't have nvidia control panel).

How do I prevent Windows from downloading and installing gpu drivers while still keeping the rest of updates on? Anyone got similar experiences?

Edited by Rocky88
Link to comment
Share on other sites

Guest nghiabui

I have a similar problem, but I don't think it has anything to do with Windows Update. My most current video drivers will always revert back to a much older set of drivers (97.46) on its own. Once I do a rollback of the 97.46 video drivers, I get back what I recently installed. This happens after reboots and sometimes when I leave the computer on for a while. I have tried Driver Clean Pro and manually removing the 97.46 driver files from the Windows directory, still no luck. I just cannot get rid of these drivers!

I have a Dell M1710 running with a 7900 GTX.

Link to comment
Share on other sites

I'm pretty sure it's because of windows updates, because yesterday I installed new drivers from this website and then windows said that there are new updates available. Then I turned off the computer and drivers were automatically installed and after turning on computer I had old drivers again. Then I checked windows update history and in the log list there were geforce drivers listed at exact time when I shut down the computer last night.

Edited by ®®®
Removed Full Quotation of Previous Post
Link to comment
Share on other sites

Guest nghiabui

I apologize. You're right. I do see the same thing in my Windows Update log....this is very interesting. I'll see if I can disable this portion of the updating and let you know. Thanks for pointing me in the right direction.

Link to comment
Share on other sites

Well, I kinda solved this by disabling automatic updates and selecting option in windows update "notify me of new updates and let me choose which to download and install".

Now I can manually select which updates to install. When I saw nvidia driver update I just right clicked it and selected "hide", so now I got rid of it forever. :)

Link to comment
Share on other sites

  • 1 month later...
Guest Zarigis

I had this same issue except it would manifest in weird ways, causing my system to crash whenever the update was applied and whatnot. You don't need to disable automatic updates entirely, just disable the automatic installing of them, then once the system suggests updating your graphics drivers you just set the update to "hide". You might be able to turn automatic update installs back on after that, I haven't really been brave enough to try.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...