Jump to content
LaptopVideo2Go Forums

Help with Dell 5150 and 1366x768


kane81

Recommended Posts

I have dell inspiron 5150 XP, using larry inf with version 9795 drivers (tried other driver too)

I cant seem to select 1366x768 (tried 1368x768 too - for outputting to LCD TV) or add this resoultion. Get an error saying "can not add resolution" when trying to add

I was reading that this should be avaliable as part of the mod inf, but doesnt showup on my laptop.

the res I can get from the VGA out analog is

2048x1536

1920x1440

1600x1200

1600x1024

1400x1050

1280x1024

1280x960

1280x854

1152x864

1024x768

800x600

768x576

720x480

640x480

512x384

480x360

400x300

320x240

Hide modes not supported is unticked

There are three monitor profiles

Default Monitor

Plug and Play

Default Monitor

all have hide modes not supported unticked.

Any ideas?

Thanks

Link to comment
Share on other sites

HKR,, NV_Modes, %REG_MULTI_SZ%, "{*}S 320x200 320x240 400x300 480x360 512x384 640x350 640x400=1FFF;SHV 640x480 720x400 720x480 768x576 800x600 852x480 853x480 854x480 864x480 1024x640 1024x768 1152x864 1280x720 1280x768 1280x800 1280x854 1280x960 1280x1024 1360x768 1365x768 1366x768 1400x1050 1440x900 1600x900 1600x1000 1600x1024 1600x1200 1680x1050 1800x1440 1920x1080 1920x1200 1920x1440 2048x1280 2048x1536 2560x1600 3840x2400x8,16,32=1FFF;"

These are the supported resolutions in the modded INF

By the looks of it you have a standard INF and standard resolutions that come with them.

Link to comment
Share on other sites

Did you replace the original INF with Larry's modded one ?

As it looks like you havn't.

Once done reinstall driver and it should work.

The settings are there.

Link to comment
Share on other sites

^

yes this is the file I used.

If I wasnt using larry's inf, setup.exe would say "no compatible devices were found"

so I'm sure setup.exe is using this inf.

I deleted the org inf and put this one in the install directory. renamed the inf to nv4_disp.inf

......

Seems odd, I know. Even powerstrip fails to add custom resolutions.

I tried adding the predefined 1366x768 from powerstrip and it just doesnt show up as an option.... :)

Link to comment
Share on other sites

The modded INF is not installing.

Try the update driver method via control panel to update the driver.

Point the driver locator to where the modded INF and drivers are.

Link to comment
Share on other sites

nope.. just tried it, didnt work :)

I think I will try reformatting and see if I can get it working....

Link to comment
Share on other sites

Horray! Fixed!

A reformat worked!

Seems like there was something in my old system that stopped custom resolutions working....

when in dobut clean install!

thanks for the help

Link to comment
Share on other sites

  • 4 weeks later...

I found the bug in larry's driver which stopped custom resolutions showing when using nvidia XP drivers

http://forums.laptopvideo2go.com/index....amp;#entry55913

basically

need to delete this key (it seems to block all custom resolutions, even in the inf)

[nv_SoftwareDeviceSettings]

HKR,, WidePanelBehavior, %REG_DWORD%, 0x31

and add

[nv_ClearRegistrySwitches]

HKR,, WidePanelBehavior

Doing this will allow you to add custom resolutions using powerstrip in vista!

And also allow you to use the custom resolutions contained in the inf file!!!!!!

Edited by kane81
Link to comment
Share on other sites

Good collaboration with Larry with this. Great find, patience pays.

Though i guess Larry has put this value in his INF on purpose for his Go5200 recommended drivers.

For which driver series/version is this fix valid?

Link to comment
Share on other sites

I tested under 67.66 XP driver under vista

however, I couldnt get 1366x768 using 84 series either.

I could get 1366x768 when using vista spacific drivers and without larry inf, but performance was slow.

Link to comment
Share on other sites

Try my new Vista inf and see if it helps. It's for Vista driver 97.34.

...And yes, it includes your widescreen fix.

:)

Link to comment
Share on other sites

  • 11 months later...

I had this exact problem with my Toshiba Satellite M35-S456, It has a geforce fx go5200.

I had been trying to get it into dualview with 1360x768 on an LCD tv for a few days with no luck, but I modified the Toshiba-supplied driver with all the suggestions you made and it worked like a charm... Thanks guys!

List of the changes I made:

-Added 1360x768 resolution to the NV_Modes line

-Deleted this line: HKR,, WidePanelBehavior, %REG_DWORD%, 0x31

Note: Don't have to add the "HKR,, WidePanelBehavior" line under the "[nv_ClearRegistrySwitches]" section, it already has it.

That's it! 2 little changes to the driver and it works perfectly with custom resolutions and everything :)

Link to comment
Share on other sites

That's great to hear, Evan, and it's also a timely reminder for me since I forgot to add that resolution to my most recent batch of custom infs. I'll post updated versions in the next day or so.

Thanks again!

:)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...