Jump to content
LaptopVideo2Go Forums

Problem with Bioshock and Sony Vaio FZ-11Z nvidia geForce 8400M GT


Fletch

Recommended Posts

Hi. I am the proud owner of the latest Sony Vaio as above but can not update the driver for the machine. I would like to play Bioshock but it hangs everytime, after the plane crashes. This seems to be normal with most peoples posts I have read with this particular graphics card. Any ideas where I can get the driver? I have downloaded 163.44 from this site but it does not work as this driver is for the 8400 GS NOT the GT. Please help, it's driving me mad!

Fletch

Link to comment
Share on other sites

I had the same problem. It runs by default with DirectX 10, right click the exe or the item in the Games folder and you will see below play/open there is an option to run it with DirectX 9, this will allow you to get past the plane and Bioshock logo to the crash site. The 8400M GT on my Vaio FZ190 can run Bioshock on full settings but it gets choppy at demanding moments, the trick is (in game) to set your resolution at 1024x600 instead of the systems native which is 1280x800, then it will be very smooth. I admit I have over clocked it a bit, core clock by 40 Mhz and memory clock by 60 Mhz, but it should be essentially the same on default speeds.

I am running it on the custom FZ with:

Home Premium

Core 2 Duo 2.0 GHz

2.00 GB RAM

My Windows Experience Index is:

Processor: 4.9

Memory: 4.8

Graphics: 5.9

Gaming Graphics: 5.4

Hard Disc: 4.3 <--Base

Interestingly enough, in the Games menu it displays the recommended base score for Bioshock to be 2.00 or higher, keep that in mind, you will will definately be able to play this game on an FZ.

BTW - None of the new Beta drivers (163.44) are built for the 8M series, don't bother looking for drivers.

Edited by manbearpig
Link to comment
Share on other sites

Guest Benakin
fletch it would be great if you can tell us how did you do ? i have the same problem with FZ18M ! thx

I had the same problem with my VAIO FZ11Z (Running 32 bit Vista). Running Bioshock in Dx9 mode worked ok for a bit but crashed every time I tried to hack a security bot or used a vending machine. I found a much better solution which allows running in Dx10 mode (which explains how to install the 163.44 beta drivers from www.laptopvideo2go.com) here:

club.vaio.sony.co.uk/clubvaio/GB/en/forum/viewthread;jsessionid=A9A505E7FF9BD6A91BF56435D1229FD4?thread=44960

It suggests installing the drivers found here:

forums.laptopvideo2go.com/index.php?showtopic=14562

By following these instructions:

forums.laptopvideo2go.com/index.php?showtopic=11997

That gets the game running past the plane crash. There is also a windows hotfix which can be downloaded from here:

support.microsoft.com/kb/940105

Applying that stopped me from getting the remaining random crashes (stuff like crashing when changing graphics settings when in game).

Now Bioshock runs fine.

I hope that helps.

Ben

Link to comment
Share on other sites

I had the same problem with my VAIO FZ11Z (Running 32 bit Vista). Running Bioshock in Dx9 mode worked ok for a bit but crashed every time I tried to hack a security bot or used a vending machine. I found a much better solution which allows running in Dx10 mode (which explains how to install the 163.44 beta drivers from www.laptopvideo2go.com) here:

club.vaio.sony.co.uk/clubvaio/GB/en/forum/viewthread;jsessionid=A9A505E7FF9BD6A91BF56435D1229FD4?thread=44960

It suggests installing the drivers found here:

forums.laptopvideo2go.com/index.php?showtopic=14562

By following these instructions:

forums.laptopvideo2go.com/index.php?showtopic=11997

That gets the game running past the plane crash. There is also a windows hotfix which can be downloaded from here:

support.microsoft.com/kb/940105

Applying that stopped me from getting the remaining random crashes (stuff like crashing when changing graphics settings when in game).

Now Bioshock runs fine.

I hope that helps.

Ben

cheers ben i'll try

Link to comment
Share on other sites

cheers ben i'll try

This solution works for BioShock, however, there is a small price. If you use a second monitor, the secondary screen shows up in Black and White (even though the NVIDIA control panel says it's displaying in full color). None of the Microsoft hotfixes for NVIDIA helped.

I suppose that since normal desktop cards don't do second displays the same way that laptops do, the desktop drivers just don't work properly for that feature (I'm typing this right now in my second display). Since I use the second monitor everyday for my work, this side effect was not worth it. I restored the drivers from the Sony VAIO site and am anxiously waiting for the official 8400M GT drivers to come out.

-Dan

Link to comment
Share on other sites

  • 2 weeks later...
This solution works for BioShock, however, there is a small price. If you use a second monitor, the secondary screen shows up in Black and White (even though the NVIDIA control panel says it's displaying in full color). None of the Microsoft hotfixes for NVIDIA helped.

I suppose that since normal desktop cards don't do second displays the same way that laptops do, the desktop drivers just don't work properly for that feature (I'm typing this right now in my second display). Since I use the second monitor everyday for my work, this side effect was not worth it. I restored the drivers from the Sony VAIO site and am anxiously waiting for the official 8400M GT drivers to come out.

-Dan

I'm sorry to hear that the solution didn't work for you. I also have a two monitor setup and don't have this problem.

Ben

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...