Jump to content
LaptopVideo2Go Forums

Latest Atheros WLAN drivers for Windows 7 and Vista (x86 & x64)


mobilenvidia

Recommended Posts

  • Replies 344
  • Created
  • Last Reply

Top Posters In This Topic

  • mobilenvidia

    109

  • Pawel

    5

  • Anarion

    5

  • Jake_

    6

Added 9.0.0.208

Best drivers for me. No more timeout spikes. Still the background scan issue (DPC latency and high ping every 60 seconds), tough.

Link to comment
Share on other sites

Guest nemesiz

hi folks, simple question...

why is the date of the AR9285 8.0.0.351 "xx.06.2010" and of the 9.1.xx the 28.05.2010 ?

hmm whats newer, the higher versionsnumber or the one with the higher relase date. hm hm hm

Link to comment
Share on other sites

hi folks, simple question...

why is the date of the AR9285 8.0.0.351 "xx.06.2010" and of the 9.1.xx the 28.05.2010 ?

hmm whats newer, the higher versionsnumber or the one with the higher relase date. hm hm hm

Because there can be different branches, all of them actually maintained and regularly updated, of the same driver. There's nothing wrong in this. The problem is the communication with atheros: they only support their real customers, notebook sellers like Asus, Sony, Toshiba, Acer..., and not their actual users of their product. This means that for actual users is difficult to guess which driver version is best for them, because of lacking changelogs or because there aren't clear statements that one driver branch works better with some chipsets and not others. You have to install all of them verifying their quality in more or less empiric way. Another problem is customer specific customization: it may happens that your specific bug is solved by a tweak of the actual driver that is enabled for Toshiba laptops and not for Acer ones, while they both have the same chipset! This shouldn't happen in theory: if there's a bug, it should be solved for everybody. In real world, Atheros may not consider that a bugfix just because Toshiba told "Ehy Atheros: with this setting enabled, our wireless connectivity works better" with Atheros replying "Ok Toshiba. You are the only reporter: Acer, Sony, ... didn't complain. We will enabled this just you in the next driver version and will see". If there aren't sufficient complains from notebook sellers, a real bug suffered by MANY users can be actually ignored by Atheros and not investigate to find a proper solution that's not a workaround, like a tweak that can sort things but with some costs (for example performance or not fully compatibility with every chipset in commerce).

I hope it's clear, regards.

Link to comment
Share on other sites

Guest nemesiz

ok, i use the 9.xx version but windows update tells me to use the version with date xx.06.2010 but its 8.xx.

its the same crap with the 3150GMA. Samsung has one old version, works well, intel has some old to, works well.

now intel has 2 newer versions, none of them works, brightness cannot be adjustet, none withe the samsung display manager or with windows itself, same crap.

samsung only delivers a newer 32bit version, when i use same version x64 direct from intel, brightnes is locked.

laptop drivers make me crazy

Link to comment
Share on other sites

ok, i use the 9.xx version but windows update tells me to use the version with date xx.06.2010 but its 8.xx.

its the same crap with the 3150GMA. Samsung has one old version, works well, intel has some old to, works well.

now intel has 2 newer versions, none of them works, brightness cannot be adjustet, none withe the samsung display manager or with windows itself, same crap.

samsung only delivers a newer 32bit version, when i use same version x64 direct from intel, brightnes is locked.

laptop drivers make me crazy

Not clear: have you found at least a release that does work for you? You aren't supposed to upgrade if an older version satisfy you, and MS update drivers aren't usually checked for update (you have to manually check them).

Link to comment
Share on other sites

  • 4 weeks later...

Hello!

Maybe I found a bug in modded "atheros_v9.1.0.100_v1.30.exe".

During installation Service "Atheros IHV Service" is registered depending on file "%%SystemRoot%%\system32\athihvs.dll".

File is missing in "atheros_v9.1.0.100_v1.30.exe" and file system (Win7).

Link to comment
Share on other sites

Hello!

Maybe I found a bug in modded "atheros_v9.1.0.100_v1.30.exe".

During installation Service "Atheros IHV Service" is registered depending on file "%%SystemRoot%%\system32\athihvs.dll".

File is missing in "atheros_v9.1.0.100_v1.30.exe" and file system (Win7).

Ooops. Posted in regular thread instead of modded. Moderator, please move.

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...

Atheros R928X (and some other) 9.2.0.113 for Windows 7 32 and 64 bit

http://www.atheros.cz/atheros-wireless-download.php?chipset=39&system=6

Full list here:

http://www.atheros.cz/atheros-wireless-drivers.php

Link to comment
Share on other sites

  • 2 weeks later...
Guest Blueshift

how to install this? windows tells me the current drivers are the most up to date

You must install the driver manually by clicking on "Browse my computer for driver software".

Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...
Guest lost guest

I've been having trouble recently with my dwa 552 losing connection repeatedly.Its been working fine for about a year when suddenly it doesnt like me anymore! Would using the latest diver here help with that?

Link to comment
Share on other sites

Guest Guest_Guessed_*_

use a linux-live cd to confirm windows issues. if you have problems in linux, you have hw issues (loose antennae) or crappy router(power pack) too many devices on same channel(neighbors - install driver package from station-drivers.com, run the \InstallCD folder to install app, run utility - SCAN to find local netwerks), a local transformer is about to blow on telephone pole (confirm with AM radio). Lastly give up on this site, they could care less lately.

you can always blame ISP, call & demand partial service credit. they'll do it whether or not they're at fault. don't try in china,burma,etc!

Link to comment
Share on other sites

  • 2 weeks later...
Guest guest

Just tested all drivers posted here an my D-link DWA-547 ver A.3(AR9223),and LED doesn't work at all!!!...this doesen't affect the capabilities of the card, so I gues this is not a major problem, or is it :)

Link to comment
Share on other sites

  • 3 weeks later...
Guest chago

use a linux-live cd to confirm windows issues. if you have problems in linux, you have hw issues (loose antennae) or crappy router(power pack) too many devices on same channel(neighbors - install driver package from station-drivers.com, run the \InstallCD folder to install app, run utility - SCAN to find local netwerks), a local transformer is about to blow on telephone pole (confirm with AM radio). Lastly give up on this site, they could care less lately.

you can always blame ISP, call & demand partial service credit. they'll do it whether or not they're at fault. don't try in china,burma,etc!

wtf is this idiot babbling about?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...