Jump to content
LaptopVideo2Go Forums

Drivers won't install anymore


Guest Fuwex

Recommended Posts

Hey all,

I recently bought a new laptop, the Acer Aspire 5920G, which has a Geforce 8600M GT graphics card with 256 MB memory and TurboCache. It came with Windows Vista Home Premium (32-bit), and that's what I'm currently using (although due to the instability of the system I'm thinking of going back to XP, but that's a different matter).

Obviously I didn't want to stay with the stock drivers, so I tried a few of the drivers on this site, and they worked fine. I ended up at 162.18 for some time (as I got it working with my LCD flat panel HDTV through HDMI), but now I wanted to upgrade to 163.69. Proved to become a problem.

The following problem doesn't only occur when I try to install 163.69, but with any driver that I've tested (drivers that I know would normally work as I used them before changing to my current 162.18).

Now, using the have-disk method in Vista without uninstalling the current driver, here's what it says:

Windows found driver software for your device, but encountered an error while attempting to install it

NVIDIA GeForce 8600M GT

The system cannot find the file specified.

So, I tried installing using the setup.exe that came with the driver. It reported that it detected that a Windows Device Manager wizard was running, and it would minimise and wait till it finished before it would start installing.

However, I didn't have any Device Manager wizards running, and I tried rebooting my PC several times and it still kept saying the same.

I googled it and several people reported that this happened if the Device Manager was under the effect of a 'hiccup-bug', where it would contiously refresh or something like that, due to something with the USB ports. I didn't experience any hiccup effects, but I nonetheless removed every USB device I had running. Still with no effect whatsoever on the driver installation. It simply wouldn't let me install a new driver.

Then, I tried uninstalling the driver first (well, actually, I did this prior to the above, but it doesn't matter). I used the Device Manager to uninstall, and I rebooted. In the device manager now, the graphics card wasn't recognized as a Display Adapter, but was instead under Other devices and named something along the lines of Generic VGA-adapter, can't remember exactly. Either way, the same problem persisted, and I wasn't able to install any drivers at all. So I was left with no drivers, and eventually I had to do a system restore in order to have some graphical drivers installed. So now I'm back at 162.18.

I've tried the above several times, but always with the same result.

I hope I've added sufficient information. I have included a NERD logfile, but it failed at EDID (it wasn't allowed to run fullscreen or something), so from EDID and anything past that is not included.

Any help is greatly appreciated!

LaptopVideo2Go_LogFile.txt

Link to comment
Share on other sites

That message means the modded inf is calling for a file that isn't included in the driver package. There are a number of files that are used in some driver builds and not others. These usually aren't crucial ones. If you can figure out which file is missing, you have two choices - use the same file from a different driver package, or remove the reference from the modded inf.

Somehow Windows is using this inf for every driver you install, which is why you're getting the message with all driver packages. The Have Disk method usually solves this, but it doesn't seem to be working in your case. Make sure the modded inf is the only one included in the driver package and see if it helps.

Link to comment
Share on other sites

I removed the driver files, and re-downloaded the drivers and the modded INF from this site, and miraculously, it worked! I don't quite understand it, but I'm happy that I'm able to install other drivers once again. Thanks for your help!

One thing though - I've got English Windows Vista, however the nvidia setup gives me a Norwegian control panel. My native language is Norwegian, but I'd much prefer to have it in English. How do I change the language of the Nvidia control panel (and all other nvidia applications)?

Link to comment
Share on other sites

I'm glad it's working! :)

Unfortunately, I have no idea on the language choice. Maybe someone else can jump in here on that one.

Link to comment
Share on other sites

Guest Janvitos

I am having the same problem with my new Dell Inspiron 1520 with GeForce 8600M GT.

When i try to run setup.exe, it says installation completed successfully but when i reboot i have the same "Standard VGA Adapter" listed.

If i try to update drivers manually, i get the same error posted earlyer.

I tried re-downloading the driver and inf without success.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...