Jump to content
LaptopVideo2Go Forums

Latest Atheros modded Driver for Windows 7, Vista and WinXP


mobilenvidia

Recommended Posts

Hi, I thought I would login to tell you that I've installed 8.0.0.225 on my AR5008 and all is well so far. :) I am running Windows Vista 32 currently BTW.

Link to comment
Share on other sites

  • Replies 610
  • Created
  • Last Reply

Top Posters In This Topic

  • mobilenvidia

    145

  • chiefwigms

    7

  • stanny

    10

Top Posters In This Topic

Posted Images

Guest BoardBabe

I can install the unmodified v8.0.0.225 on my HP system with Windows 7 64bit, however not the modified. The red warning comeds up and the card is not working/not able to show available networks etc.

I have an Atheros 5009 a/g/n

PCI\VEN_168C&DEV_002A&SUBSYS_1382103C&REV_01

PCI\VEN_168C&DEV_002A&CC_028000

PCI\VEN_168C&DEV_002A&REV_01

Link to comment
Share on other sites

I can install the unmodified v8.0.0.225 on my HP system with Windows 7 64bit, however not the modified. The red warning comeds up and the card is not working/not able to show available networks etc.

I have an Atheros 5009 a/g/n

PCI\VEN_168C&DEV_002A&SUBSYS_1382103C&REV_01

PCI\VEN_168C&DEV_002A&CC_028000

PCI\VEN_168C&DEV_002A&REV_01

That is really weird how you can install the Original 225 driver as it doesn't support your SUBSYS

Took me quite sometime to find the HP driver that has your SUBSYS number (only HP release drivers for your setup by the looks of it)

In this driver I discovered that HP installs the 'Atheros IHV Service'

That the Atheros orginal drivers do not.

There are no other reason that I can see that would cause your card to come up with the red warning.

I've updated the INF for 225 to v1.29 and added the IHV service.

Link to comment
Share on other sites

Hi again,

thanks for the tip, but this does not solve my problem. The drivers do install but I am unable to connect to a network (No networks found/the drivers are not loaded) after one or more computer restarts. The problem also occurs on the .225 driver. Now, I am using the .179 driver again and the problem does not occur whatsoever. Is there any difference in the way the drivers are signed between the versions?

My card is working fine with the .179 driver, so there is essentially no need to upgrade except for the upgrade junkie in me... :-)

By the way, is there any way to get a change log for the different revisions?

Thanks!

My solution to this was to install the DSEO application and sign the sys files in the package with this app. After that, it all works fine.

Link to comment
Share on other sites

That is really weird how you can install the Original 225 driver as it doesn't support your SUBSYS

Took me quite sometime to find the HP driver that has your SUBSYS number (only HP release drivers for your setup by the looks of it)

In this driver I discovered that HP installs the 'Atheros IHV Service'

That the Atheros orginal drivers do not.

There are no other reason that I can see that would cause your card to come up with the red warning.

I've updated the INF for 225 to v1.29 and added the IHV service.

Thank you very much for your time!

The driver now installs. I still get the red warning, however it now installs and seems to work fine! :)

By the way; I'm trying to figure out whether this card supports true 300mbit or not, any idea? I'm only able to get 150mbit out of it to my Netgear WNDR3300 (the router can transmit at 300 fine, until I connect with the Atheros 5009 -it drops to 150).

Edited by BoardBabe
Link to comment
Share on other sites

Thank you very much for your time!

The driver now installs. I still get the red warning, however it now installs and seems to work fine! :)

By the way; I'm trying to figure out whether this card supports true 300mbit or not, any idea? I'm only able to get 150mbit out of it to my Netgear WNDR3300 (the router can transmit at 300 fine, until I connect with the Atheros 5009 -it drops to 150).

Looks like the 5008 or the router is dropping to 20Mhz bandwidth.

Make sure if you are using the modded driver that the 5009 is set to 11ABGN(40Mhz) and the router should also be set to 40Mhz and 11n (incase its' not

Link to comment
Share on other sites

Looks like the 5008 or the router is dropping to 20Mhz bandwidth.

Make sure if you are using the modded driver that the 5009 is set to 11ABGN(40Mhz) and the router should also be set to 40Mhz and 11n (incase its' not

Thanks for replying.

It might be the problem however both the router and NIC are set to use the 40MHz width only. The 5009 is set to 11abgn(40Mhz) as standard setting and the router is set to use 11NA Only at 40Mhz lower range. Im using channel 56 + 54.

Link to comment
Share on other sites

Thanks for replying.

It might be the problem however both the router and NIC are set to use the 40MHz width only. The 5009 is set to 11abgn(40Mhz) as standard setting and the router is set to use 11NA Only at 40Mhz lower range. Im using channel 56 + 54.

Are you using that channel on the router ?

Try using channels 36 - 40 on the router, and see how you go.

Not everything works with the higher channels.

The lower the channel the lower the freq the higher the range also

Link to comment
Share on other sites

Are you using that channel on the router ?

Try using channels 36 - 40 on the router, and see how you go.

Not everything works with the higher channels.

The lower the channel the lower the freq the higher the range also

Yes those are the channels set on the router when the router was set to Auto.

Changing to manual channel selection using the upper wide channel range and channels 132 + 134 solved the issue. I am now able to achieve a reported 270 Mbps rate.

I am not sure what channels are optimal yet, however it seems to have to be high channels to achieve 270 Mbps. When set to Auto it will use 56 + 54 that limits me to 135 Mbps. Any idea how to figure out the optimal channels to use? I am not in need of great range, although high speed. Im one floor directly below the router. I can choose from channel 36 (5.180GHz) to 157 (5.785Ghz) at my router in the upper range.

Edited by BoardBabe
Link to comment
Share on other sites

Yes those are the channels set on the router when the router was set to Auto.

Changing to manual channel selection using the upper wide channel range and channels 132 + 134 solved the issue. I am now able to achieve a reported 270 Mbps rate.

I am not sure what channels are optimal yet, however it seems to have to be high channels to achieve 270 Mbps. When set to Auto it will use 56 + 54 that limits me to 135 Mbps. Any idea how to figure out the optimal channels to use? I am not in need of great range, although high speed. Im one floor directly below the router. I can choose from channel 36 (5.180GHz) to 157 (5.785Ghz) at my router in the upper range.

My Buffalo Dual band router only does the low band channels 36-48, so was never able to test these upper channels.

Have a play with the secondary channels they might be too close together.

The Buffalo when picking channel 36 would choose channel 44 for the secondary channel, can you set the secondary channel manually.

Link to comment
Share on other sites

I see. Good to know.

It seems I am unfortunatly not able to set secondary channel manually. I have flashed my router with DD-WRT firmware to enable more options.

Edited by BoardBabe
Link to comment
Share on other sites

Hey, just found this little place, a nice safe haven for atheros card users.

Stupid guest post, but a little digging through the forums turned up nothing, so...

I installed these modded drivers, as I was experiencing disconnects from my belkin router, which is a POS anyway. They finally drew the last straw, so I installed these. After a while of 7 giving me the runaround when trying to install the drivers, I finally did a manual update saying I have the disk, pointed it to one of the inf files included in the latest DL, and bam, the net works again, and so far no drops.

Only issue is.. It blinks. The LED on off light blinks, and its rather distracting... How do I go about changing it so that its just displays on or off?

I'm running a 5009 with 7 build 7100, yes I know its old.

Link to comment
Share on other sites

On this page you'll find Ver 8.0.0.238 for Win7

http://www.station-drivers.com/page/atheros.htm

Also on the same webpage there's the Atheros Client Utility Version 8.0.0.72 -> works fine on Win 7.

Ciao 4 now

~ Paulo ~

Had 238 uploaded in the Win7/Vista tread.

Did try the version with the installer but I get no Client Utility.

Hey, just found this little place, a nice safe haven for atheros card users.

Stupid guest post, but a little digging through the forums turned up nothing, so...

I installed these modded drivers, as I was experiencing disconnects from my belkin router, which is a POS anyway. They finally drew the last straw, so I installed these. After a while of 7 giving me the runaround when trying to install the drivers, I finally did a manual update saying I have the disk, pointed it to one of the inf files included in the latest DL, and bam, the net works again, and so far no drops.

Only issue is.. It blinks. The LED on off light blinks, and its rather distracting... How do I go about changing it so that its just displays on or off?

I'm running a 5009 with 7 build 7100, yes I know its old.

There are a couple of LED lines in the modded INF have a play with them.

Good luck as you will need it, very finnecky settings

Link to comment
Share on other sites

There are a couple of LED lines in the modded INF have a play with them.

Good luck as you will need it, very finnecky settings

Thanks for the quick response, and I just wanted to verify, I change the inf before the "update" right? Also, The difference between the inf with the x and the one without is just x84 vs 64 right?

Link to comment
Share on other sites

There are a couple of LED lines in the modded INF have a play with them.

Good luck as you will need it, very finnecky settings

You can delete my last post, I decided to get an account.

Thanks for the quick response, and I just wanted to verify, I change the inf before the "update" right? Also, The difference between the inf with the x and the one without is just x84 vs 64 right?

So I found the linkLEDFunc line, as well as the entry into the reg, and the value is 35, which I don't see defined anywhere. I also found an LEDactivity line in the "official" driver INF 8.0.0.238, if that even is official, 7 doesn't like it either way at least in the way of it being newer.

EDIT: and this is why I got the account. Anyway, the linkLEDFunc doesn't seem to do anything, as even renaming the reg string doesn't provide any visible results.

Edited by Kevin F.
Link to comment
Share on other sites

You can delete my last post, I decided to get an account.

Thanks for the quick response, and I just wanted to verify, I change the inf before the "update" right? Also, The difference between the inf with the x and the one without is just x84 vs 64 right?

So I found the linkLEDFunc line, as well as the entry into the reg, and the value is 35, which I don't see defined anywhere. I also found an LEDactivity line in the "official" driver INF 8.0.0.238, if that even is official, 7 doesn't like it either way at least in the way of it being newer.

EDIT: and this is why I got the account. Anyway, the linkLEDFunc doesn't seem to do anything, as even renaming the reg string doesn't provide any visible results.

Modify the IN

x=64bit

Save the modded INF (make sure it's in the dirver dir)

Now install driver using the driver update to install via the modded INF.

The LED function is bit sensitive

have a look in the original driver INFs for some example values to work with.

Link to comment
Share on other sites

I have a weird problem with my AR5009 on my HP DV5-1180eo notebook. I'm running Windows 7 x64 and I have tried a LOT of drivers, but none of them seems to work on the network on my school. They are using WPA Enterprise for encryption. Sometimes I can get a decent connection, but most of the time I can only ping the LAN for about 10 seconds, and then the connection dies. Windows doesn't see the connection as down, the link is still there. I have a feeling that it depends on what Access Point it's connected to. I can connect to all other networks I've come across without problems.

I've been using 7.7.0.199 with semi results, and now I've let Windows "update" the driver to 2.0.0.75.

Have anyone experienced similar problems, or can anyone think of a solution to these problems?

I'm so desperate that I'm thinking about changing the adaptor to some other brand, with a decent driver development team.

BR

Ulrik (Denmark)

Link to comment
Share on other sites

The newest driver was detected as a virus by Norman. Is it really safe?

The drivers are safe, I take every precaution to avoid them.

I double checked with Vipre and Nod32 and squeeky clean

Link to comment
Share on other sites

I just upgraded my system to Windows 7 x64 (clean install) and I cannot seem to install any of the modded drivers. I get an error message saying that my system has not been modified because the drivers are not digitally signed. They worked fine on Vista x86. :)

Link to comment
Share on other sites

I just upgraded my system to Windows 7 x64 (clean install) and I cannot seem to install any of the modded drivers. I get an error message saying that my system has not been modified because the drivers are not digitally signed. They worked fine on Vista x86. :)

The modded drivers ofcourse arn't signed :)

But when installing there should be a warning to say they arent' and you should have an option to go on or stop the install.

If you don't get this then there could be a a setting somewhere that doesn't allow non WHQL driver installs

Link to comment
Share on other sites

hi , i own the abit airfamily wifi card , it works great ov vista but not on windows 7 ,

how do i know what drivers do i need for it?

i dont know what chipset its working on , ive been sent here by abit support .

please help me ,

thanks ,

Ron.

Link to comment
Share on other sites

Guest Another Guest

First of all,

KUDOS for the efforts on the Atheros drivers !! Much appreciated

If I might ask : Additional feature request:

-> enable 5GHZ "outdoor" bands ... these are avaiable in US - 149 and up, gives you higher reach ....

-> enable 100mw for the 5GHZ bands

I switched to Senao 9220 MiniPCI cards for two older Notebooks to access my upgraded WNDR3700 based "A"

network running on channel 149 which gives me the best range ... channel 36.. low bands are more limited

This 149 channel on the 5MHZ band did not show up, channel 36 did tho, Intel 5100/5300 cards do not have any problem on 149

Today I was fiddling around with the drivers from here ... seems channel 14 is enabled for 2,4GHZ

and I was hoping that the additional channels in the 5GHZ bands would be enabled too, seems not.

Would it be possible to get these enabled as well ? Willing to help as far as my limited knowledge goes ...

TIA

Klaus

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...