Jump to content
LaptopVideo2Go Forums

7700 Go OpenGL Trouble


Recommended Posts

Ive been trying to play some old games and having some issues. I installed Call of Duty for some nostalgia multiplayer fragging, but it wouldnt run with the error message "failed to find an appropriate pixelformat". So...

* tried changing windows screen resolutions and bit depths

* tried compatability mode for XP

* tried command line resolution size

* tried it on my brothers computer (also vista - runs no problems)

... then gave up and installed call of duty 2 instead which worked fine, as does all other newer games.

So a bit later i installed Homeworld 2 and had a similar error message about pixel depth. Both of these games seem to be having trouble running OpenGL. My drivers were 165.01 that came from ASUS support site for my specific laptop model.

So interestingly, i completely uninstalled the drivers and Vista defaulted back to ForceWare 97.54 and both Homeworld and CoD work (although Homeworld has a warning about detecting outdated drivers).

I am downloading 163.75 and 163.69 for Vista 32 now and hopefully that will solve the issue *fingers crossed*.

Edited by Crankyhobo
Link to comment
Share on other sites

Yep, fresh graphics driver re-install with 163.75 Vista-32 resolved the issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...