Jump to content
LaptopVideo2Go Forums

Wich driver for nvidia geoforce 8700 GT in a laptop?

Guest Chris

Recommended Posts

Ive tried installing the 163.69 but when I search the folder Ive extracted the files in, I get the message, already updated driver.

But the driver name is fro 06.06.07 but this again is downloaded from toshibas homepage...

I really need help find the right one.

I even tried to uninstall the driver, and got just windows own driver, and a resolution on 1024, and then tried to update, but still got the same message.

Link to comment
Share on other sites

Ok, after searching nvidia.com I found this

Toshiba requires that you download the driver for your GPU from their support site.

You can find more information at: [url="http://www.toshiba.com"]http://www.toshiba.com[/url].

The GeForce Go mobile GPU use drivers that have been customized to support hot key functions, power management functions, lid close and suspend/resume behavior that are normally found in notebooks. The reference desktop graphic drivers that are provided by NVIDIA on our driver downloads page do not include these custom features. For this reason, the NVIDIA Forceware NVIDIA graphics display drivers will not install on most Geforce and Quadro family of mobile GPU's. Some newer laptops have been designed to work with our drivers.

This cant be true...

The current driver I have installed is 101.38.. This is so old I just want to cry... JEEZ...

Link to comment
Share on other sites

I have now registered.

I have done a bit of searching and found out that this driver supports my card:


But the problem is, when I try to install it, it says: (translated)

Drivers for this unit is already updated.

I have forceware 101.38 so this cant be right. Any ideas on how I can fix this.

Ill post every result here when tried.



Link to comment
Share on other sites

Nevermind. Its just stoopid me, that cant read a FAQ.

Ive sucsessfully updated to 156.66.

Ill post here if I get any major errors. If not Im satisfied.

If you wonder what I did wrong, it was that I pressed the wrong option during driver update. Just read the FAQ proporlie and

the rest will go just fine.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...