Jump to content
LaptopVideo2Go Forums

Lost Planet runs imobissibly slow!


Recommended Posts

I've got a vaio vgn fz11m notebook, 1.8 ghz intel core 2 duo processor, 2gigs of ram, nvidia 8400m gt.

I run on 163.69 driver, and games such as quake wars run (honestly) quite very good on medium-high settings, 1024x600.

I've tried running lost planet on dx9 and dx10 mods, on almost everything put to low (video settings) and on 1024x640 resolution, and it runs SO SLOW!! didn't check the fps but there's no point, it just runs awful! I don't think it's normal having in view how (surprisingly) well my pc runs quake wars, fear, stalker, world in conflict, etc.

Any...solutions to this problem?

Link to comment
Share on other sites

hey iudeus, i have some suggestions for you,, not sure if u tried these yet but if not they should help

1. disable AA (anti-aliasing): this feature GREATLY reduces performance... or reduce the resolution several notches and enable 2x anti-aliasing.

(eg. 700x400 with 2xAA looks better than 1000x700 without AA)

2. if you have windows vista, disable windows aero before you start your game. (windows aero is a desktop theme)

3. try other drivers,, im not sure which one isbest for that video card but experiment,, if you havent already

4. read the "how to get good performance in games" topic if you have not already. <a href="http://forums.laptopvideo2go.com/index.php?showtopic=6522" target="_blank">http://forums.laptopvideo2go.com/index.php?showtopic=6522</a>

also you do only have 128MB of dedicated memory,, did you check the reccomended requiements?

well i hope this helps you, if you can post that info, i may be able to help some more.


Edited by Treehead Woodfist
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...