Jump to content
LaptopVideo2Go Forums

EDID override for KVM switch


Recommended Posts


Great forum here. I don't have a laptop, but I see that there are a number of experts on tweaking nVidia display drivers.

The problem I have is related to bad EDID data. I need to override it. I suppose you could argue that it is a buggy EDID, even though this behaviour is intentional on the part of the KVM manufacturer. My KVM (ATEN CS-1764) is connected between 3 computers and a Dell 2407WFP-HC monitor. The Dell monitor supports 1920x1200@60 native resolution. Everything is fine whilst the KVM is switched to the relevant computer, but if I have it switched to PC 2 and PC 1 wakes out of hibernate (for example), the resolution on PC 1 will be capped at 1024x768 and nothing will get it any higher (it simply goes into a "virtual desktop" where you can pan around a 1024x768 frame).

Two of the PCs use ATI cards, and this can be resolved by clicking "Detect displays" twice, at which point it is correctly detected. My main PC however uses an nVidia card, and nothing short of a reboot will get it to detect the correct settings.

The reason this happens is because the KVM emulates a low-resolution monitor (KVM2004), whenever its focus is switched away. Great idea in theory, because a monitor will always be "connected" to the system (surely they could have simply cloned the connected monitor's EDID or am I being thick!) but suprisingly annoying in practice.

What I need to do, is override the EDID for the KVM monitor, to tell the system that it supports 1920x1200@60. Can this be done with OverrideEdidFlags0? Basically, what I want to do is for whenever the KVM2004 is detected, it will treat it as the Dell DELA026. Does that make sense?

I have attached the EDID information for both the monitor I want to "emulate" and the KVM's monitor.

Edit: I've done this, and it seems to be working. Can anyone see anything "wrong" with what I've done?

Windows Registry Editor Version 5.00



Edited by CX23882
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...