Jump to content
LaptopVideo2Go Forums

Atheros drivers with broken 11n


Recommended Posts

I've been on a cable connection to my router as the website server upgrade needed me to download and upload many Gigabytes of data.

Was easier to just be hooked with the cable.

Now the new server is working fine and I wanted my laptop with just the power cable hanging from it and no others.

So the Cat5 cable came out and Wifi came back.

I uploaded the latest driver the other day so I installed this. v7.4.2.15

But I noticed sluggish connection, all I got was 54Mbps.

I tried all my tricks but 54Mbps was all I could get.

I went back another version and this also wouldn't get past 54Mbps. v7.3.1.127

so back further I go, to last driver I really used before going back to cable v7.3.1.109

And finally success 300Mbps connection.

I tried this with both the Gigabyte WI06 and Sparklan 214N, both identical results.

So here is my suggestion AVOID v7.3.1.127 and v7.4.2.15, unless you own an older Atheros chipset where 54Mbps is the max anyway

Stick with v7.3.1.109 for best results.

If you get different results please respond back here with your findings

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...