Jump to content
LaptopVideo2Go Forums
(master)

Battlefield 2: it doesn't work!

Recommended Posts

(master)

Hi everybody,

on my Dell XPS m1530 with a GeForce 8600M GT, Battlefield 2 doesn't work.

I have got WinVista 32bit and already checked the WinXp compatibility option on the .exe and launched it with admin rights.

And i also updated my video card drivers with WinVista 32 bit 169.09 drivers found on this website.

My LCD screen refresh at 63hz.

but NOTHING! it comes back to desktop.

Take a look at my System Requirement Labs ANALISYS: immaginedl4.th.jpg

please help me understanding these informations. thanks.

:-(

Edited by (master)

Share this post


Link to post
Share on other sites
Bill

BF2 was specifically programmed to only run on certain cards. (now old)

That is why I never bought it, they screwed us GF4 users as well as owners of cards that came out after the game.

Maybe if you use a 100 series driver it might work.

Otherwise I think you will need a patch.

Could also just be incompatible with Vista, if you install on an XP partition it may run.

Share this post


Link to post
Share on other sites
Guest C90

I had the same Problem with my Asus C90s and Vista 32 bit.

You have to open the Battlefield 2 icon ,where you can start it with WinXp compatibility and change "...\Battlefield 2\BF2.exe" +menu 1 +fullscreen 1 into +fullscreen 0 and Battlefield 2 starts in window mod.

Now you get an error report and you can identify the problem.

My problem was the solution which can´t be shown in Battlefield 2 and i fixed it in my profile in my Documents.

Share this post


Link to post
Share on other sites
(master)
I had the same Problem with my Asus C90s and Vista 32 bit.

You have to open the Battlefield 2 icon ,where you can start it with WinXp compatibility and change "...\Battlefield 2\BF2.exe" +menu 1 +fullscreen 1 into +fullscreen 0 and Battlefield 2 starts in window mod.

Now you get an error report and you can identify the problem.

My problem was the solution which can´t be shown in Battlefield 2 and i fixed it in my profile in my Documents.

immaginegx7.jpg

what i have to do? thanks

Edited by (master)

Share this post


Link to post
Share on other sites
Guest C90

That´s the same problem, i have.

You have to go in your own Documents. There must be a folder with the name Battlefield 2 and than Profiles. In my there is another folder with the name default with the video.con.

Open this file with the editor and change the resolution into 1024x768@60Hz.

If you have another folder in your Profiles do the same with the video.con, otherwise Battlefield 2 will start and run until you try to start your account.

If it´s work you can start battlefield 2 in normal mode with changing to +fullscreen 1 and change the graphics options in the Battlefield 2 menu to any setting which you want.

As I can see you have a laptop and with a little modification you can play in 16:10 fullscreen by adding after +fullscreen 1 +szx 1280 +szy 800 for an resolution of 1280*800 for example or any other resolution which you want.

Share this post


Link to post
Share on other sites
(master)

Guest C_90 i have to KISS youuuuuuuu!!! IT WORKS!!!!!!

woooooow!!!!! thank youuuuuu!!!!

in the video.con file i have wrote 800x600@63Hz to make it works, because my screen is 63Hz.

now with your trick i play @ 1280x800 :-D

GRAZIE! (THANK YOU!) :-D

Edited by (master)

Share this post


Link to post
Share on other sites
Alanchau

Hello,

well i have tried everything to make battlefield 2 work on my notebook. i have the latest drivers for my 8600M GT and the latest battlefield 1.41 patch but it still crashes when i start the game, with no error message. i have tried to rewrite the video.con file to fit my 59Hertz. but i believe that is soley the problem. Battlefield only, as i heard works for monitors with a refresh rate of 60hertz. i have been diggin up information back to 2005 which people had the same problem and fixed it with forcefresh and other programs that will force a refresh rate of 60hertz but the programs are so outdated and was meant for windows xp. please someone help me so that i can play battlefield 2 and project reality.

custom notebook

Geforce 8600M GT

driver: nVIDIA ForceWare X 162.52 for Windows Vista 64bit

Windows vista 64 bit

4gb ram

Share this post


Link to post
Share on other sites
Guest Guest (Frustrated)

I have the same problem.

I've tried forced refresh and I just get a standard error report (when I open it windowed).

Much the same system specs.

Share this post


Link to post
Share on other sites
STADI

i have the same problem.

If i connect a external Monitor (15" CRT 1024x768), the Videocard switched to 2. Standard Monitor, and it works., an BF2 starts.

The Secound Monitor screens 60hz.

But the first (my Notebookmonitor) screens 59hz. The same Notebookmonitor screens with WindowsXP 60hz.

It could be only a Driverproblem.

Did anyone know, why i can copy the "WindowsXP-Standard-Monitor-Driver" ? (where are it saved in XP ? )

Then i could copy it to WindowsVista....

greets

Stadi

Share this post


Link to post
Share on other sites
Guest Alex
immaginegx7.jpg

what i have to do? thanks

Hey. Thanks for the guidance so far. I am getting the same error report. Except I have Vista 32 bit, Refresh rate of 60 GHZ. So when i try to change my video settings it still doesn't work. I'd appreciate of someone could help me out.

Share this post


Link to post
Share on other sites
Guest samet

hi people im i play bf2 its goes fine everything and i play in a map if i click escape its going to desktop.??? and if i start bf2 it says adjusting osd lockout then it starts

Share this post


Link to post
Share on other sites
Guest Death-Dealer_81

When i open it from the desktop the screen goes blacks (like its about to start) and then all of a sudden it goes back to the desktop

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...