Jump to content
LaptopVideo2Go Forums

GeForce 8600m GS + Mass Effect


Guest Jazz_messenger

Recommended Posts

Guest Jazz_messenger

Hi all !

I am looking for a driver for a 8600m GS in order to play Mass Effect !

With the driver i have now i can't really ply it (i have something like 3 pictures per minute!)

I m really new about laptop and graphic gards and desperate for help !

Thanks a lot ! :)

Link to comment
Share on other sites

Guest Jazz_messenger

First, thanks for your reply :)

I tried the driver you gave me for vista, and there is no change...

I am new with laptops and graphic cards, so i don't know if i have to try other drivers to make the game run alright, knowing this one is doing the job for you, or if i have to look somewhere else on my laptop to solve the problem... :)

Link to comment
Share on other sites

  • 1 month later...

I have geforce 8600m gs - each time i try install drivers (i tried tons, even those given above) i ger the following error "Instalation software of NVIDIA cano find drivers compling with actual hardware. Instalation ended"

Can any one help me with that?

I would like to update my drivers, but i can't do it. Mass Effect gives me dark screen form the very start.

Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...

Strange, u think a 8600M GS would tank Mass effect, 8600GT handles that game flawlessly.

Link to comment
Share on other sites

  • 1 month later...
Guest Guest jussi

I've been having the same problem and I've tried several forceware drivers from 150 -series to the newest 179 driver. So basically, when I try to play Mass Effect, I get like 3 frames per minute. I even tried to run it as an administrator and even tried turning off the UAC, but still haven't got any luck.

Some details:

Vista 32-bit SP1

AMD Dualcore @ 2 Ghz

Geforce 8600M GS, 256 Mt

3 Gb RAM

To me it seems like with those specs the game would run propelry.

Link to comment
Share on other sites

  • 2 weeks later...

See here if it's not too late.

The 8600M GS is apparently quite underpowered compared to the M-GT, so you might want to try turning down some settings?

Also, might want to see if you're suffering from the downclocking "feature" by downloading GPU-Z from here, running it, then starting up Mass Effect and loading a game. This is to make sure the high-performance 3d profile is loaded.

After that, alt-tab and go to the second tab on GPU-Z. According to this link your Core should be around 600mhz and memory 700mhz. Which is significantly higher than my 9500M GS, oddly enough :) Keep in mind this issue doesn't always occur instantly.

If it isn't at those levels, you've probably got the downclocking issue. It seems to be different for every system, however a few things you may want to try:

  • Different drivers. In particular the 169.xx series has apparently been promising.
  • Using powermizer Switch, which is on these forums, to disable powermizer when you're plugged in.
  • Using ntune/rivatuner to "overclock" your card to it's stock settings. If one doesn't work, try the other.
  • Clean out your laptop with a can of compressed air or something. You'll need to remove the cover, but it may help.

Apart from that, keep posting and hope someone can help :)

Link to comment
Share on other sites

Thanks for the help! I'll try to see if I'm having the 'downclocking' issue. I'm using Norton 360 for virus protection and it should go off when starting any game.

I tried 169.xx, 175 and even newest 180 beta drivers and seems like the problem doesn't accord to those. Of course I tried to run the game at 800x600 resolution with minimum graphic levels, but I think I could at least run the game at full res.

Hmm.. If those things won't work, maybe I just have to wait for the PS3 version.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...