Jump to content
LaptopVideo2Go Forums

GPU Downclocking for no apparent reason? Disable Powermizer


Dox

Recommended Posts

I know some people have posted on the forums in our Support Section saying that their gpus downclocks for no apparent reason,

and that temps are fine.

However i just looked at this thread which in turned linked me to this one over at notebookreviews.com.

A user has found a way to disable powermizer in Vista on AC and Battery power by way of registry editing,

This will be useful to those experience downclocking on AC power for no real reason and may solve crashes due to Powermizer (like I experience).

NOTES

*Only attempt to solve your downclocking issues if your laptop has 'normal temps' as downclocking of the gpu usually means high temps that the gpu downclocks to avoid damage!.

*Powermizer can be disabled in XP in the Nvidia Control Panel, some oem inf like clevo has this feature disabled so use Pieter's modded inf when you install :) this 'fix/work around' is more geared for Vista users

From the guide:

Step 1 - Press the "window" key + R . This will lauch a command window. Type ((regedit)) then press OK.

Step 2 - Now navigate to this registry.

\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{**a series of numbers that are different**}\0000\PerfLevelSrc

Step 3- What we need to do once you found PerfLevelSrc is edit it by double clickin and changing the value data from 3333 to 3322. Click ok.

Step 4- Find "PowerMizerEnable" which is probably 5 ways down from "PerfLevelSrc". When you find it double click on PowerMizerEnable and change the value data from 1 to 0.

Step 5 - Find PowermizerLevel and change the value to 1

Step 6- Find PowermizerLevelAC and change value to 1

Close and restart comp. You will now notice no more downclocking.

Full guide with pics can be found HERE

Also I like to give thanks to our forum members for giving support in the forums and for linking us to that 'work around'.

I hope that this comes of use to you and please feel free to post your questions over in the Support Section

Link to comment
Share on other sites

Guest IDReaper

Will now test this on my NP5792 with 8800M GTX. Thanks for the update, I have been searching for a fix to this downclocking problem forever. I'll post my results with 174.90 Official Clevo drivers.

Link to comment
Share on other sites

Guest IDReaper

Both 174.90 and 175.70 still downclock. I followed the instructions perfectly. Do I still need to tell Vista to disable driver signing before installing? Help...

Link to comment
Share on other sites

does it downclock in AC power or on battery?

changing the value of PerfLevelSrc from

3333

3322

and steps 4 -6 only disables downclocking/ powermizer on AC power but it will downclock on battery.

however changing from 3333 to 2222 stops downclocking on AC and battery

please read the original thread if you haven already done so.

http://forum.notebookreview.com/showthread.php?t=261929

Link to comment
Share on other sites

Powermizer needs to be defined in the 'Vista' context...

Ok, powermizer can be a bit goofy, as NVidia seems to change the way it behaves with every driver update.

In Vista powermizer is integrated into the Power Options and Mobility Options.

This is how it SHOULD work in general terms based on your Vista Power Options.

1) Balanced - This is the default setting of Vista. It allows your CPU and GPU to clock down to save energy and heat. It immediately will ramp up to 100% of the CPU or GPU when anything requests more horsepower.

(This setting works well 99.9% of the time although there are few NVidia drivers that are just goofy and don't work as expected)

Balanced also works differently on Battery and on AC Power, the CPU settings can be controled from the Vista 'Plan Settings' - NVidia has not fully added the UI controls to these settings for users, and they SHOULD. So on Battery Balanced with be a bit more conservative on power.

2) Power Saver - This is for getting the most out of your battery, and works quite well - pushing past XP in testing. It sets an upper limit on the CPU, and with SOME NVidia drivers also sets a Max speed for the GPU, reducing speed, but not so much that it affects simple 3D things like the UI or Aero.

Again it works more conservatively on Battery than on AC, and the 'plan' settings can be changed.

3) High Performance - This is for locking your CPU and GPU at 100% speed with no power management throttling anything down.

For most people 1) Balanced should work perfectly, giving you a 'cool' laptop and turning on CPU and GPU speed resources as needed. (In performance testings Balanced should work so well it should equal the performance of High Performance, and still allow the CPU and GPU to down clock to reduce heat.)

NVidia drivers tend to respect and reflect the 3 Vista settings - no matter what temperature your devices are running. So even if your GPU is running cool, setting it on Balanced you will watch your GPU drop down to 300 or 100mhz depending on Video card you have. (As 100mhz is plenty of speed even for Vista's Aero.)

The 'old rule'was that Balanced didn't clock the GPU down as far as Power Saver, but that has changed in newer NVidia drivers.

The old rule used to be like this on a 7950M GTX:

Balanced: 300mhz min - 575mhz Max

Power Saver: 100mhz - 300mhz Max

High Perf: 575mhz all the time

Recent Drivers (17x.x series) do this:

Balanced: 100mhz min - 575mhz Max

Power Saver: 100mhz min - 575mhz Max (On AC, 300mhz or 100mhz Max on Battery)

High Perf: 575mhz

So the reason I am posting this is so that users understand what is happening, as I have encountered people running with Balanced on and they don't understand why the GPU goes into a slower speed when it is not being used. Which is how it should act, and for people with laptops that can make toast are a nice feature for when just browsing the web.

Before turning off PowerMizer (especially on a laptop) test the settings and make sure you understand them and make sure they are not working properly first.

Some 3rd party applications can also mess with the GPU and powermizer, for example a TV application will sometimes shove the GPU to 100% even if it isnt' needed (Some will even turn off Aero and it isn't needed either)

Also...

Some of the moddified INF files from this site mess up the PowerMizer settings for difference series of GPUs, as it would be hard for the person writting the INFs to properly compensate and set them for all the Video cards. If you can use your MFR inf files, they will work better most of the time (unless your MFR sucks and doesn't release new drivers very often).

NVidia doesn't document the driver inf information very well, nor do they document the default behaviors of all mobile GPUs, so getting a complete and custom INF that works perfectly is not easy to obtain, even though this site's contributors do a fantastic job.

When your game or 3D applicaiton needs more performance, in Balanced mode your GPU should jump to optimal performance instantly.

Test the settings with your laptop and game. You may just need to set Vista's power options to High Performance for your GPU to behave properly or how you want, (and you can still allow the CPU to scale down via the Vista Plan Settings for High Performance)

Also if you are using a custom plan, and have 'renamed' it from one of the three standard plans, this can confuse some software or drivers sadly (poorly written they are). Move back to one of the 3 plans, and just modify it with your settings instead of creating a new one and see if your results work better.

Before everyone turns off Powermizer, make sure this is the only option left to you, as a 7950M running at 100% all the time would strain even the best Laptop cooling out there, and is not needed for Aero or light 3D applications like WPF/Silverlight, etc...

Good Luck to everyone...

Link to comment
Share on other sites

Guest IDReaper

Yeah, unfortunately I am on AC, followed the original instructions exactly. I think it is my Vista 64 and it's driver signature secutrity. I get a fixed 275/300 when I disable powermizer on 175.70.

Link to comment
Share on other sites

:) NetAvenger!

Link to comment
Share on other sites

Yeah, unfortunately I am on AC, followed the original instructions exactly. I think it is my Vista 64 and it's driver signature secutrity. I get a fixed 275/300 when I disable powermizer on 175.70.

I saw the original post a few days ago and tried it then. Im running vista 32-bit, and it did'nt work for me either

I found another way to stop my system down clocking. In the BIOS of your system you can DISABLE 'speed step'

Now... this DOES make the CPU run slower, but it cools down the CPU and GPU by 20 Oc on my system. So i don't have the down clocking problem.

I am also able to overclock an awefull lot more than ever before.

Games don't require much CPU power anyway, only every used like 50% at most for me.

I'd recomend it, as heat has always been the enemy : )

Edited by wook
Link to comment
Share on other sites

I think the downclocking is not an issue of powermizer or the vista power management because (at least in my case) the GPU is clocking down DURING gaming eg. AoC. And no one can tell me the game doesn't stress my system.... :)

The GPU clock will just come back to 500MHz (8600M GS) when I'm restarting the laptop or, as I recently found out, when installing an new driver via the "have disk" method after the GPU clocked down. Further there are (older) drivers out there, wich will not show that behavior.

Link to comment
Share on other sites

I saw the original post a few days ago and tried it then. Im running vista 32-bit, and it did'nt work for me either

I found another way to stop my system down clocking. In the BIOS of your system you can DISABLE 'speed step'

Now... this DOES make the CPU run slower, but it cools down the CPU and GPU by 20 Oc on my system. So i don't have the down clocking problem.

I am also able to overclock an awefull lot more than ever before.

Games don't require much CPU power anyway, only every used like 50% at most for me.

I'd recomend it, as heat has always been the enemy : )

Can someone tell me how do I disable 'speed step' in Acer 5920G?

(k1ck-idro) (CPU1) Intel® Core?2 Duo CPU T7500 @ 2.20GHz @ 2201MHz (Acer, Inc. Chapala mainboard) (RAM) 2GB, 996.54MB free (HDDs) 219GB, 93.6GB free

(k1ck-idro) (VGA1) NVIDIA GeForce 8600M GT (512MB), 1280x800x32, 60Hz (OS) Microsoft® Windows Vista? Home Premium (SP1), 16h 36m 57s uptime, 16h 36m 57s uptime record

Link to comment
Share on other sites

i was able to test this before i moved to ubuntu fully (no dual boot)

and it does work :)

Link to comment
Share on other sites

when you browse to \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\ in regedit.

you should see three random numbers.

pick one of the three

and then choose \0000

and the one that has a list of games (game profiles), that is the one with the PerfLevelSrc

Link to comment
Share on other sites

Guest Guest-tex

I tried this, but Powermizer is still downclocking my video card for no reason whatsoever. 8400m gs running at 61c, still downclocking. Runs at 59C normally.

Link to comment
Share on other sites

I wouldn't just disable PowerMizer, there is a report that nVidia chips might be overheating... Vista could be saving some peoples arse. Posted about this problem in the Support Side.

Link to comment
Share on other sites

  • 3 weeks later...

Nope it's definitely the gpu since nvidia monitor shows a gpu core clock of 275

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...