Jump to content
LaptopVideo2Go Forums
Sign in to follow this  
xenomeno

Summarize 1667 MXM upgrade

Recommended Posts

xenomeno

Do you have any pictures or guides how to remove the motherboard. I'll try to remove the IDE connector after that. I think it's not soldered but just plugged in and screwed with the screws facing down(which is the problem with removing it).

Also do you know from this forum what's the biggest HDD that can be installed in 1667? Uniwill specs at their sight says 120gb but I think that was the biggest HDD at the time when the laptop was released ...

Today we've just ordered another 2nd hdd kit for the other 1667. I think if the IDE connector is removed the cable in the kit is not needed at all because the board will be plugged in the white thing behind the SATA connector.

Share this post


Link to post
Share on other sites
Guest bodycount

Hi again, sorry for answering so late - have been on holidays!

Have you been successfully upgraded your system to SATA?

So I wrote the guy who made it but he does not have his a166g any more! He told me that he used a 200gb SATA hdd with the uniwill 1.07c bios! He also told me that there are some little differences in these a1667g series! So that's what I also had to find out with my geforce 8600gt- Kris has been testing it again in 2 different systems and it works just very well! Maybe this could be the same situation with the connector - On my mainboard it's close to the IDE connector and on your it's not! I don't know what Fujitsu thought about this!

I'm going to tell you my story later when I'll have been changing my hdd! Primarly I'll fix/upgrade my VGA from 7600 to a higher version!

Share this post


Link to post
Share on other sites
xenomeno

Yes, I've managed to install my old 100gb SATA but using the cable coming with the conversion board. I don't see SATA connector next to the IDE one. The ide one is just plugged in something white that looks like a SATA connector(maybe some kind of a conversion board). I'm looking for some pictures or manuals how to remove the motherboard so I can unscrew the screws of the IDE connector and see what's behind it. Tommorow I'm getting the other HDD kit for the other 1667g and maybe we'll try to open it completely. Any suggestions on the german forum about that?

Share this post


Link to post
Share on other sites
Guest bodycount

I'm not quite sure but I think you should also remove the keyboard to see some hidden srews! I think I've seen them as I've been cleaning my keyboard a few months ago! Maybe you'll checkit out tomorrow otherwise I'm going to check that again during the next days because I'll get my VGA back!

Good luck for tomorrow!!!

Share this post


Link to post
Share on other sites
Guest bodycount

Hi again, got my 8600gt back and it doesn't work either! Seems to be the pin configuration of tha vga! It differs from the one of the mxm connector and also from my current 7600go/x700! I think it'll be possible to solder a new pin configuration, but I don't want to do that with my system! This should work without this! Maybe IceTea got another solution or I'll have to buy a new and more powerful system (Clevo M570TU with centrino 2 and 9800gt) becuase I'll need a more powerful system (again) for my universtity studies(cad works etc.) which continue in a few weeks!

For all who want to upgrade this system be 100 %ly sure that the pin assignment of the new vga is the very same as the pin configuration of your old vga!!! That's what I found out, because the current 7600go and ati x700 does have the same configuration! The tested 8600gt and 6800go had on their part the same configuration but this vary from x700/7600!!!!

For my share I tested any possible thing - 90W PSU and 120W PSU, bios upgrades of mainboard and vga, hardware resets, ...!

Maybe I got one of those a1667g series that doesn't support anything but something! Perhaps uniwill produced 2 different types of mainboards???

Share this post


Link to post
Share on other sites
xenomeno

well, I'm with this one and it definetely works for mine 1667.

http://cgi.ebay.com/ws/eBayISAPI.dll?ViewI...52BSI%26otn%3D4

A month ago the price was 50$ lower :)

I'm thinking for Clevo too but D901C with 9800GTX Sli maybe :) Howevere it's not selling here in Bulgaria. Can you find it in Germany? I was thinking about Sager's NP9262 vesion when I'm goint to USA during september. Any other suggestions about Clevo resellers?

Cheers

Share this post


Link to post
Share on other sites
Guest bodycount

Spontanously I can tell you 4 German homepages where to buy clevo systems:

www.notebookguru.de

www.mysn.de

www.cyber-system.de

www.deviltech.de

It's possible to select English or whatever as your preferred language for your order! They all offer centrino 2 systems with Geforce8800GTX/9800GT but they will be able to sell 9800GTX and hopefully ati 4850/70 by the end/beginning of September too!

Share this post


Link to post
Share on other sites
Guest bodycount

Hi again,

Within the next few days I'll get some new VGAs! Atix1800/hd2600 and geforce 8600gs! I'm going to check the compatibilty and tell you later about it.

Share this post


Link to post
Share on other sites
xenomeno

It will be interesting to know which of them works in the 1667 and whats their performance/temperature. However I've almost decided about purchasing Clevo's D901C int he face of sager's NP9262 from www.sagernotebooks.com when I go to the USA after a few days :) They are a lot cheaper than hear in Europe. Here's a list of mobile cards comparsion table

http://www.notebookcheck.net/Mobile-Graphi...List.844.0.html

The first entry with the 2x512MB 9800GT SLI has just appeared but it's still not filled with data. It will be interesting to compare it with the single 9800GTX with 1gb VRAM.

About the SATA question: there's no way to remove the IDE connector walking the keyboars way - it's not visible from there. We cut it with a SAW !!!! And guess what - there's no SATA connector behind it !!! So the only SATA connector is the one on the other side of the laptop. The good thing about the ugly cutting is that the notebook with the SATA conversion board firts perfectly and the HDD pad from the notebook's bottom now fits normally. We've tested with 200GB SATA Hitachi @ 7200rpm and it almost double the perforance - about 60mb/s, 15ms access time, a little bit lower burst rate - 90mb/s but higher CPU usage around 8-9%. The higher transfer rate is due to the double density according to the 100GB Seagate Momentus.

Share this post


Link to post
Share on other sites
Guest Smartass

Hey i have the same laptop, what is the difference between a SATA 7200 rpm and an ATA of the same speed? Wouldn't it be more convenient to buy an ATA one and not put yourselves in this procedure?

Share this post


Link to post
Share on other sites
Guest bodycount

Hi,

There is a clear and big differnce between SATA( Seriel ATA) and ATA (parallel ATA also known as IDE or U-ATA)!!!

The fastest solution (theoretically) is SATA but for the A1667G please take a normal 2,5" hdd from Hitachi (Travelstar ...) or a WD with 7200 rpm!

Concerning my vga problem:

Today I received my first new testing candidate (ati hd2600). Hope to get it working. Next week the x1800 and geforce 8600gs will have also been arrived!

Hasta la proxima colegas!

Share this post


Link to post
Share on other sites
Guest Smartcule

Alright ATA it is then.

Anybody knows how to remove keyboard? It doesn't work and i'm planning to replace it.

Share this post


Link to post
Share on other sites
Guest quipster
Alright ATA it is then.

Anybody knows how to remove keyboard? It doesn't work and i'm planning to replace it.

Look out for some black rectangular notches around the keyboard. They keep the keyboard in place and can be pushed back with a flat screwdriver to allow removal.

Share this post


Link to post
Share on other sites
Guest Smartcule

Hi again.

All of sudden the laptop would get slower, problematic shutdowns until a couple of days later it wouldn't boot into windows. I have 3 partitions, and windows XP on two of them (3 partitions, 2 separate window installs). So i booted with the other one, did a virus check and removed several viruses. But now i have this problem with dvd-rom, it won't recognize it? Or when it does it appears like some random letters and symbols instead of the NEC-6550A it used to be. Is it possible that a virus could have damaged the dvd-rom?

And how can i flash this under windows? Is there a flashing utility i should download?

Thanks in advance

Share this post


Link to post
Share on other sites
Guest Smartcule

Alright folks, i took out, cleaned it, installed new firmware and it looks like it's working again.

Share this post


Link to post
Share on other sites
Guest bodycount

All right folks, today I received 3 new vga's from Kris and what should I tell you - all of them work just very well!!! I got an ATI x1800, a geforce 8600 gs and a 8400! All of them with original vbios revisions. It's a little tricky why the 6800 and 8600 gt didn't work!!!

Maybe it's the mxm connector!

Share this post


Link to post
Share on other sites
xenomeno

hmm, that's another approach :) It will be interesting to see the results comparing to mine conversion board. And also how you will manage to plug it inside :)

I'm just installing the NP9262 now :P

Share this post


Link to post
Share on other sites
Guest asd

Any luck with the adaptor? It seems they don't make PATA at 7200RPM anymore so converting to SATA is the only way for an upgrade.

Share this post


Link to post
Share on other sites
Guest Guest

It's no converting, the laptop supports SATA. Also better choice that PATA because of the higher bandwidth supported.

And now - solution of the ANNOYING noise produced by the crappy fan:

I've installed this one:

http://www.pchub.com/uph/laptop/88-36484-6...oling-Fan-.html

which has MAGLEV technology instead of bearings and is completely silent.

I would recommend this one though as it is 1mm wider and fatter so it will better fit. Anyway both solution are great, for the second one- cut the ears out and superglue it to the heatsink - first one - the same.

http://www.pchub.com/uph/laptop/88-37266-6...oling-Fan-.html

With all the upgrades available to this 3yr old machine, it seems I'll keep it around for a while.

Share this post


Link to post
Share on other sites
Guest bodycount

Hi again,

The system definitely supports SATA. Works just fine. I'm planning to buy a new system (Clevo m570tu). So there won't be any further tests with the a1667g in the near future!!

Share this post


Link to post
Share on other sites
Guest Dexx

Some one tried to update VBIOS in 8600gs before running in FS a1667g.

some one have a1667 witch 8600gs running?

I have 8600 but i become whitescreens and with x700 it is ok.

Should i sell this card or it is possibility to run it on a1667g

BTW: sorry for my English.

Share this post


Link to post
Share on other sites
Guest bodycount

Some 8600gs/8600gt modules work and others don't!!! It's a miracle because I tested the 8600gt with different vbios versions but nothing changed!!! The 8600gs worked very well with the first vbios version Kris installed!!! Maybe you get in contact with Kris from mxm-upgrade.com and he tells you the version and maybe he can send it to you!!!

Share this post


Link to post
Share on other sites
dexx

but how to flash vbios witch whitescreen ?

BTW do you have email to Kris i can't find it

i read something about MXM in the MXM_electro_spec ( http://www.nvidia.pl/object/IO_13290_pl.html )

The MXM will automatically detect power supply limitations and thermal limitations

of the platform and will automatically throttle its clocks to stay within the power

and thermal limits. If the platform?s power supply and MXM thermal cooler are

equal to or exceeds the MXM power requirements, the MXM will run at full speed.

The MXM system information data contains the necessary information for MXM

throttling. This data is stored in either the SBIOS or the MXM system information

ROM on the system?s motherboard.

the MXM connector is the same in MXM I and MXM II the this must be software problem of SBIOS or VBIOS

Edited by dexx

Share this post


Link to post
Share on other sites
xenomeno

Wow, there was a progress in this thread while I was away :)

New SATAs, new fans :) I wonder if the 9600m GT 512mb DDR3 will fit in the 1667 :P Does anybody tested it yet?

My brand new Clevo 901c is dead and I'm back on the Amilo until I find a way to repair it. So I was wondering about the new fan. I'm using it on the notebook cooler which I bought with the NP9262 and it's definetely much cooler than before. The 8600GT instead of the ATI x700 helps too I think.

But as someone said before this 3years old machine is a tough one :P

Cheers

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...