Jump to content
LaptopVideo2Go Forums

No hardware acceleraion with 8400M G


bxf

Recommended Posts

My previous laptop had a 7600 GO, which gave me hardware acceleration for HD video by simply using KM Player + Cyberlink H264 decoder with "Use DxVA" selected. Acceleration also worked for VC-1 when decoded by WMVideo Decoder DMO. Under either of these conditions CPU usage figures were so much lower than with other setups that there was no difficulty in determining that hardware acceleration was in fact taking place.

Some thieves made off with the aforementioned laptop (and my wallet), so I bought a new LG, which has the 8400M G card.

I installed the 175.19 driver, after adding the appropriate statements to the INF file, and "everything" looks OK.

Except that I can't get hardware acceleration to work, no matter what I try, neither for H264 nor VC-1.

Although I don't see how this could make a difference, I may as well mention that on the previous machine I had PowerDVD installed, whereas now I just registered the decoder. It works, but there's no difference with DxVA selected or not, and the CPU figures clearly indicate that no acceleration is in effect.

I chose the 175.19 driver only because that's the latest one showing on the Nvidia site for the 8xxx series cards, even though it's not intended for the 8400M G. I know that much is made of different drivers for various cards, but these discussions usually focus on gaming performance. But perhaps I'm missing something. Is it possible that, for any given device, some older drivers support acceleration, and more recent ones do not? Is it possible that although a driver installs cleanly (and works, for the most part), not all it's features will become available to a device manually added to the INF file?

I'm running XP/SP3.

Any suggestions would be appreciated.

Thanks.

Edit: I just tried an older driver, but one which is intended for the 8400M G. Unfortunately, the situation is still the same.

Edited by bxf
Link to comment
Share on other sites

To help other users that may be agonizing over this issue, it appears that although the 840M G hardware has H264 & VC-1 acceleration capabilities, there is no software support for this yet (I hope "yet" is correct) - at least not for XP. Hardware acceleration for MPEG2 appears to work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...