Jump to content
LaptopVideo2Go Forums

1080p hdmi > tv out shows black bars


Chad

Recommended Posts

I got a Sharp TV, 32" LC32GP3U-B (1080p full). I connected an hdmi cable from my laptop (1080p certified) to the TV.

BLACK BAR TV OUTPUT PROBLEM

I do not get the full screen output on my TV when connected via HDMI. The TV itself works fine in full screen (1080p). I DO get full screen output on any Linux o/s I test it with, via hdmi such as Ubuntu. However, I prefer to use Vista instead in order to use MCE and the plug-ins I have (Netflix, Joost, etc plus MCE remote). I duplicated this before and after upgrading to Vista SP1. I've duplicated this with many WHQL certified NVidia drivers as well. Literally about 10 different driver versions for my 8400M GT card. I cannot figure out why it is not showing full screen output, but I can confirm this happens in Vista only, not Linux (did not and will not test in XP). My index score in Vista is 5.3.

Nvidia panel shows proper 1920x1080 resolution.

Some drivers I've tried and duplicated the same problem:

174.93

175.12

167.43

163.75

Also, my TV settings are certainly proper since I do get full screen output in Linux and general TV viewing. I did try several new HDMI cables too, but thats irrelevant since it works fine in Linux.

Summary of settings / methods to fix the problem:

- 1920x1080p resolution (59 and 60Hz, same black bar problem)

- various Nvidia drivers

- Nvidia nTune overclocked (but keeps resetting back to factory on reboot)

- disabled aero interface in Vista

Hardware / Software:

Sharp TV 32" LC32GP3U-B (1080p) supposedly called a "gamer tv" by Sharp themselves

Nvidia 8400M GT (1080p)

Vista x64 Ultimate with SP1

Vista Codec Pack + 64bit components

DirectX10

I Googled "sharp LC32GP3U firmware" and cannot find any info on upgrading the firmware. The TV does have a software upgrade option via usb, but where these software upgrades to be found? No where on Sharp's site.

Link to comment
Share on other sites

I found a not so great solution to get proper full screen. The *only* way I can get full screen is by setting the TV's refresh rate to 23Hz within the Nvidia control panel. Setting it to 59 or 60Hz will result in black bars. Setting it to 23Hz however results in not so great quality, even on DVD.

Any ideas from here?

PS: Sony does not provide 64bit support/drivers at all. I get the drivers from laptopvideo2go.com

Right now I'm using drivers 174.82

Link to comment
Share on other sites

Guest Guest

Hi,

I experience exactly the same problem, I have a Dell M1530 with HDMI out to my Samsung LE40M87BD, using any drivers I get a black border about 1 inch all the way around the screen, Laptop and TV report 1920x1080p.

Try using drvers 165.01, this rectified the issue for me but the drivers have other performance issues so not the best perm fix, not sure if anyone else knows of knewer drivers that will work.

Link to comment
Share on other sites

  • 3 weeks later...
Guest danello

Exactly the same issue, Vista Ultimate x64 SP1 and Aquos 42XL2E, i tried out several forceware on my 8400M, nothing helps.

Xp x64 (with every drivers release) and Linux work fine.

Just disappointed. :)

Link to comment
Share on other sites

  • 3 weeks later...

Anyone found a solution to this yet?? I just got a new 42" tv that supports 1080p. But I get black borders if I go over 30 Hz refreshrate. I tried with my stationary computer with DVI and it works fine at 60 Hz. This is really frustrating.

Edit: I tried the 165.01 drivers mentioned above and now it works at 60 Hz so it is definately a driver problem.

Edited by ainatar
Link to comment
Share on other sites

Does noone really know anything about this?? I don't think using a driver that is more than 1 year old is really a good solution. There must be something else that can be done, or? And many people must have this problem.. Installing XP can't be the only solution I hope..

Edited by ainatar
Link to comment
Share on other sites

I'm using 174.31 on my XPS 1530, and no black borders whatsoever :)

I had black borders with 177.41 though (except on 1080p24)

Black borders with that one to. Its because nvidia scaling is greyed out. Why have they done this?? Because a hdtv is connected?? When a normal computer monitor is connected the nvidia scaling is enabled. Im so tired of this s***..

Edited by ainatar
Link to comment
Share on other sites

Haha I fixed it. Under the menu where you can create your own resolutions, I just unchecked treat as hdtv and now there are no black borders :-) Now all the new drivers work :-)

Edited by ainatar
Link to comment
Share on other sites

  • 4 weeks later...
Haha I fixed it. Under the menu where you can create your own resolutions, I just unchecked treat as hdtv and now there are no black borders :-) Now all the new drivers work :-)

Where do you create your own resolutons?

Link to comment
Share on other sites

  • 3 weeks later...

If you are using an nvidia card. Right click the desktop and open up the Nvidia Control Panel. There should be an option to Manage Custom Resolutions on the left hand side of the screen, click that and the option to create your own resolutions will appear. As for the "Treat as HDTV" checkbox, i have no idea what ainatar is talking about. Hope this helps.

Link to comment
Share on other sites

Guest Guest0009
If you are using an nvidia card. Right click the desktop and open up the Nvidia Control Panel. There should be an option to Manage Custom Resolutions on the left hand side of the screen, click that and the option to create your own resolutions will appear. As for the "Treat as HDTV" checkbox, i have no idea what ainatar is talking about. Hope this helps.

That option does not seem to be in my list of options under NVIDIA Control Panel.

2vdhgdk.jpg

Link to comment
Share on other sites

  • 1 month later...

I'm still having this issue.

Look what I found from Sharp's website for my model TV anyway

http://www.sharpusa.com/files/tel_man_LC32GP3U.pdf

(complete list of TV model's manuals)

http://www.sharpusa.com/products/TypeManua...083,127,00.html

Read PC compatibility chart on page 18

False advertising anyone??? Never advertised the limits on pc connection at all when I bought it. Never seen such "notice" statement.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...