Jump to content
LaptopVideo2Go Forums

V-Sync + Stutters Problem...


Guest cdahmedeh

Recommended Posts

Guest cdahmedeh

Hello,

I am currently using a Dell XPS m1530. I've noticed that espicially in DirectDraw Games, I get Micro-Stutters when V-Sync enabled. Using Kega Fusion, I've discovered that the refresh rate is locked at 59.5. However, my refresh is really 60hz. I've decided to try an external display, the frame rate was at 60.0 and there were no stutters. Using the nVidia Custom Resolution utility, I've forced the refresh rate to 60.499 and Kega Fusion would show 59.9 FPS. The stutters happened less often but were still there. The stutters I'm talking about are micro-stutters.

Dell XPS m1530

1680x1050 screen

8600m GT 256MB GDDR3

Drivers version 174.31.

Finaly, I've noticed that using the Dell Official drivers always showed the same problem. However, when using drivers version 178 for example, the problem was much worse.. and the stutters happened almost every second.

Anyone know what the solution is... and why dosen't the problem happen on a external display (tried it on two one Samsung Plasma TV (using VGA) and a Compal FM678 Monitor LCD)

Thanks

Link to comment
Share on other sites

Guest cdahmedeh

I've did more testing to find out what could be causing the problem.

It seems that nVidia is having a problem with the refresh rates and V-Sync...

It always tries to set V-Sync to 0.5 FPS less than the refresh rate.

So if the refresh rate is 60.5, V-Sync will be at 60... If refresh rate is at 59.5, V-Sync will be at 59.0.. ans so on....

For some reason... this problem occurs only on the laptop display. No problems on external displays.....

Does anyone else have this problem ? Does anyone know what the fix is ?

Link to comment
Share on other sites

Guest cdahmedeh

Doing more trial and error, I've discovered that the problem has something to do with triple buffering. Certain programs that use DirectDraw allow you to turn off triple buffering. It solves the problem... and the frame rate is stuck at 60 fps instead of 59.5 fps. However, certain applications don't. Using a utility called D3DOverrider that comes with RivaTuner I was able to disable triple buffering. Only one problem, the effect of the application seems to be temporary. For example, in Kega Fusion, the application starts normally with 60.0 fps.. but after a while, it returns 59.5 fps and the stutters come back....

Link to comment
Share on other sites

  • 12 years later...

HINT for Kega-Fusion:

On modern Windows 10 systems (Win 10 20H2, NVidia 462.31+, G-sync) remember to force G-Sync OFF to finally remove annoying "hiccups" and stuttering in fullscreen.
You can use NVidia Profile Inspector.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...