Jump to content
LaptopVideo2Go Forums

[Help] to disable Smartdimmer


nyo11

Recommended Posts

i set my monitor for a certain minute to do screensaver and eventually turn it off (e.g. 10 minutes to screensaver, 15 minutes to turn off monitor).

after the monitor is off, then I move my mouse to power it on, but it stays somewhat black. The monitor is already on though, but the light is very dark, almost black, and I hardly see a thing on my desktop.

usually I restart and everything goes back to normal again, or you access: nvidia control panel -> smartdimmer -> just move the slider randomly and the light goes back on (hard to see since everything is dark). this is so annoying.

I try disabling the smartdimmer by ticking "disable smartdimmer" in nvidia control panel, but it won't disabled. it keeps enabled.

so, anyone know how to disable it permanently rather than using the nvidia control panel?

my spec:

Vaio, G8400M GT, driver 177.79. XP SP3

Link to comment
Share on other sites

you need to reinstall the driver again.

however you need to delet some entries in the inf before you reinstall.

open the inf and find and delete:

(under [mobile tweaks])

HKR,, EnableBrightnessControl, %REG_DWORD%, 1

(under [nv_ControlPanelSettings])

HKLM,"SOFTWARE\NVIDIA Corporation\Global\NVTweak", SmartDimmerConfig, %REG_DWORD%, 2

HKLM,"SOFTWARE\NVIDIA Corporation\Global\NVTweak", SmartDimmerEnable, %REG_DWORD%, 1

save and reinstall the driver.

it should remove the smart dimmer

Link to comment
Share on other sites

wow

thanks bro Dox

i will give it a try right away

Link to comment
Share on other sites

had the same problem. my monitor always went blank as some kind of screensaver, although i had disabled everything of this kind.

after moving the mouse or pressing a key, the monitor went on, but damn dark.

thanks to this tip the screen stays on :)

many thanks :)

Link to comment
Share on other sites

you could also try this:

leave all settings as they are but add these to the inf under [mobile_tweaks]

HKR,, PanelPWMFrequency, %REG_DWORD%, 200

HKR,, PanelBrightnessLimits, %REG_DWORD%, 0x0000FF32

first line = max brightness slider to 200

second line = minimum brightness set to 50 (without this line I'm guessing the default minimum was 00 hence the blackness)

regards

Link to comment
Share on other sites

nice..

works like a charm..

thanks a bunch again bro

Link to comment
Share on other sites

you could also try this:

leave all settings as they are but add these to the inf under [mobile_tweaks]

HKR,, PanelPWMFrequency, %REG_DWORD%, 200

HKR,, PanelBrightnessLimits, %REG_DWORD%, 0x0000FF32

first line = max brightness slider to 200

second line = minimum brightness set to 50 (without this line I'm guessing the default minimum was 00 hence the blackness)

regards

since i have max brightness of 255, so i change those value above to:

HKR,, PanelPWMFrequency, %REG_DWORD%, 255

second line is the same

thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...