Jump to content
LaptopVideo2Go Forums

FPS dropping all of a sudden from 60 to below 10


g1real

Recommended Posts

Hello everyone on this awesome forum (And trust me, this forum is awesome, to have people being so dedicated to helping out with driver problems and laptop stuff is... awesome?)

I've been having trouble lately, and I can always use the simple way out of reinstalling vista by factory defaults on my Acer Aspire 6920G, the machine is about 2 months old now and I'm perfectly fine with it. The only problem is that it sometimes drops in performance until I quit the game and restart it again, and it just happens randomly! At any given moment!

I bet y'all know the specs of a 6920G, and if not, it's in my profile. This review explains a lot about it if you're to lazy to google it, I'll do it for you (After all, free support!)

I've been using the standard drivers acer provided me from their website, altough I wasn't entirely happy with that, because they're not being updated (as far as I know, they haven't yet) and the FPS lag didn't fix. Now I tried using an option provided me in the facepunchstudios thread (increasing paged pool) I made, that didn't do any damn thing either, I think it's the configuration of my mobile video card downgrading itself somehow while playing games.

I'm downloading 3D mark '06 right now to get some performance results, for the fun and it might be helpful to have it ready.

And here are some general experiences with games I played and the FPS I gotten from it.

Team Fortress 2: 60-80 high, 20-30 High combat, 4-5 when it messes up. (Graphics: Recommended, a bit tuned down, this is all settings on high, no AA, HDR, and I believe some stuff disabled, I'll make a screeny if needed)

EVE Online: I've gotten 60 FPS for like a whopping half an hour, but overall it always was 18 to 30 to me (depending where I looked with the camera and what I was doing) (Full power settings, which I should easily be able to handle, because of the 60 FPS I had gotten before, it suddenly jumped to 10-20 after that half hour)

TES: Oblivion: I generally get 15 FPS, but I turn up the settings pretty high there, and it's modded, I still think it can do better as I've seen people playing with worser videocards at 30 FPS.

Garry's mod: 140-180 FPS on a non-detailed map, as soon as I've put some strain on it (rendering like 50 physics props) it went down to 40-60, which is perfect!

I hope this helps, gave enough info, I hope someone can help me. I'll be closely watching this thread.

Link to comment
Share on other sites

Sounds to me like your video card is downclocking due to PowerMizer. Try updating the drivers. If this doesn't help, then disabling PowerMizer would also be a good idea. You might also want to check the GPU temps, because sometimes problems like this can be caused by overheating.

Link to comment
Share on other sites

I tought so, updating the drivers to what? I am/was using the latest version from this website, I'm trying to clean the drivers completely and then reinstalling them to be sure. I'll go look around the forum on how to disable powermizer, and I hardly think it's an overheating issue, the laptop doesn't even feel warm and EVEREST keeps saying the temperature doesn't get higher then 60-ish

(I can't find that program that rids you of the drivers completely, any help on this?)

Edit: Is there any way I could get the GPU temp to show ingame

Or wait, I'm running windowed, I might be able to move the window a tad.

Edit: Disabled powermizer, got a hacky way to uninstall the drivers (used the normal way to remove it, didn't seem to clean everything, so I also uninstalled drivers in device manager, but that glitched for me, it was using an older version anyhow so I removed the dlls with nasty file remover) then I reinstalled the modded inf drivers and the system tools for nvidia, I'm trying to get it to overclock with 25 mhz, as long as it keeps under 75 degrees, but it doesn't seem to accept it somehow.

*Sigh* Issues, issues!

Edited by g1real
Link to comment
Share on other sites

Gonna bump this one, since the issue didn't solve yet.

Now I also wanted to overclock, and I heard rumors here and there that they wouldn't work for 1.7x versions, so I tried using the last 1.6 driver, however things messed up so hard uninstalling and reinstalling that the video card isn't recognized anymore.

Before this however, I still noticed downclocking a few times, like in 5 minutes after playing oblivion (ugh, 3 FPS) and in TF2 after some heavy combat.

Powermizer was disabled, but I can't find it back in the registry anymore to mess about with it. Any help?

post-28863-1220013660_thumb.png

Link to comment
Share on other sites

1.7x version support overclocking, you can use RivaTuner.

I recommend you to uninstall the nVidia driver from your software list. Boot into safe-mode and let DriverSweeper (http://phyxion.net) remove the driver rests.

Then startup in normal mode again. In case your screen stays black (which happened to me few times), boot into safe-mode again, rightclick your video card in Device Manager and uninstall it; boot into normal mode.

You can check my Powermizer Switch if you want under http://forum.notebookreview.com/showthread.php?t=273276

Good luck.

Link to comment
Share on other sites

I've fixed the drivers by system restore, so everything's up to date and fine now, it still wont let me overclick with rivatuner.

I've disabled powermizer and I still get underclocked frequently, it's really pissing me off.

Edited by g1real
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...