Jump to content
LaptopVideo2Go Forums

Spore (Go 7950 GTX)


Hellscreamy

Recommended Posts

I recently got myself Spore, but every time I get past the EA Logo (Intro Movie) my screen freezes. This is solved by doing Ctrl Alt Delete and then go back to Spore.

However, this also happens when:

  • A window with info pops up ingame
  • When scrolling over items to attach to my creature
  • When selecting which phase I want to play (Cel, Creature, Tribal etc.)
  • Continuously during loading screens between phases. I have to spam-press Ctrl-Alt-Delete to actually load anything.
  • When opening my 'Sporepedia'.

The screen freezes, it won't load anything and it cannot be solved without pressing Ctrl-Alt-Delete.

I managed to reach the Tribal phase (3rd part of the game) by pressing C.A.D. a lot, but I cannot get past this loading screen for some reason.

When I browsed EA's forums I discovered the problem lies with Spore running on notebooks/laptops that have a Go Card.

I run Vista SP1 and I run the latest driver for my Nvidia GeForce Go 7950 GTX I found on my manufacturer's site.

What should I do?

Link to comment
Share on other sites

i'm using the driver 174.74 and i'm running spore on max settings at 1900*1200 with no problems

Link to comment
Share on other sites

i'm using the driver 174.74 and i'm running spore on max settings at 1900*1200 with no problems

I'll try that driver, just have to find a back-up of my current driver first.

I found the following driver on Nvidia: http://www.nvidia.com/object/winvista_x86_...75.32_whql.html. Gonna try it now.

Edited by Hellscreamy
Link to comment
Share on other sites

I also have this problem with Spore.

My laptop has a geforce go 7600. And I can't seem to fnd a working driver. I tried that version you mentioned, but when I tried to install it. it said that it couldnt continue the install because it couldnt find the matching hardware for it or something. I'm now downloading 17631. Hopefully that will work.

Looking at this thread for more answers

Link to comment
Share on other sites

That didnt work either. Because I could only download a vista x64 version of that driver. This sucks! please somebody help me find a new driver for my geforce go 7600. I just want to play spore!

Link to comment
Share on other sites

EDIT: Using a scan from the Nvidia site I found the 175.32 Driver, but it won't update my current driver (98.something). Would it be save if I uninstall my current driver, and reinstall the other one?

Link to driver: http://www.nvidia.co.uk/object/winvista_x8...32_whql_uk.html

Current Laptop: XXODD M570U (Not in the list)

Edited by Hellscreamy
Link to comment
Share on other sites

when you download any drivers from this site, make sure you also download the 'modded inf' (link next to driver download).

Extract the driver, then copy the modded inf over the original one, and it should install fine to your card.

Spore is known to not like older drivers, but anything in the 17x.xx series should be fine

Here are the links for 177.98:

Vista x86 (32bit)

Vista x64

XP x86 (32bit)

XP x64

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...