Jump to content
LaptopVideo2Go Forums

Sleep mode problem finally solved


Guest Mr. Tao

Recommended Posts

Guest Mr. Tao

Recently I posted here about my sleep problem (and as far as I remember I wasn't alone complaining about this issue). Just minutes ago I read new posts in topic about 53.04 ForceWare and this one caught my eye. I modified Pieter's INF version 13 according to this brave nameless guest and yes, it really works-I can use sleep mode again :!: I would like to express my big thanks here :)

I don't know what mapOSD3ToNV=3 does, but whatever it is, it works.

Edited by dontknow
Link to comment
Share on other sites

:)

Glad it worked for you. I'm not sure exactly what the MapOSD3ToNV entry does, but I have a vague idea. The terminology "D3" is the power state defined for the hardware and software industry-standard sleep mode. I guess this setting causes the drivers to register shut-down and wake-up routines with the OS.

-Scott- ("The Guest")

Link to comment
Share on other sites

hi, this is really interesting. I knew that we call s3=suspend to ram

and

s4=suspend to disk=hibernate

but then i found this:

"PMC Register Block and S-to-D Mapping for Video Adapters

For video adapters with the PCI Power Management Register Block implemented, Windows 2000/Windows XP uses the capabilities re-ported by the Power Management Capabilities (PMC) register to create a System-to-Device state mapping table. In such an S-to-D mapping table, the device power state for a given system power state is always equal to or lower than that system power state.

For example, if system power state S1 can be mapped into D1, D2, or D3 power state for the device, the operating system selected the highest supported and valid device power state for mapping. In this example, S1 would map to D1. If the device supports only D0 and D3 power states, the system power state S1 would be mapped to D3 for the device.

Driver support for D0 and D3 is implicit by exposing the Power Management Register Block in the PCI configuration space for the device (or function). Drivers commonly handle their hardware incorrectly by not supporting the D3 power state in their power management handling code. For example, if the device (or function) reports only D0 and D3 support in the Power Management Register Block, and the associated video miniport driver does not provide D3 support, then the system will not be able to enter S1 (standby) power-saving mode.

To resolve this error, video miniport drivers must support all power states reported by the hardware in the Power Management Register Block. The D1 and D2 capability bits of the PMC Register should be implemented for video adapters as well. By doing so, more flexibility for system power management is provided."

Looks like an explanation...

Link to comment
Share on other sites

mapOSD3ToNV=3

In my INFs this is enabled for GPUs NV18 (448go) and above. (except v13.00)

Now the Dell D800 (4200go) is having problems with all my 5x.xx INFs but works fine with 4x.xx (Standby/Hibernate/lidclosure)

So why would mapOSD3ToNV=3 work with 4x.xx but not with 5x.xx.

I have a feeling that the 5x.xx drivers have a lot to do with it.

Good finding Dontknow, very good explaination, this might turn into the same problem as the SoftEDIDs with certain Laptops (Toshibas mostly)

Another thing to work on.

I'm working on v20.00 of my 53.04 INF, a whole new INF with mapOSD3ToNV=3 included.

But I can't get nView to work (#@@!!@), I know it works when I add it manually or use orignal INF but not with new INF.

I hope to work some more on this over the weekend.

Also havn't even looked at 53.06 yet.

Pieter.

Link to comment
Share on other sites

That's interesting dontknow.

Just glancing at this post and some OEM INF files this seems to be a consistent setting for a majority -- not all -- cards and laptop models.

Pieter, NVIDIA is already into v55 development (ie. 55.00 ) ... perhaps the next release will be soon.

Link to comment
Share on other sites

Guest r.y.a.n

Hi. Im not sure how to do the prementioned modifications. I'm trying 52.06 with the 20.02 and can't get my pc to wake from sleep mode properly.

Can someone maybe modifiy the file for me and attach it here?

Link to comment
Share on other sites

Maybe disabling FastWrite during Resume helps, too:

HKR,, DisableFWDuringResumeFromD3, %REG_DWORD%, 1

Someone who still encounters problems when resuming from Standby can try this.

Found this in the technical area of the forum (just posted by Pieter) :)

dontknow

Link to comment
Share on other sites

Guest Mr. Tao
My PC just switches to CRT mode when it wakes up from some reason. If I do Fn F8 after it wakes up, it switches back to LCD and everything is happy again.
This wasn't my case, my notebook wasn't responding to keyboard input, even no beeps on Fn something keys.
Link to comment
Share on other sites

Drew,

Here it is 53.06 modded with the adjustment.  

Pieter.  

--------------------------------------------------------------------------------

nv4_disp.zip  

Description: 53.06 modded with HKR,, MapOSD3ToNV, %REG_DWORD%, 3  

 

Download  

Filename:  nv4_disp.zip  

Filesize:  9.33 KB  

Downloaded:  4 Time(s)  

 

Not quite actual screen but you get the idea.

Just press 'Download' (on the far left of screen).

Then just eiher press 'Save' (to disk) or 'Open' (with winzip).

Either way you'll need winzip or winrar to open the zip file.

In there is the INF your looking for.

Pieter.

Link to comment
Share on other sites

Guest r.y.a.n

You need to register

Pieter, that INF didn't seem to do the trick for me :)

I couldn't get out of suspend, and CTRL F8 didn't seem to do anything. I can tell that the PC is responding to keyboard commands and stuff though, and could do a shutdown with th power button (not a forced shutdown).

I'm back to the 4x.xx series again :) :P

Link to comment
Share on other sites

So if we close the lid the computer will not lock up anymore?

I have all sleep/hibernation/standby settings set to off but for some reason whenever I close the lid, the monitor goes off and I cannot get it to resume...

Link to comment
Share on other sites

Guys,

try this, have a look in my INF v20.00 , under the heading [nv_tweaks]

and look for these lines :

;HKR,, LidBehavior,                   %REG_DWORD%,    0x11

;HKR,, LidBehavior,                   %REG_DWORD%,    5

;HKR,, LidBehavior,                   %REG_DWORD%,    1

Remove the semicolon ';' infront of the line, only try one at a time, this feature controls what happens when the lid is closed.

Reply back with results.

Pieter.

Link to comment
Share on other sites

hello,

i found out how to check what energy states your devices (especially the GPU) support i.e. my GPU supports D0 and D3, so S3 (suspend to RAM) and S4 (suspend to DISK) is correctly mapped to D3 when the driver supports it. Because i don't have any problem from waking up from Standby (S3) or Hibernate (S4), i think the driver works correctly.

You have to add the following to your registry to see the details in your devicemanager:

[HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession ManagerEnvironment]

"DEVMGR_SHOW_DETAILS"="1" (string value, not DWord)

then open the devicemanger, doubleclick your GPU and you see "DETAILS" between "Driver" and "Ressources" and check out the last 3 entries. There you will see all informations about energy state stuff.

i.e. my built in Intel PRO/100 VE network has PDCAP_D0, D1, D2, D3 supported and even has "WAKE_FROM_D3_SUPPORTED"

Link to comment
Share on other sites

Very nice info, dontknow. I had to do a reboot after adding the entry before the new page showed up. There is some good info from the details page.

Link to comment
Share on other sites

The details page is an really old trick, i always had that enabled, but i never was interested or forgot the energy things. I used the details page for info about dev id and subsys id :)

Link to comment
Share on other sites

I'm having the same problem - my Inspiron 8200 with GeForce 4 440GO doesn't wake up after suspend with any of the 53.xx drivers

try this, have a look in my INF v20.00 , under the heading [nv_tweaks]and look for these lines :
;HKR,, LidBehavior,                   %REG_DWORD%,    0x11

;HKR,, LidBehavior,                   %REG_DWORD%,    5

;HKR,, LidBehavior,                   %REG_DWORD%,    1

tried all three settings and it didn't help - with '5' the resume seems to go 'a bit farther' since input seemed to be enabled (albeit black screen) and after a force-shutdown windows came up with an error message about a previous problem ...

any ideas what to try next?

Thanks

Nils

Link to comment
Share on other sites

Hi guys,

i can only report my little experience. I'm working on a Precision M50 (Quadro 700GoGL) and till 5x.xx i only could use my 42.57 due to the improper resolution issue. With both 53.03 (11.67) and 56.55 (20.03) i fixed the 1600x1200 issue but now i still get Standby issue. When i wake up my computer from sleepin i can see that what is turned off isn't the LCD panel but the lights that are inside the LCD. Infact if you look carefully you can see OS as after a wakeup process, with the keyboard working and all the other peripherals too. The only issue is that the fluorescent lights inside the panel are OFF. So the PC is wake, the OS too, my Quadro too, but my lights aren't.

I've set in the 20.03 inf the following tweaks

MapOSD3ToNV = 3

LidBehavior = 5

DisableFWDuringResumeFromD3 = 1

Mobile = 1

Hope my hint could help.

Have a nice day, LuxoJr

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...