Jump to content
LaptopVideo2Go Forums

53.04 and 53.06 INF v 20.00 are out, new INF to try


mobilenvidia

Recommended Posts

INFs are upto version 20.00 now, a complete rearrange inside the INF.

I've updated from my v13.00.

This is still my simplified INF, So default settings apply, or basicly just like a Desktop INF, with all Pages enabled.

I tried adding :

HKR,, MapOSD3ToNV,                   %REG_DWORD%,    3

but it plays havoc with my standby, I get about 4 screens in 1 as I come out of Standby, so that setting had to go.

It might be meant for NV18 and higher.

Feedback encouraged,

Enjoy,

Pieter.

Link to comment
Share on other sites

Guest Mr. Tao
It might be meant for NV18 and higher.
I don't thnik so. Yes, it wasn't present in original infs (30.11 if I'm not mistaken) which worked fine including sleep mode, but until I added this setting to your experimental 13.00 inf with 53.04 my nb always died when tried to wake up from sleep mode.
Link to comment
Share on other sites

You've been busy, Pieter! :)

My only comments are that most mobile infs use a maximum number of devices = 2 rather than 4. (I don't know if it matters.)

Also, are the NV_R&T and DCBOverride lines really needed? They seem to be hardware specific and I don't know if they help or hurt mobile GPUs. I leave them out with no ill effects.

Cheers, and keep up the great work!

Larry

Link to comment
Share on other sites

Mr Tao,

Could you increase the size of your font please in your profile.

It's very hard to read.

I think you've got a GF2go, I havn't seen an INF with the

HKR,, MapOSD3ToNV, %REG_DWORD%, 3
for anything lower than a NV17 (only a Toshiba) all the rest were NV18

Like I said earlier, my screen turns to custard coming out of Standby with the above setiing.

Best thing to do for anybody with Standby/lid closure problems is to remove the :(semicolon) in front of the

HKR,, MapOSD3ToNV, %REG_DWORD%, 3
setting in my INF.

Then reinstall driver, to see if it helps.

There are loads of settings in the INF to play with.

I couldn't test them all, so if you find something interesting give us a yell.

I might just add certain things like MapOSD3ToNV to me tweaks expalined page.

For others to modify INfs to suite them selves.

Enjoy,

Pieter.

Link to comment
Share on other sites

Dontknow,

I have a good friend called 'Google' you may have heard of him.

On quiet nights I do a little searching, and I find all sorts of things.

What is more interesting is what will the go5750 be ? (0349 ?)

and even more finger licking good the Quadro FX go1000 (034A ?) supported as of 53.04

Cheers for that link, I'll have a look. [update the link to 52.22 is for Premier Support only :) ]

Enjoy,

Pieter.

Link to comment
Share on other sites

Guest Mr. Tao
I think you've got a GF2go, I havn't seen an INF with the
HKR,, MapOSD3ToNV, %REG_DWORD%, 3
for anything lower than a NV17 (only a Toshiba) all the rest were NV18

Like I said earlier, my screen turns to custard coming out of Standby with the above setiing.

Best thing to do for anybody with Standby/lid closure problems is to remove the :(semicolon) in front of the

HKR,, MapOSD3ToNV, %REG_DWORD%, 3
setting in my INF.

Thanks for this solution, I'm happy that I can finally use standby with newest drivers :)

Only problem I still have is associated with DVD playback-I can't play any DVD movie since I upgraded drivers from 30.xx series as WMP keeps complaining about screen resolution and/or color depth.

Link to comment
Share on other sites

Mr Tao,

Get a different DVD player, even nVidia's player is infinitly better than WMP.

Pieter.

Link to comment
Share on other sites

I want to try the 53.06/20.01, but I would like to make sure that I've completely have all the old drivers and settings deleted. Anyone got any uninstall utilities? I seem to remember seeing some links, but can't find them anymore.

Thanks,

Tenstrum

Link to comment
Share on other sites

Tenstrum,

At least your not alone on the SS Toshiba, the leaky boat has many passengers just like your self.

Hopefully one day a miracle will happen and a 5x.xx driver will work.

Captn Pieter.

Link to comment
Share on other sites

Tenstrum, I am going to *attempt* an INF for you (53.06) but am having difficulty with your subsys number for 2415.

One way to find it is : start-run-dxdiag-sound 1 tab-device id line

SUBSYS_XXXXXXXX. It'll help me make sure I'm setting the values right in the INF.

Link to comment
Share on other sites

Tenstrum,

Have try with my new 20.02 INF, inside the INF you'll find a section with this :

[ToshibaPanel0]HKR,, Panel00,                     %REG_MULTI_SZ%, "Toshiba XGA"

HKR,, Panel01,                     %REG_MULTI_SZ%, "Toshiba XGA"

HKR,, Panel02,                     %REG_MULTI_SZ%, "Toshiba XGA"

HKR,, Panel03,                     %REG_MULTI_SZ%, "Toshiba XGA"

HKR,, Panel04,                     %REG_MULTI_SZ%, "Toshiba XGA"

HKR,, Panel05,                     %REG_MULTI_SZ%, "Toshiba XGA"

HKR,, Panel06,                     %REG_MULTI_SZ%, "Toshiba XGA"

HKR,, Panel07,                     %REG_MULTI_SZ%, "Toshiba SXGA "

HKR,, Panel08,                     %REG_MULTI_SZ%, "Toshiba SXGA "

HKR,, Panel09,                     %REG_MULTI_SZ%, "Toshiba XGA"

HKR,, Panel0A,                     %REG_MULTI_SZ%, "Toshiba XGA"

HKR,, Panel0B,                     %REG_MULTI_SZ%, "Toshiba SXGA "

HKR,, Panel0C,                     %REG_MULTI_SZ%, "Toshiba XGA"

HKR,, Panel0D,                     %REG_MULTI_SZ%, "Toshiba XGA"

HKR,, Panel0E,                     %REG_MULTI_SZ%, "Toshiba XGA"

HKR,, Panel0F,                     %REG_MULTI_SZ%, "Toshiba XGA"

Remove the heading '[ToshibaPanel0]', this will then make it part of the [nv_tweak] section and install.

Now install the driver (53.04 or 06), hopefully a fix.

If this doesn't work remove the entire [ToshibaPanel0] section and remove the [ToshibaPanel1] section heading and try again.

in the [ToshibaPanel1] section is the following :

[ToshibaPanel1]HKR,, Panel00,                     %REG_MULTI_SZ%, "Default Monitor"

HKR,, Panel01,                     %REG_MULTI_SZ%, "Default Monitor"

HKR,, Panel02,                     %REG_MULTI_SZ%, "Default Monitor"

HKR,, Panel03,                     %REG_MULTI_SZ%, "Default Monitor"

HKR,, Panel04,                     %REG_MULTI_SZ%, "Default Monitor"

HKR,, Panel05,                     %REG_MULTI_SZ%, "Default Monitor"

HKR,, Panel06,                     %REG_MULTI_SZ%, "Default Monitor"

HKR,, Panel07,                     %REG_MULTI_SZ%, "Default Monitor"

HKR,, Panel08,                     %REG_MULTI_SZ%, "Default Monitor"

HKR,, Panel09,                     %REG_MULTI_SZ%, "Default Monitor"

HKR,, Panel0A,                     %REG_MULTI_SZ%, "Default Monitor"

HKR,, Panel0B,                     %REG_MULTI_SZ%, "Default Monitor"

HKR,, Panel0C,                     %REG_MULTI_SZ%, "Default Monitor"

HKR,, Panel0D,                     %REG_MULTI_SZ%, "Default Monitor"

HKR,, Panel0E,                     %REG_MULTI_SZ%, "Default Monitor"

HKR,, Panel0F,                     %REG_MULTI_SZ%, "Default Monitor"

I found the above settings in an up and coming INF for Toshibas.

I hope this helps your woes,

Pieter.

Link to comment
Share on other sites

im posting this on many threads so that it spreads easily. sorry if this is bad :)

with my tosh 1415-s105 (gf4go420 16mb) 15v, i used to be able to do the softedid mod and have a perfect screen. however, i tried the 20.xx series inf and it no longer works. im using 53.04mce with softedid mod (and tried without) and it is a nogo. damned blackbar

oh well. im telling everyone whos asking why i have a dead area that "im trying to save battery life" :)

Link to comment
Share on other sites

Hi,

I have a toshiba sat. 5100-201, P4-m 1.6 GHz, 15'', GF4 440 go. I've never been able to use NV drivers v5x.xx because of whitw screen at logon, til today.

I've tried 53.06 with pieters inf 20.01 and it works fine. Just have a milisecond flick after logon.

Thanks for the good job Pieter.

Miguel

Link to comment
Share on other sites

Thanks Miguel,

Aaaaaaarrgggghhhh, whats a poor boy to do?

I fix one laptop that never worked before, just so another which used to work doesn't.

Toshiba have a lot to answer to, with their very odd behavioured laptops.

Toshiba owner with the 1415-s105, look under the [nv-tweak] section of the INF and remove the ';' (semicolon) from infront of HKR,, Mobile, %REG_DWORD%, 2

Make sure that SoftEDIDs is not used (place a ; in front of the line).

Now reinstall driver, and keep fingers crossed.

Pieter.

Link to comment
Share on other sites

With this new version of the video driver, my laptop sometimes has problems shutting off. I'll tell Windows to shut down, and it will unload all programs, go to the plain color background (after unloading my desktop and explorer), and just hang. I have to physically remove the battery and AC power to kill it. This is intermittent, and doesn't happen everytime.

Link to comment
Share on other sites

Ludic I had the same problem, I now have the laptop set to Standby mode when lid is closed then Hibernate after a few minutes and this works just dandy.

What made it even worse was having this

HKR,, MapOSD3ToNV, %REG_DWORD%, 3

So my INFs have this not enabled at all, if you have this set, then maybe change it.

Pieter.

Link to comment
Share on other sites

Teraphy,

Here's all of my sound info.

I'll attach all of my DirectX info as well.

thanks,

Tenstrum

-------------

Sound Devices

-------------

Description: YAMAHA AC-XG WDM Audio

Default Sound Playback: Yes

Default Voice Playback: Yes

Hardware ID: PCIVEN_8086&DEV_2485&SUBSYS_00011179&REV_02

Manufacturer ID: 1

Product ID: 100

Type: WDM

Driver Name: yacxgc.sys

Driver Version: 6.13.0010.3152 (English)

Driver Attributes: Final Retail

WHQL Logo'd: Yes

Date and Size: 7/24/2002 15:42:34, 202880 bytes

Other Files:

Driver Provider: YAMAHA CORPORATION

HW Accel Level: Full

Cap Flags: 0xB5B

Min/Max Sample Rate: 48000, 48000

Static/Strm HW Mix Bufs: 1, 0

Static/Strm HW 3D Bufs: 0, 0

HW Memory: 0

Voice Management: No

EAX 2.0 Listen/Src: No, No

I3DL2 Listen/Src: No, No

Sensaura ZoomFX: No

Registry: OK

Sound Test Result: Not run

---------------------

Sound Capture Devices

---------------------

Description: YAMAHA AC-XG WDM Audio

Default Sound Capture: Yes

Default Voice Capture: Yes

Driver Name: yacxgc.sys

Driver Version: 6.13.0010.3152 (English)

Driver Attributes: Final Retail

Date and Size: 7/24/2002 15:42:34, 202880 bytes

Cap Flags: 0x41

Format Flags: 0xCC0

-----------

DirectMusic

-----------

DLS Path: C:WINDOWSSYSTEM32driversGM.DLS

DLS Version: 1.00.0016.0002

Acceleration: n/a

Ports: Microsoft Synthesizer, Software (Not Kernel Mode), Output, DLS, Internal, Default Port

YAMAHA AC-XG WDM Audio, Software (Kernel Mode), Output, DLS, Internal

Microsoft MIDI Mapper [Emulated], Hardware (Not Kernel Mode), Output, No DLS, Internal

Microsoft GS Wavetable SW Synth [Emulated], Hardware (Not Kernel Mode), Output, No DLS, Internal

Registry: OK

Test Result: Not run

Link to comment
Share on other sites

Pieter,

Tried the 20.02 INF modifications, but I'm still getting the black bar. My resolution won't go above 969x768. I just need it to go 1024x768. I appriciate you trying to help me.

Tenstrum

Link to comment
Share on other sites

Teraphy,

I don't think my DxDiag got attached. I'll just paste all the info in.

Tenstrum

---------------

Display Devices

---------------

Card name: NVIDIA GeForce4 420 Go

Manufacturer: NVIDIA

Chip type: GeForce4 420 Go

DAC type: Integrated RAMDAC

Device Key: EnumPCIVEN_10DE&DEV_0175&SUBSYS_00011179&REV_A3 Display Memory: 16.0 MB

Current Mode: 1024 x 768 (32 bit) (60Hz)

Monitor: Default Monitor

Monitor Max Res:

Driver Name: nv4_disp.dll

Driver Version: 6.14.0001.4351 (English)

DDI Version: 9 (or higher)

Driver Attributes: Final Retail

Driver Date/Size: 4/2/2003 14:40:00, 3118954 bytes

WHQL Logo'd: No

WHQL Date Stamp: None

VDD: n/a

Mini VDD: nv4_mini.sys

Mini VDD Date: 4/2/2003 14:40:00, 1265130 bytes

Device Identifier: {D7B71E3E-4235-11CF-3662-002002C2CB35}

Vendor ID: 0x10DE

Device ID: 0x0175

SubSys ID: 0x00011179

Revision ID: 0x00A3

Revision ID: 0x00A3

--

Mod Edit: Removed the rest of the posting. Thanks but the bold is what I'm after :) Hope the INF file attached below works.

Link to comment
Share on other sites

Tenstrum,

right try this, this is out of Toshiba's 56.54 INF.

Cut and paste the following in to the [nv_tweak] section of 53.04/6 :

HKR,, IgnoreHWSelectedDeviceInSpanningMode,         %REG_DWORD%,    1

HKR,, PanScanSelection,            %REG_DWORD%,    1

HKR,, DevicesConnected,            %REG_DWORD%,    257

HKR,, DisableTVClockInversion,     %REG_DWORD%,    1

HKR,, PowerSaverHsyncOn,           %REG_DWORD%,    1

HKR,, WidePanelBehavior,           %REG_DWORD%,    0x22

HKR,, OverrideMonitorPower,        %REG_DWORD%,    1

HKR,, Override1400x1050,           %REG_DWORD%,    1

HKR,, DualviewPolicyID,            %REG_DWORD%,    1

HKR,, OverlayMode2,                %REG_BINARY%,   50,00,10,04

HKR,, OverlayMode3,                %REG_BINARY%,   01,00,00,10

HKR,, HotkeyPrimaryDevScheme,      %REG_DWORD%,    1

HKR,, NV11MLFNT,                   %REG_DWORD%,    1

HKR,, UseGDIRefreshRate,           %REG_DWORD%,    1

HKR,, DevSwitchSuppressMask,       %REG_DWORD%,    7

HKR,, ModesetBlankDelay,           %REG_DWORD%,    150

HKR,, UseBestResolution,           %REG_DWORD%,    1

HKR,, RotateFlag,                  %REG_DWORD%,    4

HKR,, DeviceSpecificDPMS,          %REG_DWORD%,    1

HKR,, PowerMizerDefault,           %REG_DWORD%,    1

HKR,, EnableCoreVoltage,           %REG_DWORD%,    0

HKR,, BandwidthFactor,             %REG_DWORD%,    4

HKR,, FSDOSHotKeyPolicy,           %REG_DWORD%,    1

HKR,, VPVer,                       %REG_DWORD%,    1

HKR,, UseDefaultFlatPanelModeOnReboot,%REG_DWORD%, 1

HKR,, PanelPowerWaitForSequencer,  %REG_DWORD%,    0

HKR,, DeinterlaceMode,             %REG_DWORD%,    0

HKR,, MutuallyExDevs,              %REG_BINARY%,   00,00,02,00,01,00,00,00

Reinstall driver and fingers crossed.

Pieter.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...