Jump to content
LaptopVideo2Go Forums

Recommended Posts

Hello all fellow gamers ,

I have a problem to share about Sacred 2 which involves nvidia cards mostly as i have read (and experienced myself).

The problem is that the game keeps crashing randomly after you start playing or freezes and then a blue screen comes up,

or if you get lucky nvidia drivers stop working and you can reboot your pc safely.

After reading several cases having this problem in the specific game , i tested some things like disabling PhysX (some people

say that this is the heart of the problem after the latest patch) or i put the texture quality to minimal or default and generally

even if i have nvidia 8800 Ultra/768 which is capable to play the game in the most maximum of settings i had to drop several

settings just to test what is happening, and from where those crashes come from.

I must say that i currently use the nvidia drivers 180.48 which is just fine with everything else than Sacred 2 (not blaming :P )

I wish to know if any of you experience same problem like me and if you have a solution or proposal that actually worked,

because after testing and testing problem still is there waiting :) Is it the drivers? it is the PhysX? is it the patch or the game that

needs attention? :)

Best Regards.

Link to post
Share on other sites

I had similar problem. The game intend to stop responding whenever I change the graphic setting ONLY after playing.

If I do it before playing the game --> no problem.

Do you notice any improvement boost by disabling physx? It doesn't make much difference I guess.

Gonna try disable physx today.

Link to post
Share on other sites

Continuing the post and your question above,

the problem with nVidia cards & driver issues and Sacred 2 began with and after applying the

latest patch 2.31 to Sacred 2. With the previous patch 2.12 it was running fine as a game in

most cases. At least you didn't had random timed crashes , freezes or blue screens.

It is said that by disabling PhysX the game runs with no problem mentioned earlier but as i tested

it myself it still brings same problems sooner or later (which means random again) so i think

that PhysX is not a problem right now.

Trying the game to the max settings demands a card with 768MB and no less than that as the

game developers say on a forum of S2. They also say that this is a result because the game itself,

uses a too many textures which is consuming the video memory of our pcs. Okkk we got that so far,

so even if we set our Texture Quality to minimal still we experience same stuff. So ,

~ Tested Enable/Disable of PhysX = Didn't solve the problem

~ Tried to set the game to run in various detail levels = Didn't solve the problem

Finally , is the game patch 2.31 itself that creates this mess? And if ATI doesnt have problem with S2

even with the latest patch, then must be a solution about the Nvidia cards and Sacred 2 (2.31ver).

Share your experiences and thoughts :)

Maybe we will work something out in the end

Best Regards

Answer to the above post: By disabling PhysX you will not see a performance decrease or increase

as long as you have a CPU Core2 of 2.0+ GHz or somewhere there. Normally you will not meet any

problem by disabling it anyway but as i tested this ain't needed anymore :)

Link to post
Share on other sites

Update :

After testing the game running under latest patch 2.31 with the 180.48 drivers and applying all the combinations ingame

like weather on/off, texture quality minimal/default, low/med/high/ultra high settings or by enable/disable PhysX (either

8.10.13 or 8.10.29) the game was still being unstable with results of random timed crashes with or without blue screens.

Uninstalled 180.48 completely bit by bit and now testing the game with all ultra high settings and enabled PhysX but with

nvidia drivers 178.24 and soon under the beta 180.84

So far 178.24 seem to be most stable with Sacred 2 with every setting that pleases you :) Let's see what will bring..

Best Regards.

Link to post
Share on other sites

Update:

Sacred 2 : Fallen Angel

working over 24h now under maximum settings, weather on, PhysX enabled

nvidia drivers 178.24 ~ PhysX tested as 8.10.13 and 8.10.29

No Random Crashes with the above.

Now will turn to test the re-released 180.84 drivers to see how they act :)

Best Regards

Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...