Jump to content
LaptopVideo2Go Forums
sondredh

Upgrade Acer 6920g 9500M GS To 9600M GT

Recommended Posts

sondredh

Hi i have an Acer Aspire 6920g with the 9500M GS. I want to upgrade it to the 9600M GT DDR3, I found THIS on ebay.

Is it possible? Anyone tried it with this lappy? Where is the GPU located on this laptop? I've looked through the service guide and dissassembly guide but it doesn't say anything about it. And the 9600M GT is the best upgradeable card for this laptop, right?

Thanks in advance:)

Edited by sondredh

Share this post


Link to post
Share on other sites
wook

remember google is your friend!

i had a quick search... type II MXM, so yes the 9600gt will fit. But, you will need to make sure u have the right one. i'd buy one from acer directly as you will know that this will work.

Even though any type II cards will fit, some just wont be compatable. ie. bios etc will need changing...

Share this post


Link to post
Share on other sites
sondredh
remember google is your friend!

i had a quick search... type II MXM, so yes the 9600gt will fit. But, you will need to make sure u have the right one. i'd buy one from acer directly as you will know that this will work.

Even though any type II cards will fit, some just wont be compatable. ie. bios etc will need changing...

But do you think the one i found will work? "The card is ES bios inside, but it run 3d normally" what's ES? I just flashed my current 9500m gs to overclock it, can i just find an acer 9600m gt bios and put it on my usb stick and then flash it when im using the 9600m gt?

Share this post


Link to post
Share on other sites
reiluke

thank you for the ebay seller links, wow he sells a lot of mxm cards, but no details on other cards to what the bios is and what laptop is he testing it with

Share this post


Link to post
Share on other sites
wook

well the good news is you cant wreck a bios flash. so can always start from strach. have never heard of the ES bios. sorry cant help there

The mxm slot is usually located in the memory slot. so unscrew that, and take it out and slot the other card in. if nothing is displayed... unfortunately often users need to do a black flash. screen wont display anything, so you will need to type in and execute commands while not looking at the screen. hopefully you wont need to do this.

i did hear a roumer that the 9800 gtx is coming to MXM II. which i very much doubt. its a very hot GPU, and i think that it will and should only come to type III and the rear type IV

i.e. 17" laptops

you may want to message these people if you cant get it to work.. same system as you and have also tried to upgrade.

http://forums.laptopvideo2go.com/index....art=#entry89240

Share this post


Link to post
Share on other sites
reiluke

but blind flash does not apply to all i tried an asus bios 8600Gt on my acer 4520G and it keeps restarting after 8sec. no chance to blind flash, but with an acer bios 8600GT, worked perfectly

Share this post


Link to post
Share on other sites
sssniper
But do you think the one i found will work? "The card is ES bios inside, but it run 3d normally" what's ES? I just flashed my current 9500m gs to overclock it, can i just find an acer 9600m gt bios and put it on my usb stick and then flash it when im using the 9600m gt?

If i`m not mistaken, it means Engineering Sample and it`s not very good. You should buy only the card with your BIOS. Otherwise, it may become incompatible with your system.

http://forums.laptopvideo2go.com/index....showtopic=21841

You should find something like this, with Acer BIOS pre-installed, it would be better

http://cgi.ebay.com/Nvidia-MXM-Graphics-Ca...%3A1%7C294%3A50

Share this post


Link to post
Share on other sites
sondredh
If i`m not mistaken, it means Engineering Sample and it`s not very good. You should buy only the card with your BIOS. Otherwise, it may become incompatible with your system.

http://forums.laptopvideo2go.com/index....showtopic=21841

You should find something like this, with Acer BIOS pre-installed, it would be better

http://cgi.ebay.com/Nvidia-MXM-Graphics-Ca...%3A1%7C294%3A50

I found THIS.

Is VGA Board 512MB.GDDR3.NB9-pin-GS the correct 9600M GT?

Edited by sondredh

Share this post


Link to post
Share on other sites
sssniper
I found THIS.

Is VGA Board 512MB.GDDR3.NB9-pin-GS the correct 9600M GT?

At least looks better than with ES Bios. Anyways, use the Contact Us page on their site to ask about the Acer Bios pre-installed before you decide to purchase anything. Don`t forget to ask about the clocks - they could downclock the card or block overclocking through the bios :)

Share this post


Link to post
Share on other sites
sondredh
At least looks better than with ES Bios. Anyways, use the Contact Us page on their site to ask about the Acer Bios pre-installed before you decide to purchase anything. Don`t forget to ask about the clocks - they could downclock the card or block overclocking through the bios :)

If i flash the ES card with an acer 9600m gt bios wouldn't that be just as good? And on the ES bios card on ebay it look like its missing something (the grey thing thats on my 9500m gs, see pics.) Do i need that?

post-25091-1230419468_thumb.jpg

post-25091-1230419494_thumb.jpg

Share this post


Link to post
Share on other sites
reiluke

you take that off and put it in your new card

Share this post


Link to post
Share on other sites
sondredh

But if i just buy the card with the ES bios for $199 and flash it with an 9600m GT acer bios (i've recently flashed my 9500M GS to overclock it so i know how its done) wouldn't that be just as good as buying the one for $319 on ebay or the one from acer spare parts?

Share this post


Link to post
Share on other sites
foxultra
Hi i have an Acer Aspire 6920g with the 9500M GS. I want to upgrade it to the 9600M GT DDR3, I found THIS on ebay.

Is it possible? Anyone tried it with this lappy? Where is the GPU located on this laptop? I've looked through the service guide and dissassembly guide but it doesn't say anything about it. And the 9600M GT is the best upgradeable card for this laptop, right?

Thanks in advance:)

"ES" stand for "Engineering Sample", according to my understanding, it is not the final version, so it can only run partly function of the chip...i would not recommand to buy it.....

Btw..... how to buy a 9600m from acer directly???

Edited by foxultra

Share this post


Link to post
Share on other sites
Kayldera
"ES" stand for "Engineering Sample", according to my understanding, it is not the final version, so it can only run partly function of the chip...i would not recommand to buy it.....

Btw..... how to buy a 9600m from acer directly???

You need to get your hands on a service manual and find the part ID that correspond to the 9600m GT.

Share this post


Link to post
Share on other sites
foxultra
You need to get your hands on a service manual and find the part ID that correspond to the 9600m GT.

dude, i find a website from another thread here http://www.mk-electronic.com/ (sould be the offical acer sparepart supplier) , and find the part number of 9600m gt's is "VG.9PG06.006" ACER VGA BOARD 512MB GDDR3 NB9P-GS 164,66 (incl. VAT 195,95), is that what you mean by "Part ID"??? however, so far i have to no idea how to purchase it on this site, because it require membership....

Share this post


Link to post
Share on other sites
sondredh

I've already bought the card, will be receiving it in a few days. Atleast i know that someone's got the card working on the 6920g LINK. But since it's only the vBIOS that is "ES" and nothing is wrong with the card, can't i just flash it with an acer 9600m gt vBIOS?

Edited by sondredh

Share this post


Link to post
Share on other sites
sondredh

Ok, so now i've got the card, but im having some problems getting it to work.

When i try to start my 6920g with it, i first get a message about "Enginering sample not for production use" or something like that, then it continues to boot, i can see everything, the green vista loading bar, the login screen etc., but its running in a lower resolution (1024 x 640, i think). However, the problem is that after about 30 seconds it shuts itself down. I've tried rebooting it but then it takes even shorter time before it shuts down again. Is this a thermal issue??

The card feels pretty hot when its only been active for under a minute. I think i've installed the card correctly. I don't think it could have anything to do with the vBiOS, coz it boots longer the first time, and it goes fewer seconds till it shut down the second time i boot it, but if i let it cool down it gets further in the boot. But should i try flashing with a acer 9600m gt bios?, cause i have one ready. But im afraid if i flash it, it will shut down while im doing it and i will be left with a dead card :)

What should i do?? :)

Pls i need help fast or im gonna return the card :P

And as i said before, others have got it working on the 6920g

Edited by sondredh

Share this post


Link to post
Share on other sites
sssniper
Ok, so now i've got the card, but im having some problems getting it to work.

When i try to start my 6920g with it, i first get a message about "Enginering sample not for production use" or something like that, then it continues to boot, i can see everything, the green vista loading bar, the login screen etc., but its running in a lower resolution (1024 x 640, i think). However, the problem is that after about 30 seconds it shuts itself down. I've tried rebooting it but then it takes even shorter time before it shuts down again. Is this a thermal issue??

The card feels pretty hot when its only been active for under a minute. I think i've installed the card correctly. I don't think it could have anything to do with the vBiOS, coz it boots longer the first time, and it goes fewer seconds till it shut down the second time i boot it, but if i let it cool down it gets further in the boot. But should i try flashing with a acer 9600m gt bios?, cause i have one ready. But im afraid if i flash it, it will shut down while im doing it and i will be left with a dead card :P

What should i do?? :)

Pls i need help fast or im gonna return the card :unsure:

And as i said before, others have got it working on the 6920g

Damn engineering sample. as i sad :)

Share this post


Link to post
Share on other sites
sondredh
Damn engineering sample. as i sad :)

But it's not the CARD itself that's ES, it's the vBIOS, so i think i have done something wrong with the heatsinks or something so it overheats, coz it gets pretty hot when its only been operating for less than 1 minute, but im gonna try to install i via my HDTV as the guy in the other thread on NBR. If that doesnt work im gonna flash it and if that doesnt work, i've installed the heatsinks etc. wrong OR its just the card is faulty.

Here's how i installed the card:

1. Pasted heat stickers as instructed

2. mounted heatsinks, but not the one that came with the card, but my old 9500m gs heatsink since the 9600m gt one didnt fit

3. Booted it; got the ES message, vista continued to boot got to the login screen, logged in, got to the desktop, shutted down.

4. Booted it again, got to log in screen, shutted down

5. Booted it again, shutted down after a few seconds

6. Waited till the card was cooled down and tried booting again got to right after the logon screen.

So i think its a Thermal issue

But shouldnt the card be able to run even if it had no heatstickers/heatsink atleast do basic 2d operations?? The seller tested the card in 3dmark before he sent it, so it should work???

Plz i really need help with this, only got a few days till i have to return it if i doesnt work :)

Share this post


Link to post
Share on other sites
sssniper
But it's not the CARD itself that's ES, it's the vBIOS, so i think i have done something wrong with the heatsinks or something so it overheats, coz it gets pretty hot when its only been operating for less than 1 minute, but im gonna try to install i via my HDTV as the guy in the other thread on NBR. If that doesnt work im gonna flash it and if that doesnt work, i've installed the heatsinks etc. wrong OR its just the card is faulty.

Here's how i installed the card:

1. Pasted heat stickers as instructed

2. mounted heatsinks, but not the one that came with the card, but my old 9500m gs heatsink since the 9600m gt one didnt fit

3. Booted it; got the ES message, vista continued to boot got to the login screen, logged in, got to the desktop, shutted down.

4. Booted it again, got to log in screen, shutted down

5. Booted it again, shutted down after a few seconds

6. Waited till the card was cooled down and tried booting again got to right after the logon screen.

So i think its a Thermal issue

But shouldnt the card be able to run even if it had no heatstickers/heatsink atleast do basic 2d operations?? The seller tested the card in 3dmark before he sent it, so it should work???

Plz i really need help with this, only got a few days till i have to return it if i doesnt work :)

Yes. i meant that its ES vBIOS. Does GPU cooler start working before the lap shuts down?

Share this post


Link to post
Share on other sites
sondredh
Yes. i meant that its ES vBIOS. Does GPU cooler start working before the lap shuts down?

How do i know if it starts working? The fans are running at normal speed but i dont know about the coolers for the gpu. Is there any way i can check temperatures without booting windows?

Share this post


Link to post
Share on other sites
sondredh

I got it working!!!! :) :unsure: :w00t: :P :) (well, kind of)

I had just mounted the heatsink wrong + pasted a heatsticker on the thing in the middle so it didnt get cooled down :P

Im running with the Engineering Sample vBIOS as the Acer one didnt work so i had to blind-flash it back again, and i had to do it in less than a minute if else it shutted down :P

So i got windows to boot and it was running with standard windows VGA driver @ 1024x640. It started searching for drivers but it didnt find any. I got a driver disc with my 9600m gt so i checked the drivers on the disc but there was only vista 64 bit and xp 32 bit drivers on the disc, and i have vista 32 bit :unsure:

I checked trough the folder i use to store downloaded LV2GO drivers, tried 169.04 didnt work, unsupported hardware, and the next driver i tried was 174.74 and it worked!

I rebooted and now it was running at native resolution. I started gpu-z to check temps but there wasnt any tab for temperature any longer :unsure:

9600m_gt_acer_6920g_Clocks.jpg

9600m_gt_acer_6920g_sensors_no_temp.jpg

I've also tried other temperature monitoring programs but none of them works :unsure:

It always runs at 500 core, 450 memory. Here's the worst part: everytime i start a game, the laptop shuts down. This happens at once when i start the game so i know it's not a temperature issue. Its more likely the card that cant switch into 3D or Extra mode, OR maybe it cannot run anything in fullscreen or something coz Photoshop CS4 runs fine and it utilizes the GPU, but i havent tried running any game in windowed mode coz i dont want to reboot again, but i''ll try it later if nothing else works. Here's a screeny of the 9600M GT ES vBIOS:

ES9600mgt6920G_Nibitor.jpg

It has very high boot clocks and double the memory speed (supposed to be 800 mhz) Should i try flashing a modified ES vBIOS with the original clocks? And what can i do to get the temperature monitoring to work??

Share this post


Link to post
Share on other sites
TheAlien

Wow. I think you have the exact same card as i have.

Could you take a picture of the GPU and Memory (better whole card) buy chance ? I will do the same when I get new heatpads.

Just yo make things clear: You have the Amilo Xi 1546 ? If so, you HAVE to modify your heat sink a bit or otherwise the card does not have full contact with the heat sink. This could be an explanation for your crashes.

Could you also post you vbios here ?

Where did you get the card from ? I got mine of ebay. And i got into big arguments with the seller. As he didn't say that this cards was a f**ked up enegeering sample.

My card runs. It also runs 3D applications, but I cannot clock the card at all. Not even with editing the vbios. And it gives me the 30 seconds of beeping and the card also runs in a power saving (clocked down) mode. Therefore I only get about 4300 3D Mark06 points (not that I care, but just to show that the performance isn't where i should be)

Edited by TheAlien

Share this post


Link to post
Share on other sites
sondredh
Wow. I think you have the exact same card as i have.

Could you take a picture of the GPU and Memory (better whole card) buy chance ? I will do the same when I get new heatpads.

Just yo make things clear: You have the Amilo Xi 1546 ? If so, you HAVE to modify your heat sink a bit or otherwise the card does not have full contact with the heat sink. This could be an explanation for your crashes.

Could you also post you vbios here ?

Where did you get the card from ? I got mine of ebay. And i got into big arguments with the seller. As he didn't say that this cards was a f**ked up enegeering sample.

My card runs. It also runs 3D applications, but I cannot clock the card at all. Not even with editing the vbios. And it gives me the 30 seconds of beeping and the card also runs in a power saving (clocked down) mode. Therefore I only get about 4300 3D Mark06 points (not that I care, but just to show that the performance isn't where i should be)

Im using an Acer Aspire 6920G.

I bought the card from HERE

Link to Engineering Sample vBIOS below.

Here's some pics of my 9600M GT:

9600mgt_9500mgs_driverdisc_heatsink.jpg

9600mgt_Front_no_heatsink.jpg

9600Mgt_Back_no_heasink.jpg

9600mgt_front_with_heatsink.jpg

9600MGT_back_with_heatsink.jpg

Ok, so i checked with Nibitor and it says my card is a g94 Board (Reading from the ES bios), but isn't the 9600m gt a g96??

And i've tried to flash a g96 acer vBIOS so thats why it didn't work, i just got a black screen.

What do you mean you cant clock the card? Cant you clock it even with flashing??

I've tried editing my ES bios and i got it to run at 702mhz memory but i set it to 800 in nibitor but it wouldnt get over 702. And running with these clocks wouldnt even let me start photoshop CS4 anymore coz it utilizes the gpu so it shutted down, and i think the problem is that when a 3d application starts it wants the card to switch into 3d or Extra mode but my card shuts off because theres something wrong with the Vbios. I have something i didn't try yet: changing everything inside the ES bios to match the Acer one, Timings, Id, bootup clocks etc..

When looking in the ES bios i saw that Extra mode didn't have any voltages assigned to it so i will try first with just that. But is changing the Timings dangerous? I will be able to blindflash still if i change the timings and something goes wrong, right?

What drivers are you using? Can you monitor the temps?

And would you mind posting your vbios here so i can try with that?

And one more thing: i still have 4 days left to return the card. Should i return it, or should i keep it if this is possible to fix?

EDIT: im just adding something: in Nibitor when i open the ES BIOS there's nothing under the temperature tab, and i cant change the critical temp. etc..

I think this is why i cant monitor temperatures because the vBIOS wont allow it. Im pretty sure that the ES bios is the reason why i can't start any games.. Im gonna edit it now and flash it 2morrow to see if it works..

And one last thing: My 9600m gt looks different from the ones on google...

9600M_GT_Engineering_Sample.zip

Edited by sondredh

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...