Jump to content
LaptopVideo2Go Forums

MacBook Pro - Broadcom 43xx Chipset


Recommended Posts


Here's the predicament: the old Broadcom drivers (4.170.xx.xx) that Apple ships with Bootcamp are buggy. Based on what I've been reading, it seems like this is a pretty common complaint--packet loss, strange audio artifacts, etc--are pretty common topics of discussion among Mac and PC owners. Unfortunately, all of my efforts to nuke and subsequently replace my old drivers have been for naught.

Here's what I've tried, using XP SP3 (32-bit) and Vista SP1 (64-bit):


1. Searching for drivers using Device Manager's automatic function. Result: nothing.

2. Manually attempting to update to the newer drivers by locating a directory containing the newer software. Result: Windows tells me that my current drivers are up to date already. I've attempted this process using the driver package from this site, as well as both (4321AG and 4322AG) drivers from Microsoft's Update Catalog page.

3. Uninstalling the old drivers, and then repeating the process listed above. Result: the same as before, except the old drivers, instead of staying uninstalled, are magically re-installed.


Obviously, I'm stuck. I've been up and down the net for a couple of hours in an effort to find substitutes for as much of Apple's crap as possible, and you guys are clearly the people to talk to. Does anyone have a suggestion as to what I should try next? I'm fairly technical, so if you have a crazy idea, or want me to dig up some information to help you formulate one, I'm all ears.

Edited by Angelw1ng
Link to comment
Share on other sites

When pointing windows driver update don't let it do anything automatically.

You need to select the directory and the INF file.

Your device should then show.

What could be happening seeing your card is for a MAC it may not have your DEV_ID in the install INF

Why it can't find and says best dirver already installed

Link to comment
Share on other sites

Thanks for the response, and sorry about the wait.

I was using the plain-vanilla .INF that came with the driver, so the fact that my machine's card doesn't match one of the entries within makes perfect sense. I think I know how to gather the information necessary to write my own modified .INF, but I'd appreciate any advice you have. Here's what I'm looking at:

- In the original .INF under the x64 Vista section, there's a lot of device/manufacturer entries, like so:

%BCM4322NM_DeviceDesc% = BCM43XNM22_NT60, PCI\VEN_14E4&DEV_432B&SUBSYS_1510103C

- Looking at the entries in the Details tab of my network adapter, it looks like I've got a Broadcom 4328 chipset. That worries me--this driver was intended for the BCM4322.

- In Device Manager, I found the following data, which seemed useful:

(Hardware Ids)





(Device Instance Path)


(Driver Node Strong Name)



Given the above, is creating my own modded .inf as simple as writing a string similar to the ones listed in the newer driver's .inf, only with the data I gleaned from Windows? If so, here's what I'd probably try:

%BCM4328NM_DeviceDesc% = BCM43XNM22_NT60, PCI\VEN_14E4&DEV_4328&SUBSYS_008C106B

Note that it appears that I have "&DEV_4328" versus the given .inf's "&DEV_432B". Am I on the right track, or am I missing something?

Thanks again!

Edited by Angelw1ng
Link to comment
Share on other sites

I'm making some progress:


- First, I tried adding the string that I mentioned above to the .inf, installed it, and got a message saying that part of the device's extended properties were inconsistent/incompatible with the driver. Needless to say, I rolled the driver back.

- Then I tried the "Have Disk" method with the original .inf. Installation went fine--however, it looks like only two of the four driver files were updated:





Again, I'm just making stabs in the dark here, but it looks like I could go straight into C:\Windows\system32 and manually overwrite those two older files (bcmihvsrv64.dll and bcmwlcoi.dll) manually. Sound like a bad idea?

Link to comment
Share on other sites

Too late. I went ahead and did it: disabled my wireless card, manually replaced the outdated files, rebooted the system, and re-enabled the wireless card.

Everything seems to be working fine, but to be sure, I'm going to hammer on my machine to see if I can reproduce the issues inherent to the old 4.170.xx.xx drivers.

In the meantime, I'd be interested in knowing if anything I did was inadvisable (especially the manual replacement of those .dlls). If not, I will probably be recommending this process to quite a few other people, and I wouldn't want to be giving bad advice.

Edited by Angelw1ng
Link to comment
Share on other sites

Well, the problem seems completely fixed. Hopefully, I did everything correctly.

Link to comment
Share on other sites

Well done, this is how I got started :)

If everything works as it should then you must have done it right.

Maybe do up a procedure for other MACians to learn from.

I can pin it here

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...