Jump to content
LaptopVideo2Go Forums

Far Cry Bad Grahics with GeForce 9600M GT


Guest Computer Genious

Recommended Posts

Guest Computer Genious

Hi,

I have a MacBook Pro (Core 2 Duo 2.4 GHz, 2GB DDR3, GeForce 9600M GT) but i run windows vista ultimate on it. I have totally removed Mac OS from it because I believe Apple harware is the best and windows OS is the best, so I have made the deadly combination. Recently I installed Far Cry (the first one) on it, because I love the game and secondly I didn't get a chance to play it earler. The graphics are very bad with Geforce 9600M GT although the games runs with ausome graphics on some low tech graphics cards.

Can somebody tell me how to configure my graphics card with this game so that the graphics are good, currently, it doesn't show any details of the jungle and water, it seems as if you are playing in a frozen place with every thing white except the player, the huts and people?

Link to comment
Share on other sites

try different drivers.what drivers have you installed?sorry for bad english...

Link to comment
Share on other sites

I believe Apple harware is the best.

Not true at all. You just wasted an awful lot of money on buying a mac if you are going to use windows on it, because Apple doesn't make its own hardwares, they just optimize intel, nvidia and major brand pc hardwares to work on mac. Mac prices are high because they want people to think that they are getting the best machine.

Recently I installed Far Cry (the first one) on it, because I love the game and secondly I didn't get a chance to play it earler. The graphics are very bad with Geforce 9600M GT although the games runs with ausome graphics on some low tech graphics cards.

Can somebody tell me how to configure my graphics card with this game so that the graphics are good, currently, it doesn't show any details of the jungle and water, it seems as if you are playing in a frozen place with every thing white except the player, the huts and people?

I would recommend you to get far cry 2. Much better graphics and optimized to make full use of the newer hardwares like yours.

I have a 8600m gt ddr3 gfx card and I get approx 29 fps in far cry 2.

Edited by nikechristo
Link to comment
Share on other sites

Guest Computer Genious
try different drivers.what drivers have you installed?sorry for bad english...

well, the latest nvidia drivers are installed as well as the latest physx drivers. I think the problem is that there are some features of geforce cards, which need to be turned off to play far cry properly but i don't know which ones.

Link to comment
Share on other sites

Have you tried updating the game with the latest patches ?

Edited by CrazyCrack
Link to comment
Share on other sites

  • 3 months later...

Had the same problem. Just update to latest version of far cry.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...