Jump to content
LaptopVideo2Go Forums

Battlefield series 59Hz Refresh FIX! [Vista]


Cujucuyo

Recommended Posts

Well guys I can't say I'm not excited! Finally, finally oh GOD finally! I had to connect a clunky VGA monitor to my VGA port in order to play Battlefield but now I can play it without the monitor attached and now you will too!

1st you'll need to have:

1. Direct Refresh:

http://rapidshare.com/files/199560878/DirectRefresh_1.2.zip

2. Nvidia Control Panel or the "NVIDIA PhysX Properties" which is the one I used [can be downloaded through nvidia.com].

Now for the process:

1. Open the Nvidia Control Panel or "NVIDIA PhysX Properties" [same layout] and go to the left part and click where it says:

"Manage Custom Resolution" > click on "Create"

1-1.png

Change default GDI refresh rate to 60 > Click on "Test" and it will ask you something, just click OK, the screen will flash once, then click OK again:

2.png

Now under "Custom Resolutions" your new resolution should appear now saying 60Hz [Mine is 1680x1050 so the resolution will of course vary]. Don't forget to click on the checkbox that says "Allow modes not exposed by the Display" otherwise it might not work.

3.png

2. Go to your desktop > right click > Personalize > Display Settings > Advanced Settings > click on the "Monitor" tab > click drop-down menu under "Scree Refresh Rate" and Voila! 60Hz is now available!

4.png

Now click Apply and OK.

3. Now we'll work for the 800 x 600 resolution, this is the default Battlefield 2 opens with [i'm sure all the battlefields do so as well] so it's necessary to make a custom resolution for the 800 x 600... So go to Go to your desktop > right click > Personalize > Display Settings > lower your resolution to 800 x 600 click apply and OK.

5.png

Now open your Nvidia Control Panel or the "NVIDIA PhysX Properties" and go to the left part and click where it says:

"Manage Custom Resolution" > click on "Create" [Notice that now is for the 800 x 600 resolution]

Change default GDI refresh rate to 60 > Click on "Test" and it will ask you something, just click OK, the screen will flash once, then click OK again:

6.png

Now under "Custom Resolutions" your new 800 x 600 resolution should appear now saying 60Hz like this:

7.png

Don't forget to Save!

4. Time for Direct Refresh in case the Custom resolution didn't work for you, this program will basically force your resolution to the refresh rate you want once a program changes it, in this case, Battlefield 2, which changes resolution to 800x600 @ 60Hz when opened, this little gem will force it to 60Hz whether it likes it or not! So, moving on, just open it directly [yes pic shows the obvious :) ] and open DirectRefresh.exe from the RAR file, no need to extract it. Now a window will open showing a lot of resolutions, just change the "0" to a "60" [without quotes of course] on the 800x600 and on the resolution you use [in my case 1680 x 1050], make sure the check-box that says "Save settings on Exit?" is checked, now after you've done the changes close the window, and as you'll notice it will remain on your taskbar, and it should stay there, at least until you're done playing Battlefield 2...

8.png

And that's it!!! Hope it works for you guys! :)

9.png

Edited by Cujucuyo
Link to comment
Share on other sites

Just in case anyone is wondering I'm using Driver 180.84 for Vista 32-Bit on a GeForce 8600m-GT. My Specs are underneath my Username.

Link to comment
Share on other sites

BTW Battlefield 2142 needs a resolution of 1024x768@60Hz so make sure you make a custom resolution for it on Nvidia control panel.

Edited by Cujucuyo
Link to comment
Share on other sites

Hi, I have been having this problem for about a year now.

Ive seen a lot of fixes that are suppose to fix this but have not. Im hoping this is real.

I see we have the same vid card. How did you get that driver version to run for your card, 180.84, when I try to install it says no hardware matches this driver version. I have the 8600m GT.

I have no custom resolution option in my nvidia control panal. I have driver version 179.48, the latest one from nvidia website.

If you can help please let me know. I have been having to connect to an external moniter just to start and it gets so annoying, specially with a game that crashes to desktop so much.

I tried to use the direct refresh, however all that does is keep my resolution at 800x600 after the game crashes at start-up.

Link to comment
Share on other sites

I downloaded NVTweak and was able to get the manage custom resolutions in my nvidia control panel. Did every step in your post, and still nothing. If you actually got this to work I would love some help if you dont mind. But I really dont know what I could be doing wrong. I even changed the 0 in "GeneralSettings.setLCDDisplayModes 0" to a 1, as suggested in another forum, the guy said doing that, along with the custom resolution will work, it didnt. I tried with it set to 0 and 1, nothing. :)

Link to comment
Share on other sites

Hi mate, I'll be more than glad to help you! :) Try downloading and installing PhysX and try the resolution mode on the control panel now without changing any values other than the refresh rate to 60:

http://www.nvidia.com/object/physx_8.09.04_whql.html

As for the 180.84 Driver you need to follow the instructions here:

http://forums.laptopvideo2go.com/index.php?showtopic=9243

9b8f423f.jpg

Basically you download the Driver and the Modded INF > Extract the driver once you've download it [at any location] > Download modded INF and replace original INF in extracted folder [basically just copy and paste on the extracted driver folder and it will prompt you if you want to replace the file, select yes] > Install & restart your computer. Done!

Hopefully PhysX is the missing part of the puzzle.

Edited by Cujucuyo
Link to comment
Share on other sites

  • 2 weeks later...

Update!

The fix works with Dox's Customized 180.84.1:

http://forums.laptopvideo2go.com/index....t=0&start=0

Can some people report if this fix worked or didn't work on "X" driver? Thanks!

Link to comment
Share on other sites

  • 1 month later...

I?m experiencing the same problem and tried just about every solution I could find on the internet.

Here are my specs:

HP Pavilion dv9700 Notebook PC

64-bit Vista Home Premium Operating System

Intel Core2 Duo CPU T9300 @ 2.50 GHz

4.00 GB RAM

NVIDIA GeForce 8600 GS 512Mb video card

I purchased the Battlefield 2 Complete Collection (it comes with the v1.41 patch). I loaded it in compatibility mode (Windows XP SP2). When I launch it, the splash page appears, the screen goes black, and then immediately crashes to the desktop. When I launch the game windowed, it still crashes but I get the following error message:

?Debug assertion failed!

Version: 1.1.2965-797.0 Build date:2006-9-26 18:53

Module: RendDX9

File: D:\Aphrodite\BF2_1.4\Code\BF2\RendDX9\VideoOptions.cpp

Line: 234

Text: Unknown DynamicOption value 800x600

Current confile: ?

Here?s what I?ve tried thus far:

1. Updated nVidia driver v179.48 (released 11 Feb 2009)?didn?t work

2. Disabled UAC?didn?t work

3. Ran in compatibility mode (Windows XP SP2/as administrator)?didn?t work

4. Ran full screen and windowed?didn?t work

5. Deleted ?Battlefield 2? folder in ?Documents?. ?didn?t work

6. Forced 60Hz with both DirectRefresh and nVidia Control Panel (per your instructions) ?didn?t work

7. Replaced deleted ?Battlefield 2? folder in ?Documents?and changed AudioSettings.setProvider "software" to AudioSettings.setProvider "hardware" in ?Audio.con? file in Documents\Battlefield 2\Profile\Default?didn?t work

8. Disabled integrated sound card?didn?t work

9. Installed the Vista64 180.84.1 driver?didn?t work

I don?t know what else to do. I can play CoD4 and CoD5 fine. I can even play Crysis (at lower settings), but you can have all those games; I NEED MY BATTLEFIELD 2!

Please help. Cujucuyo, you seem to know what you're doing. Your assistance is greatly appreciated.

Link to comment
Share on other sites

Download Direct Refresh [ http://rapidshare.com/files/199560878/DirectRefresh_1.2.zip ] and change ALL the values to 60, also, download "Refresh Force":

http://rapidshare.com/files/229358054/reforce.zip

Under Frequency change all the value to 60 on all the resolutions [why? just in case]... make sure that under "Monitor to modify" you have the ACTIVE monitor selected, or you can do what I did and go ONE BY ONE of all the ones there to select, and change the frequency value of all of the resolutions on all the options to 60 [again, to be on the safe side]. :)

Let me know if it works. :)

Link to comment
Share on other sites

  • 2 months later...

I'm having this issue and have the same graphics card the OP has. In my nVidia Control Panel, I have no option to "Manage Custom Resolutions". So I don't know what to do. :) I will try Dox version of the 180.84.1 drivers and maybe I'll get that option in the control panel.

Does anyone know of any type of registry hack or something that will allow me to see the "Manage Custom Resoltions" item in the nVidia Control Panel tree? Thanks.

Link to comment
Share on other sites

  • 1 month later...

I'm having this issue and have the same graphics card the OP has. In my nVidia Control Panel, I have no option to "Manage Custom Resolutions". So I don't know what to do. :) I will try Dox version of the 180.84.1 drivers and maybe I'll get that option in the control panel.

Does anyone know of any type of registry hack or something that will allow me to see the "Manage Custom Resoltions" item in the nVidia Control Panel tree? Thanks.

180.84 and Dox's version seem to be the only ones that work for this fix as they're th eonly ones that allow custom resolutions in 60Hz, I'll try a few other right now. The 180.84 is prone to random freezes which rarely happen but are still very annoying.

Edited by Cujucuyo
Link to comment
Share on other sites

~UPDATE REGARDING PATCH 1.50~

The resolution in which BF2 opens due to patch 1.50 now is 1024 x 768 @ 60Hz! Make Sure you make a custom resolution for it, otherwise it will NOT open!

8f3ba0f7.png

43fe051f.png

Link to comment
Share on other sites

  • 1 month later...
  • 3 months later...

Guys driver 196.34 [Vista 32-Bit is the OS I have] works very well for custom refresh rates [great driver, no errors, no BSOD, no flickering, etc], you just need to adjust the refresh rate manually to 60.01Hz and it will work with any resolution [check all the custom resolutions I managed to make], 70Hz-100Hz will work as well however 90-100Hz make the screen all fuzzy so I recommend you stick to 70Hz at most:

798654.png

Also, before I forget, BF2 didn't open unless I made a 1024 x 640 @ 60Hz resolution - No idea why, I checked my Video.CON file and it said that was the resolution it will open with, so give it a try!

Link to comment
Share on other sites

I forgot to log-in before I made that post ^^^ - dammit, lol.

Edited by Cujucuyo
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...