Jump to content
LaptopVideo2Go Forums

Toshiba P100 - 7900GS White Screen of Death


Guest Elile

Recommended Posts

I just installed Vista Ultimate on my Toshiba Laptop, installing the standard Nvidia mobile drivers from their site and using the modded nfo (179.48). Now, whenever i load windows it'll log in, show the desktop, then quickly blanks the whole screen white. Is this a possible hardware issue, or would rolling back the drivers to another version work.

cheers,

Elile

Link to comment
Share on other sites

Just try a different driver, mine does it with 185.XX driver. the black slowly filters out to white. Quite pretty, but rather annoying.

Link to comment
Share on other sites

:) ffs.. still not working.

Here are my specs:

fresh install Windows Vista ultimate (fully updated)

Toshiba Sat P100 SD802E - http://support.toshiba.ca/support/techsupp...productcontents

Intel® Centrino® Core? Duo Processor T2500 (2.0 GHz 667MHz FSB, L1 Cache 32KB/32KB L2 Cache 2MB)

upgraded to 2 sticks of 2G (4gb total) of 667 DDR2

Geforce GO 7900GS -256mb

These are the drivers i've tried, and have crashed to a white screen upon entering any game (WoW, L4D, HL2 etc...)

163.25

162.85

163.02

176.05

175.90

177.40

163.44

179.48

177.66

180.70

all resulting in instant crash.

My bios is updated to 4.5 (what toshiba has available) and i have updated my chipset from intel

all of my attempts have been with no usb devices, no firewall/virus, and with a freshly reformated and wiped hard drive. I've attempted all the drivers that go under my driver's ID, and still nothing runs!

I just dont get it, and i hope this doesnt mean my card is shot, as my warranty is up now (ended in august 2008)

Link to comment
Share on other sites

downloaded 3DMark06 to eliminate some possibilities.

the white screen goes up about when the test is starting and even in the 3dmark demo, however, the music/sound continues to run... its as if this white screen is a curtain, and the show is still going on behind it :)

help, or any possible explinations, other things i can try to test it, would be much appreciated.

Link to comment
Share on other sites

  • 2 months later...
Guest infernis

I also have kind of same problem. I have a P105-S9722 with the same 7900GS. My problem started when I updated my graphics drivers, I was using XP then.

The screen goes white and system locks down, I had to shut down from the power button. This happens mostly during running games like Civ4 or WOW, I assume using 3D driver is the problem. I loaded a fresh vista ultimate a month ago, I tried original toshiba vista drivers and modded new drivers, still no change... :)

Link to comment
Share on other sites

  • 11 months later...
Guest china_p100

I also have kind of same problem. I have a P105-S9722 with the same 7900GS. My problem started when I updated my graphics drivers, I was using XP then.

The screen goes white and system locks down, I had to shut down from the power button. This happens mostly during running games like Civ4 or WOW, I assume using 3D driver is the problem. I loaded a fresh vista ultimate a month ago, I tried original toshiba vista drivers and modded new drivers, still no change... :)

[/quot

I have a P100-222 7900GS

it will tune to white screen

the notebook will go to death .

win7 winxp are the same .

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...