Jump to content
LaptopVideo2Go Forums

Resolution and Color Fail


Guest Liman

Recommended Posts

Guest Liman

Hello, I've tried my best to solve this problem on my own, but I do not seem capable!

I am running Windows XP SP2 via bootcamp. I have a MacBook Pro. GeForce 8600M GT.

I've never had a problem before, but I am attempting to play Mass Effect and the configuration suggests I update my video drivers. Since they are dated 5/22/2007 I decided to go for it..

However, every driver I've tried installing from this website has given me the same problem. The display settings are locked at the lowest possible. Very low resolution, and 4 bit color. It looks really gross and it depresses me so. When I try to change them, it just resets itself.

I was looking around these forums and saw people mentioning nVidea control panel. When I try to open it (with the bad video driver installed) it doesn't seem to open.

I really don't know whats going! I've tried about 6 of different drivers and they all have the same problem (minus one that completely BsoD me).

Any help would be much appreciated!

Link to comment
Share on other sites

Guest Liman

UPDATE: I was looking through some forums and saw someone with the same video card as me that said the 176.75 driver was good. I tried installing it and it got rid of the resolution/color problems. However, when I try to open the nVidea control panel it says

The NVIDIA Display Panel extension cannot be created.

Possible reasons include:

Version mismatch. Reinstalling display drivers may solve this problem.

Also, Mass Effect still did not work, however I am beginning to think that might be a different problem, even though the config tells me to update my driver still.

Any help appreciated!

Link to comment
Share on other sites

Guest Thejoker

Those drivers are outdated, problems exist with those drivers in game and frame loss, u should try Dox's Optimized, version 182.05, which gives u great performance boost control panel and can wake from sleep :)

Greets the joker

Link to comment
Share on other sites

Sounds like you haven't even installed the previous drivers and it's just using the basic included driver.

Make sure you are using the modded inf, or use Dox's which has them included

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...