Jump to content
LaptopVideo2Go Forums
Sign in to follow this  
Guest Guest

Alienware M5750 MXM upgrade

Recommended Posts

Guest Guest

Hi all,

I have a Alienware M5750 and the Ati x1800 card die.

Has anyone tried Ati HD 3650 with this latop?

Share this post


Link to post
Share on other sites
Guest Elbit

I have a Xi 1546 with alienware 1.19W (I think it is the 5700 series) Bios, 2 x 2 GB DDR2-667 RAm with an HD 3650 GDDR3 256 and it works without problems

Share this post


Link to post
Share on other sites
Phnx

According to this page, it will work, but you will need to modify the heatsink

Edited by Phnx

Share this post


Link to post
Share on other sites
bautile

Hello,

I'm on the same boat. My lappy is the Special Edition Superman Alienware (AKA m5750/m5790 T7600, 4gb ram, mobility x1800, vista home premium AW1.09w bios) and have read extensively that the Amilo Xi's are basically the same laptop but just differ in branding. After reading through many people's success stories, I thought i'd give it a shot. I purchased my card from ebay and the first one resulted in a power on, caps keys light up, wireless light turns on when hardswitch is on "on" position and power works. However, the screen is blank, the gpu is warm but there is no signs of booting, just stuck on that blank screen. So i did some more reading and found out that its because the vbios of the card was not right (possibly power differences/requirements.) I noticed that the back of the card had an HP8530P sticker on it and i did some digging and found out that HP vbioses arent compatible with the AW/FS models and needs to be reflashed.

So I returned the first card, received the second one today, the gray chip that is the reason for the heatsink mod was chipped badly revealing a coil. HP8530P sticker on the back again (not the same card since i kept a copy of the first's serial number) and i tried it anyway. Turn on power, immediately laptop powered off. I though weird, i'll try from powercord (was on battery) booted again, all i hear is 2 seconds of a scratchy/squeaky sound, caps lights blink on and stay on this time, but screen is still blank and comp powers off. So I emailed the ebay seller and asked for them to check (like i asked in my first message) before they send the next one.

Share this post


Link to post
Share on other sites
Guest Elbit

Hi,

I bought it from mxm-update.

As Phnx said, I had to dremel the heasink a bit but it works without problems.

Share this post


Link to post
Share on other sites
Guest Elbit

Yes, they are not the cheapest. I bought mine there because I didn't find any seller for the card in europe but send them and email.

Share this post


Link to post
Share on other sites
bautile
i think we bought it from the same seller.

http://cgi.ebay.com/AMD-ATI-Mobility-Radeo...1QQcmdZViewItem

On the back of the card, it also has a label said "HP-8530P"

Yeah we did buy it from the same seller. I think the guy only has HP models though, I asked him to send me a nonHP (one without the sticker on the back) and he said he'll look into it so heres to hoping :)

Share this post


Link to post
Share on other sites
bautile

well thats fortunate for me... i just got my third one about an hour ago, and i guess its true what they say... third time is a charm... so im currently looking for the best drivers/possibly a better vbios as well

Edited by bautile

Share this post


Link to post
Share on other sites
facey

there are different card for 3650 and several different vbios. There are cards with red pcb and cards with green pcb. The HP cards have several different vbios also, there is one particular vbios from HP that does not contain the memory information ie 256mb gddr3, this vbios will not work, the card needs to be flashed in a different system

Share this post


Link to post
Share on other sites
Guest Guest

After I return the card to that seller, I bought another HD 3650 from ebay. The seller is located in TW.

The PCB board is Green color.

Plug in the card and it works like a charm.

Thank you for everyone in this forum~

Share this post


Link to post
Share on other sites
Pixel 6

Ok, what info do you need from me? lol.

I'm in the same boat. Did the heat-sink mod, and got the HD 3650 mounted. All the lights came on, hard drives spun up, but black screen and no BIOS. Put my other card back in and works fine... Albeit it's a toaster... the only thing this laptop didn't come with was a skillet.

Bought from Adds2it on Ebay. Ref # (#380134988473)

So, where do I go from here?

Alienware M5750 (5700R2 Series)

Bios Version 1.19

T7600 Core 2 Duo Processor

4 GB DDR2 Ram

2 Hard Drives (Western Digital Scorpio Black 320GB 7200rpm) Independent

(Windows MCE w/2 partitions & Ubuntu Jaunty 9.04)

Original Video Card ATI X1800

Attemped Card ATI HD 3650 (109-B3731-00B) The GREEN one

Thanks for any help!

- Pixel -

Share this post


Link to post
Share on other sites
facey

5750 should be the same as xi1546, there could be two vbios for the card there is a vbios which in radeon bios editor shows without having any memory information and the other which shows the memory as 256mb gddr3. If you have the version with no memory information you will not be able to boot the machine, I had to use an acer machine to sort that. If you have the other one you may have a start up bug which I also encountered, to solve this let the machine loop for a minute or 2 to heat up then power off and straight back on again and it should start.

Share this post


Link to post
Share on other sites
Niroy

Ok, what info do you need from me? lol.

I'm in the same boat. Did the heat-sink mod, and got the HD 3650 mounted. All the lights came on, hard drives spun up, but black screen and no BIOS. Put my other card back in and works fine... Albeit it's a toaster... the only thing this laptop didn't come with was a skillet.

Bought from Adds2it on Ebay. Ref # (#380134988473)

So, where do I go from here?

Alienware M5750 (5700R2 Series)

Bios Version 1.19

T7600 Core 2 Duo Processor

4 GB DDR2 Ram

2 Hard Drives (Western Digital Scorpio Black 320GB 7200rpm) Independent

(Windows MCE w/2 partitions & Ubuntu Jaunty 9.04)

Original Video Card ATI X1800

Attemped Card ATI HD 3650 (109-B3731-00B) The GREEN one

Thanks for any help!

- Pixel -

How does your Alienware works with WD scorpio black 320GB 7200? Does Alienware M5750 has VT6421A chipset? I heard this notebook internally is fully the same as Amilo Xi1526/Xi1546/Xi1554? I mean the motherboard.

I have Amilo 3438 and this hard drive (WD scorpio black) is not recognized cause of the old chipset. Now i wonder if Alienware has the same chipset on not and why scorpio black works on Alienware and doesnt work on 3438. Maybe Amilo Xi1526/Xi1546/Xi1554 will solve the problem?

P.S. Does anyone know his e-mail? I want to contact him cause maybe he'll never ever visit this site. For me it isn't shown, written "private"

Edited by Niroy

Share this post


Link to post
Share on other sites
Robin4

Ok, what info do you need from me? lol.

I'm in the same boat. Did the heat-sink mod, and got the HD 3650 mounted. All the lights came on, hard drives spun up, but black screen and no BIOS. Put my other card back in and works fine... Albeit it's a toaster... the only thing this laptop didn't come with was a skillet.

Bought from Adds2it on Ebay. Ref # (#380134988473)

So, where do I go from here?

Alienware M5750 (5700R2 Series)

Bios Version 1.19

T7600 Core 2 Duo Processor

4 GB DDR2 Ram

2 Hard Drives (Western Digital Scorpio Black 320GB 7200rpm) Independent

(Windows MCE w/2 partitions & Ubuntu Jaunty 9.04)

Original Video Card ATI X1800

Attemped Card ATI HD 3650 (109-B3731-00B) The GREEN one

Thanks for any help!

Is that an DDR3 version or an DDR2 version card?

- Pixel -

Share this post


Link to post
Share on other sites
Niroy

Ok. M5750 = M5790 = 5700i-R2 Yes?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...