Jump to content
LaptopVideo2Go Forums

Upgrading my Alienware laptop


Sathanous

Recommended Posts

Ok I'm having trouble upgrading my now dead graphics card... This is what I have:

AREA-51 M5500i-R3

AREA-51M 5550 R3 15.4" WXGA SILVER

N- CORE 2 DUO 2.00GHZ T7200 4MB 667MHZ

2 SAMSUNG 512MB DDR2 PC5300 SODIMM

SEAGATE 160GB 5400RPM SATA

8X DVD+/-RW NEC AD-5540A REV 1

NVIDIA GO 6600 256MB DDR1 MXM2

INTEL PRO WIRELESS 3945 A/B/G MINI-CARD LEAD-FREE

INTEL MOBILE INTEGRATED HIGH-DEFINITION AUDIO

MICROSOFT WINDOWS XP MCE 2005

And I pick up a 8600m GS off ebay (MacR)

And all I get is white screen that slowly fades to colored lines... so i tried updating the bios... a no go i get the same thing... course now i read i prolly need 2.06 bios... which i can't get off of thier site anymore.

Am i screwed? can anyone helps?

Thanks you.

Link to comment
Share on other sites

  • 1 month later...

do you see the Alienware Bios screen before the screen turns white? Also, is it turning white in Windows or before you enter Windows? ive had a TON of experience when upgrading my old alienware (i now have a XPS 1730 with dual sli 9800m gt's :) ). Ive upgraded my older Alienware m5500 to both a 8600m GS and a 8600m GT and have had similar problems with black screens. Mostly due to DX 10 support with Vista and incompatible drivers for XP.

Edited by TC Ozman
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...