Jump to content
LaptopVideo2Go Forums

INF v 4.004


mobilenvidia

Recommended Posts

293 changes to version 3 of my INF and it's time for a change :)

v4 has been made and now needs to be tested by any volunteers that are willing and able.

v4 INFs are based on the new 185.xx series INF, these use a new INF scheme, which should make INF modding easier in the future.

Spent 2 nights reworking the PCI_ID's to the new style, I'm very confident that Vista/Win 7 x86 and x64 will work as they should.

WinXP I'm not so confident on as for some reason nVidia changes the sections that the GPU's are in with Vista versions.

These INFs have NO tweaks added to them.

For now just interested in getting these to work with all GPU's

When installing you will get an error saying NVCPL.DLL can't be found.

This is a NVIDIA error and can be ignored, once you reboot after the install all is well.

NVIDIA's trying to run an App that only gets installed after the reboot.

The INFS are below, consider these beta hence not in the driver posts

These are for 185.68, but should work happily for other 185 series drivers as well.

Vista/Win 7 x86

Vista/Win7 x64

WinXP x86

WinXP x64

Feedback encouraged, WinXP x86 and x64 may need a little tweaking

If you have feedback be it good or bad, please please state what OS version you are using and whether it's x86 or x64, as the iNFs are different internally

INF v4.002 fixed:

All contain single quote on line

NVIDIA_DEV.06EC.01 = "NVIDIA GeForce G 105M'

V x64

Missing [commonDisplayModes_addreg__01]

INF v4.003 fixed:

WinXP x86 and x64 got some fixes, pretty confident now these should also work now

INF v4.004 fixed:

Small typo in WinXP x64

Link to comment
Share on other sites

Great! I'll probably wait until they've been tested though, but I'm looking forward to them!

Link to comment
Share on other sites

What problem with them!I can't download!!!

Link to comment
Share on other sites

Are those just for 185.x series, or do they work with 182.x series too?

Link to comment
Share on other sites

All contain single quote on line

NVIDIA_DEV.06EC.01 = "NVIDIA GeForce G 105M'

V x64

Missing [commonDisplayModes_addreg__01]

X x64: Sections 8-10 not defined.

Link to comment
Share on other sites

I still have the same problem with all 185.65 and later no mater .inf ver i use even the v4.001 ....image artifacts when changing from perf. 3D to perf 2D or low 2D frequency and opposite........any help??

Link to comment
Share on other sites

Just a silly nitpick: the English plural of PCI-ID would be PCI-IDs, not PCI-ID's (though we Dutch are very fond of the latter). (appears in ";PCI-ID's by www.laptopvideo2go.com")

Something I noted in the addreg sections: do "nvwgf2umx.dll" and "nvwgf2um.dll" need to be added twice? I don't really know how the registry settings work, but it seems redundant.

Finally, why isn't the "0x00004000" (replace after reboot if file is in use) flag used for every file? I guess it still works alright, but it seems inconsistent.

And Teraphy is right about the single quote typo. Otherwise, it looks very clean - good job!

Link to comment
Share on other sites

I still have the same problem with all 185.65 and later no mater .inf ver i use even the v4.001 ....image artifacts when changing from perf. 3D to perf 2D or low 2D frequency and opposite........any help??
Just a silly nitpick: the English plural of PCI-ID would be PCI-IDs, not PCI-ID's (though we Dutch are very fond of the latter). (appears in ";PCI-ID's by www.laptopvideo2go.com")

Something I noted in the addreg sections: do "nvwgf2umx.dll" and "nvwgf2um.dll" need to be added twice? I don't really know how the registry settings work, but it seems redundant.

Finally, why isn't the "0x00004000" (replace after reboot if file is in use) flag used for every file? I guess it still works alright, but it seems inconsistent.

And Teraphy is right about the single quote typo. Otherwise, it looks very clean - good job!

ID's, IDs I have no ideas ('s) :)

The INF is as modified from NVIDIA's original, so there are some inconsistencies I can work on.

Main aim was to get it working first so that I can then mod it some more for enhancements.

I noticed nvwgf2umx.dl as well, but for sake of keeping things original kept it in there.

WinXP is still a work in progress, would like to not mod these at all, everyone should migrate to Win 7 and be done with it :)

Link to comment
Share on other sites

INF v4.002 fixed Teraphy's noted typo's

Link to comment
Share on other sites

ID's, IDs I have no ideas ('s) :)

The INF is as modified from NVIDIA's original, so there are some inconsistencies I can work on.

Main aim was to get it working first so that I can then mod it some more for enhancements.

I noticed nvwgf2umx.dl as well, but for sake of keeping things original kept it in there.

WinXP is still a work in progress, would like to not mod these at all, everyone should migrate to Win 7 and be done with it :)

Yeah, the only reason I'm so acutely aware of the deal with apostrophes is because they're used differently in Dutch :P

I don't always agree with it either.. I mean what if you want to pluralize something like the letter 'a'?

as <- weird but presumably correct

As <- looks better but might be confusing in context

a's <- wrong, Dutch way of doing it

'a's <- probably right, but annoying

Anyway yeah, apostrophes are used for possessive forms: "Pieter's inf", "Greeneyes' inf"; but never for plurals.

Sorry if treating this like a serious issue comes across as pompous, I just thought it looked weird ...

Is the WinXP inf significantly different? I could give it a look over too. (though I don't think you really need my help with people like Teraphy around)

Edited by Ver Greeneyes
Link to comment
Share on other sites

INF modding is just monotonous work, mistakes easily creep in, especially in the XP case where I have to allow for so many variables :)

Just need some more time to go through and iron things out.

The new scheme is a lot better on the eye

Link to comment
Share on other sites

INF modding is just monotonous work, mistakes easily creep in, especially in the XP case where I have to allow for so many variables :)

Just need some more time to go through and iron things out.

The new scheme is a lot better on the eye

Lazy.... :unsure:

In all seriousness.. good job.. :) tis a ton of work for one person. :P

Everything in the INF starts looking the same after working on 'em a while. The new scheme is laid out better and makes more sense. Still don't get the point of the control panel in a separate installer though.

Link to comment
Share on other sites

The whole CP in the installer makes sense, could do with better compression though.

Keep it nice and tidy

Link to comment
Share on other sites

Right click and 'Save link as' or what ever IE uses to save links :)

Link to comment
Share on other sites

Works fine here, any 3rd party apps causing this to happen ?

Link to comment
Share on other sites

Guest Guest

I can't download them with any tools!I think it's caused by the IP restrictions,I am in CHINA,hope you can solve the problem!I like your drivers very very much!

Link to comment
Share on other sites

So are you having trouble with drivers ? which are *.exe

Or the INFs which are *.inf

There is not much I can do, it works for the vat majority of people.

Your ISP or Work might be blocking exe's and/or INFs.

Link to comment
Share on other sites

Updated WinXP x86 and x64 to v4.003

Link to comment
Share on other sites

Many thanks for XP version.

For those of us making a living with graphics software such as ADOBE CS4 Photoshop, we need a stable platform (I know vista is great but not for me) to keep going. I'll probably switch to Windows 7 once it is verified that there are no problems with Adobe's suite of graphic products.

Until then, I extend my thanks to you and Dox for keeping us poor XP users up-to-date.

Link to comment
Share on other sites

Guest Guest

I could download your drivers when the download address is beginning of www.laptopvideo2go.com,for example the 185.68?s address is www.laptopvideo2go.com/nvidia/185series/18568_vista.exe,I can download this driver。BUT when the address is beginning of files.laptopvideo2go.com,for example the dox 186.68?s address is files.laptopvideo2go.com/Dox/Vista/Vista_185.68.exe,I can't download it。So I can't download the INF V 4.003;because it's address is beginning of files.laptopvideo2go.com;wish you could solve the problem;Thanks!!

Link to comment
Share on other sites

AGAIN :)

Are these just for 185.x or do they also support 182.x drivers?

Thanks for answering this time :)

Link to comment
Share on other sites

.......

These are for 185.68, but should work happily for other 185 series drivers as well.

.....

AGAIN :P

Are these just for 185.x or do they also support 182.x drivers?

Thanks for answering this time :)

As per first poat, I modified yesterday after you asked me the first time :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...