Jump to content
LaptopVideo2Go Forums
Sign in to follow this  
edg322

Cannot install Broadcom drivers on Vista/BootCamp

Recommended Posts

edg322

I've been at this for hours. Windows encounters a problem every time I try to install Broadcom drivers, with every single driver I try. Device Manager doesn't even show the name of the network device; it just says Unknown. I disable, reboot, try another driver, same problem. I uninstall, reboot, try another, same problem. I've tried using the .inf that came with BootCamp, then copying newer .dll files into System32. Nothing is working. Choosing Have Disk then finding an .inf and selecting any of the devices there does not work either.

I have a new MBP, ran BootCamp on it and installed a Vista upgrade. Vista upgrade worked fine, *at first*. And that is the frustrating thing in all this. (Yes, you can do a Vista upgrade on a MBP in BootCamp... what happens is you don't enter your product code the first time, run the clean install, load Vista, then when you're all set up but not activated yet, run the install/upgrade from the Vista disk a second time. Only this time, you choose to upgrade and you enter your product code, and that actually works.)

Alright I'm getting to the frustrating part. When I first did the Vista install, I didn't have any problems whatsoever. My wireless connection was fine, and I even played with it for about a day, before I decided ok I need to get this activation going. I ran the Vista upgrade the second time, and everything went without a hitch. Everything, that is, except this wireless network device.

After the Vista activation, I had no internet, no wireless connection at all. Couldn't find the network that I was just on prior to running the activation upgrade.

So I ran the BootCamp drivers again, as I did after the first Vista clean install. But this time around, I started getting an error: Something about the file bcmwlcoi.dll has a problem and it won't work. No idea why it wouldn't work the second time around. This Vista 'upgrade' was simply a re-copy of the initial Vista install, just to trick the activation into thinking I was doing an 'upgrade'.

But this second time, the BootCamp drivers fail. I completely uninstall the Broadcom drivers, then re-run Bootcamp drivers, it still fails. I connect thru ethernet cable and download various Broadcom drivers (found here, thanks), and none of them work. Every single time now it just says the driver install fails and check with the manufacturer. I've run out of options but to come crying here looking for help or advice. Did I mention - I don't even know for sure now if I have a Broadcom device, I just assumed it because that's what everyone seems to have in these new MBPs, plus when I try to install a driver it seems to *think* it's a Broadcom. How can I check that for sure? Network Device Properties just says 'Unknown', no details.

Thanks

Edited by edg322

Share this post


Link to post
Share on other sites
mobilenvidia

I had the reverse issue in getting my Broadcom WLAN to work Leapord.

I did manage it once, but after hours of frustration gave up on Leopard all together.

Does your Vista upgrade allow you to search for drivers automatically ?

If so let it search.

You've tried a driver with an installer ?

Dell drivers have an installer, you may need to go there.

Any notebook with the Broadcom chipset option (nearly all) will have a driver.

To get the latest one, pick a latest laptop series.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...